Ubuntu

french symbols map for macintosh is incomplete

Reported by Étienne BERSAC on 2006-03-24
32
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
High
Unassigned

Bug Description

Hello,

I reported similar bug, but this was refused/unfixed.

I must say something before : currently, keyboard config on mac is prettry ugly, especially for french users : gfxboot does not allow language and keymap selection. And even if user select macintosh/fr from the keyboard config applet in Gnome, the keymap is unusable : no [, |, ~, }, € and other important symbols. This keymap also do not allow VT switching which may be very critical.

I saw a lot of french mac user giving up using Ubuntu on their mac because of this problem.

This is why i ask for a quick inclusion in dapper of an updated symbols map for french user.

The symbols map is available at http://bersace03.free.fr/pub/Linux/xkb-mac/fr and must replace /etc/X11/xkb/symbols/macintosh_vndr/fr

I also mention that using lv3:lwin_switch make VT switch impossible on mac. This must be disabled for mac, at least french one.

Étienne.

Laurent Bigonville (bigon) wrote :

Yes there is problems with french keymap for macintosh users.
But the last upstream version of xkeyboard-config includes this symbols file. The problem is elsewhere.

The correct url is: http://bersace03.free.fr/pub/Linux/xkb-mac/fr

Salut,

> But the last upstream version of xkeyboard-config includes this
> symbols file. The problem is elsewhere.
*this* ??? I'm sorry, but the symbols map shipped with does not allow
neither VT swicthin nor use of Alt+Shift and Shift+Alt.
Here is diff http://bersace03.free.fr/pub/Linux/xkb-mac/fr /etc/X11/
xkb/symbols/macintosh_vndr/fr

143a139,149
 > // Begin modifier mappings
 > key <LWIN> { [ Alt_L, Meta_L ] };
 > key <LFSH> { [ Shift_L ] };
 > key <LCTL> { [ Control_L ] };
 > key <LALT> { [ Mode_switch ] };
 > key <RMTA> { [ Meta_R ] };
 > key <RTSH> { [ Shift_R ] };
 > key <RCTL> { [ Control_R ] };
 > key <RALT> { [ script_switch ] };
 > // End modifier mappings
 >
202,216d207
< // Begin modifier mappings
< key <LWIN> { [ Alt_L, Meta_L ] };
< // key <LMTA> { [ Meta_L, ] };
< key <LFSH> { [ Shift_L ] };
< key <LCTL> { [ Control_L ] };
< //key <LALT> { [ Mode_switch ] };
< key <LALT> { [ Mode_switch, Mode_switch ] };
<
< key <RWIN> { [ Alt_R, Meta_R ] };
< key <RMTA> { [ Meta_R ] };
< key <RTSH> { [ Shift_R ] };
< key <RCTL> { [ Control_R ] };
< key <RALT> { [ Mode_switch, Mode_switch ] };
< // End modifier mappings

This minor changes allow VT switching and Shift+Alt. This is
important. If you know how to synchronise each pair of right and left
key, the keymap will be very near from complete.

> The correct url is: http://bersace03.free.fr/pub/Linux/xkb-mac/fr
Thanks you, i made a typo. :(

Étienne.

oups.. you're right, nerver mind

The keyboard works as expected with this new symbols file

Yeah, I noticed the problem too.. I think I wrote the fixed symbols file a while ago after a very painful time trying to understand xkb :) Oh and deciding that some things can't be fixed... like legacy applications using the pre-xkb stuff and assuming alt is alt and cannot be used to compose things ...

However, at some point, the modifiers setting got commented out and it got broken.

In fact, what should be done is that all "Mac" keymaps should be consolidated to have a common options driving how the modifiers and how iso-level-3 works. Either the "macos" way or some different way we could use (with some other key than Alt for ISO level 3 shift) for linux that is more legacy-X11 friendly and have all the symbols file just include that common stuff but I don't have time to deal with that now.

Correction, I wrote _a_ fixed symbols file which isn't this one. Mine uses ISO Level 3 Shifting instead of Mode_switch as suggested by the xkb folks and is included in upstream xorg as macintosh/fr.

Hello,

> Correction, I wrote _a_ fixed symbols file which isn't this one. Mine
> uses ISO Level 3 Shifting instead of Mode_switch as suggested by
> the xkb
> folks and is included in upstream xorg as macintosh/fr.
Youpie !

That's exactly what we need. I did not understand why use Mode_switch
instead of ISO_Level3_Shift. Where is this keymap to test it ?

Étienne.

Here it is. I though it made it into X CVS a while ago but it looks like it never actually did.

Hello,

Please do not include another non working symbols keymap. You should use ISO_Level3_Shift, ISO_Level3_Shift in order to have both Alt+Shift and Shift+Alt working. Test it before. Your symbols map and it does not work on my iMac G5 rev C (dapper). Here is some xorg.conf snippet :

 Option "XkbRules" "xorg"
 Option "XkbModel" "macintosh"
 Option "XkbLayout" "fr"
# Option "XkbOptions" "lv3:lwin_switch"

I test the latest symbols map shipped with xkeyboard-config. It allow
extra character, but neither VT switching nor wether Alt+Shift or Shift
+Alt.

All other symbols map use Mode_switch instead of ISO_Level3_Shift. I
don't know why Mode_switch exists. Comments on
symbols/macintosh_vndr/apple are interesting. Especially about Help and
"laptop_bad_switch".

If Benjamin tell how to use ISO_Level3_Shift, this should be good, else,
we should include the tiny changes I propose in the report.

Étienne.

Did you try out the map I attached ? Does it work ? It used to but it may need fixing for recent xkb's...

Hello,
> Did you try out the map I attached ?
Yes, i'm sure

> Does it work ?
No. The effect was the same as when lv3:rwin_switch option was enable
and combining keys with right Command.

> It used to but it may need fixing for recent xkb's...
When defining symbol, we usualy define 4 symbols per key. Which
normally are for event <key>, <Shift>+<key>, <Modifier>+<key> and
<Shift>+<Modifier>+<key>

What is that modifier ? Mod1 ? Mod2 ? ... Mod5 ? Am i completely wrong ?

according to symbols/apple, some laptop broke the keymap and need
Mode_switch is this now the case for all new Mac (including iMac G3) ?

Really, i don't know, and an xkb guru is very welcome.

Étienne.

On Mon, 2006-03-27 at 23:06 +0000, Étienne Bersac wrote:
> Public bug report changed:
> https://launchpad.net/malone/bugs/36492
>
> Comment:
> Hello,
> > Did you try out the map I attached ?
> Yes, i'm sure
>
> > Does it work ?
> No. The effect was the same as when lv3:rwin_switch option was enable
> and combining keys with right Command.

Hrm.. I'll have a look as soon as I manage to dig out my old powerbook
with a french kbd

> > It used to but it may need fixing for recent xkb's...
> When defining symbol, we usualy define 4 symbols per key. Which
> normally are for event <key>, <Shift>+<key>, <Modifier>+<key> and
> <Shift>+<Modifier>+<key>
>
> What is that modifier ? Mod1 ? Mod2 ? ... Mod5 ? Am i completely wrong ?

ISO_Level3_Shift

> according to symbols/apple, some laptop broke the keymap and need
> Mode_switch is this now the case for all new Mac (including iMac G3) ?

No idea what this is supposed to be about.

> Really, i don't know, and an xkb guru is very welcome.

This bug is more than confirmed. Does those fixes posted here fix the problem? Can this be sent upstream?

Changed in xkeyboard-config:
status: Unconfirmed → Confirmed

Hello,

xkeyboard-config 0.8-5 does not allow VT switching. Please use
bersace03 one which contain very few enhancement to allow VT
switching and Option+Switch equal to Shift+Alt.

For now, don't try using ISO_Level3_Shift, that's obviously out of
our skills (except Benjamin Herrenschmidt maybe), and should cover
all macintosh_vndr symbols maps.

Let's fix quickly this bug by using http://bersace03.free.fr/pub/
Linux/xkb-mac/fr

Wish we will be able to use ISO_Level3_Shift in the furure.

Étienne.

Hello,

I improve a lot the symbols map. It is now almost complete except a few symbols like cross, double cross, apple logo, f oblique, wave equal, single left and right quote and others which I don't find the symbol name in english.

I corrected some symbols and added ™, º, π, Π, Ω, δ, Δ, ‰, ≤, ≥, ∫, ∞, … and ≠. I may forgot one or two new symbols. I follow OS X placement of symbols.

I'm definitively sure of my modifications. I review a lot the symbols map. I strongly advice to use this. Even if the perfect solution would be to use ISO_Level3_Shift.

Please use http://bersace03.free.fr/pub/Linux/xkb-mac/fr which add VT switching, Shift+Alt support and a bunch of special character in the keymaps. This time this is a quite big improvement.

Thank you.

Étienne BERSAC (bersace) wrote :

Hello boys,

I updated my symbols map now including †, ‡, “, ”, ‘, ’, Ÿ, ∑, √ and Ø. Still missing kerned fi and fl, apple, etc. Some problems with em and en dashes with MoL.

This symbols maps is almost complete. Please include it in xkeyboard-config.

Changed in xkeyboard-config:
assignee: nobody → tfheen
Matt Zimmerman (mdz) wrote :

Tollef, what's happening with this bug?

description: updated

I use the Étienne's keymap. It's great ! Especially for œ, [, … that i'm using often...

Hello,

> I use the Étienne's keymap. It's great ! Especially for œ, [, …
> that i'm
> using often...

Do not forget to mention that reinstalling ubuntu solved your problem
with Gnome keep setting your keymap to PC 104 fr.

Étienne.

I can confirm that this keymap works great, i'm using it with a usb mac keyboard plugged on a PC.

It should be included as soon as possible!

> It should be included as soon as possible!

This bug report is very slowly handled. So, I guess the new keymap will be put in upstream for Edgy Eft, or Edgy Eft +1…

Hello,

> I can confirm that this keymap works great, i'm using it with a usb
> mac keyboard plugged on a PC.
>
> It should be included as soon as possible!

thank for your comments Sébastien :)

I submit this symbols map to xorg ( https://bugs.freedesktop.org/
show_bug.cgi?id=6382 ) and xfree86 ( http://bugzilla.xfree86.org/
show_bug.cgi?id=1574 ).

When does this problem be solved ??? I'm going tired to see that for
several month, i'm fighting to get a proper keyboard support and
things are very lazy. First i suggested the best symbols maps
available, then i improve it to fully support keyboard. What else is
needed ????

I understand that we are in freeze time, but such files are used and
tested, and aren't supposed to instability like a compiled driver. As
dapper is a long term support release, please consider complete the
upgrade to better support of this keymap. This will save a lot of
problems on forums and mailing list !

I'm quite fed up with this file not being updated. That just cause
user to switch back OS X or make linux an OS that does not support
keyboard without opening a terminal :(.

Étienne.

There was irony in my previous post…

Hello,

> There was irony in my previous post…

Okay, i prefer … That subject is not a joke.

See bug #12368 , this was the first time is signal this problem and
it's still unresolved. That's a mess.

Étienne.

Sebastien Estienne (sebest) wrote :

Hello, i have a new macbook, and i noticed that 2 keys are swapped:
"@/#" and "</>"

i and know how to cleanly handle this difference between the macbook keyboard and the full keyboard

any idea?

Zhares (launchpad1) wrote :

It seems Apple keeps inverting this 2 keys again and again. There should be a separate keyboard model for the machines that are reversed. I've got the impression that laptop keyboards have those keys in the other way of usb and bluetooth keyboards.

On Fri, 2006-08-11 at 16:23 +0000, Zhares wrote:
> It seems Apple keeps inverting this 2 keys again and again. There should
> be a separate keyboard model for the machines that are reversed. I've
> got the impression that laptop keyboards have those keys in the other
> way of usb and bluetooth keyboards.

I think there is a way to know wether it's an ISO or not (location of
those 2 keys). In the ADB code, afaik, we have something to detect taht
and re-invert them from the driver to make things consistent :)

Ben.

Étienne BERSAC (bersace) wrote :

Hi,

The keyboard map hasn't been updated. How long have french user to wait before having a decent keymap ??? Debian seems to rework xkb-data, but that's not usable for edgy.

How long ???

effraie (effraie) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

illovae and i are working to include a modified package in a third part
repository, for french user.

Étienne Bersac a écrit :
> Hi,
>
> The keyboard map hasn't been updated. How long have french user to wait
> before having a decent keymap ??? Debian seems to rework xkb-data, but
> that's not usable for edgy.
>
> How long ???
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFFOd8pDZrS/Pzxy5oRAjD9AKChlCWNnJ9kuz5qECg0Yx4CTX1whQCePRoE
MOX+HLDL3QSWksA5eZhsa4Y=
=e82D
-----END PGP SIGNATURE-----

Étienne BERSAC (bersace) wrote :

Hi all,

We have very very good news at xkeyboard-config front. debian-powerpc guys did a really good job or reworking xkeyboard-config in order to support mac (both ppc and intel).

However, the new keymap lake special character support like ™, …, –, ≤, ≥, ≠, and a lot of more or less useful character. I included almost all of special characters from OS X keymap in the keymap i published at http://bersace03.free.fr/pub/Linux/xkb-mac/ .

I wish this changes being integrated into the new keymap.

Thanks

Hi all,

xkb update fixed a lot of things for macintosh users and french one especially. However, the symbols map is still very incomplete compared to PC105 one or Mac OS X one. It lakes about 20 symbols (™,…,≤,≥,“,”,‘,’,†,‡,π,Π,δ,Δ,♦,∫,∞,÷,≠, etc.).

I wrote an updated symbols map for the old xkb (0.8). I updated this file for xkb 0.9. It works nice on MacBook, iBook G4, iMac G3 and iMac G5. I haven't tested on other devices, but get happy feedback from ppc users without knowing which box they were running. Also, this is just an update of the current symbols map, not another from scratch symbols map. So it don't change the default behaviour, just complete it !

Please consider include it.

Thanks,
Étienne.

Sure if you attach the patch - I could consider it:)

Created an attachment (id=8590)
Updated fr symbol map

This is the awaited french symbol map fro macintosh. Replaces /etc/X11/xkb/symbols/macintosh_vndr/fr

Oops. Sorry ;)

Updated, thanks

Étienne BERSAC (bersace) wrote :

Hi,

The new xkb-data has improved a lot french keyboard support. Thanks to debian-powerpc guys. The configuration bug (pc105 instead of macintosh) is fixed, the modifier bug (no VT switch is fixed) and minimal character set is retrivable.

However, there is still two bugs :

 1. The default config does not allow to access third level since Mac keyboard doesn't have Alt Gr key. Setting right logo as third level modifier fix that. This should be the default (this setting works either on ppc or mactel or laptop or desktop).

 2. The symbols map is still incomplete.

I attached the almost complete symbols map updated for the new xkb-data. It include support for ™, …, ≤, ≥,‰ and tons of other symbols. All are consistent with Mac OS X symbols map.

Please consider using this.

Thanks.

Étienne, there are several problems with your patch:
  - Comment added at the beginning is wrong, it does not document
    applied changes: EuroSign, oe and OE were already present.
  - You replaced acircumflex and Agrave by doubledagger and Greek_OMEGA
    in <AC01>, but previous key definitions are much more useful for
    French speaking people.
  - Same with <AC11>, ucircumflex is wrongly replaced by per-mille sign.
  - Why did you add Greek letters? They are useless for most people,
    and you may need those free slots if you want to add other symbols.
  - <AB01> uses undefined symbols guilsinglleft and guilsinglright.
  - <BKSP> is redefined, which means that Ctrl+Alt+Backspace does no more
    kill X.
  - Key definition for <KPDL> has been dropped.

CVS repository can be browsed online at
http://cvsweb.freedesktop.org/xkeyboard-config/xkeyboard-config/symbols/macintosh_vndr/fr

> - Key definition for <KPDL> has been dropped.
Sorry, this one is my fault.

> CVS repository can be browsed online at
> http://cvsweb.freedesktop.org/xkeyboard-config/xkeyboard-config/symbols/macintosh_vndr/fr

Étienne, you could get CVS revision 1.4 of this file, and add the new
definitions you need. This way, there will be no unwanted changes.

Hi,

This map is as close as possible to the Mac OS X one. Users switching to X11 wait a similar keymap. Xorg symbols map changes affects old (or dual booting) Mac OS X users, not PC users. Also, the real difference between OS X and mine is that Caps then 'ç' give Ç, not 'ç'. In OS X, you must use Option + ç. There is some symbols i missed (like the 'apple' symbol).

> - Comment added at the beginning is wrong, it does not document
> applied changes: EuroSign, oe and OE were already present.

I didn't patch the file, since i branched it earlier.

> - You replaced acircumflex and Agrave by doubledagger and Greek_OMEGA
> in <AC01>, but previous key definitions are much more useful for
> French speaking people.

acircumflex is accesible using circumflex key then a key. Like for ô and û. Agrave is still accessible with Caps then 'à', as expected.

> - Same with <AC11>, ucircumflex is wrongly replaced by per-mille sign.

The same. ‰ is consistent with %.

> - Why did you add Greek letters? They are useless for most people,
> and you may need those free slots if you want to add other symbols.

Mac OS X did add them. These greek letter are often use in math (π, Π, δ and Δ).

> - <AB01> uses undefined symbols guilsinglleft and guilsinglright.

You mean ‘ and ’ ?

> - <BKSP> is redefined, which means that Ctrl+Alt+Backspace does no more
> kill X.

This is a bug. I can't reproduce it. Ctrl+Alt+Backspace works fine on MacBook.

Created an attachment (id=8593)
Clean up regular patch.

Regular cvs diff for patching the source which clean up useless lines and comments. ChangeLog entry :

 * Drop useles lines for RTRN, BKSP, CAPS, etc.
 * Add comments for my modification and drop useless comments concerning old modifier mapping.

Hi,

I attached a regular patch (cvs diff) fixing the fix. It's a "clean up" patch. sorry. Here is the ChangeLog entry.

 * Drop useles lines for RTRN, BKSP, CAPS, etc.
 * Add comments for my modification and drop useless comments concerning old modifier mapping.

Please consider it.

Étienne.

> This map is as close as possible to the Mac OS X one. Users switching to X11
> wait a similar keymap.

You are free to make this layout similar to Mac OS X if this is what French
users are expecting, but in general I do not buy this argument, otherwise we
would also want to mimic Windows layouts on x86.

>> - <AB01> uses undefined symbols guilsinglleft and guilsinglright.
>
> You mean ‘ and ’ ?

No idea, I do not know these symbols ;)
They seem to come from the TeX world, but X symbolic name is different.
Your file contains the following definition:
    key <AB01> { [ w, W, guilsinglleft, guilsinglright ] };
Can you please tell which Unicode codepoints these 2 symbols refer to?

Étienne BERSAC (bersace) wrote :

Hi,

This symbols map has been commited upstream :D (see https://bugs.freedesktop.org/show_bug.cgi?id=9865 ) !!!

I wish ubuntu will include it as soon as possible. At least for '™' and '…' chars which are very useful.

Hi,

‘ is U+2018 LEFT SINGLE QUOTATION MARK
’ is U+2019 RIGHT SINGLE QUOTATION MARK

I guess the code is sent with the symbols in the mail !

I do not have the authority to determine which combinaison provide which symbol. The only one authority i know is the Mac OS X symbols map. However, if there is a UNIX or X11 one to implement. Go for it. But please don't apply pc105 to macintosh ! Mac user will have to swap Command and Option to Logo/Alt+Gr and Alt when switching to Unix. That's already a pc105-ization of the keymap. I think that's a wrong idea.

Please explain the symbols you want to change.

Étienne.

> â** is U+2018 LEFT SINGLE QUOTATION MARK
    = leftsinglequotemark
> â** is U+2019 RIGHT SINGLE QUOTATION MARK
    = rightsinglequotemark

These symbols added on key w are already defined on key 4, that
sounds pretty useless.

> I guess the code is sent with the symbols in the mail !

You are right, but I am lazy ;)

> Please explain the symbols you want to change.

I do not intend to make any change, but am trying to prevent spurious
changes.

guilsinglleft and guilsinglright are:

2039 [‹] SINGLE LEFT-POINTING ANGLE QUOTATION MARK
203A [›] SINGLE RIGHT-POINTING ANGLE QUOTATION MARK

and, from NamesList.txt:

2039 SINGLE LEFT-POINTING ANGLE QUOTATION MARK
        = left pointing single guillemet
        * usually opening, sometimes closing
        x (less-than sign - 003C)
        x (left-pointing angle bracket - 2329)
        x (left angle bracket - 3008)
203A SINGLE RIGHT-POINTING ANGLE QUOTATION MARK
        = right pointing single guillemet
        * usually closing, sometimes opening
        x (greater-than sign - 003E)
        x (right-pointing angle bracket - 232A)
        x (right angle bracket - 3009)

I don’t see existing keysyms for them, so you'll have to use unicode keysyms, 0x1002039 and 0x100203a.

Oh, and symbols/bt already has these:

      key <AC05> { [ 0x1000F54, 0x1000FA4, 0x1002039, guillemotleft ] };
      key <AC06> { [ 0x1000F55, 0x1000FA5, 0x100203A, guillemotright ] };

Changed in xkeyboard-config:
status: Unknown → Confirmed
Tollef Fog Heen (tfheen) on 2007-03-30
Changed in xkeyboard-config:
assignee: tfheen → nobody
Romuald (romu70) wrote :

I confirm the problems remains with Feisty on my Macbook Pro.

Created an attachment (id=9985)
Updated french symbols map.

Hi,

I added ‹ and › to W key. Sorry for the long time …

Can you commit that one ?

Étienne.

Etienne, there are several differences (not only W) with the current CVS. Could you please have a look at what's there and commit a smallest patch if possible (including most probably only W - and anything you find suitable).

Thanks

Changed in xkeyboard-config:
status: Confirmed → Needs Info

feisty come with an invalid setup in xorg.conf.

I have to edit xorg.conf and change the following line:
Option "XkbOptions" "lv3:rwin_switch"
with
Option "XkbOptions" "lv3:alt_switch"

then everything is OK.

rwin_switch make layout unusable. Many symbols are not available, no VT...

Hi,

CVS 1.5 version for symbols/macintosh_vndr/fr is just fine. Thank you !

Étienne.

U r welcome:)

Étienne BERSAC (bersace) wrote :

Hi,

The upstream bug is solved. They merged with the proposed symbols map. I suggest to use latest xkeyboad-config as soon as possible (CVS configure.in state version 1.0 !).

Thanks,
Étienne.

Changed in xkeyboard-config:
status: Incomplete → Fix Released
Timo Aaltonen (tjaalton) wrote :

Hardy has 1.1 prerelease, so marking the bug as fixed.

Changed in xkeyboard-config:
status: Confirmed → Fix Released
Changed in xkeyboard-config:
importance: Unknown → Medium
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.