Dapper amd64 $Xorg: XErrorDB, failure!

Bug #47391 reported by Gnu_Raiz on 2006-05-29
8
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg

Open up a terminal in Dapper amd64 type quake4-smp I crash to terminal after trying to open a online multiplayer game.

If I use quake4 I can play the game but textures look black, and no fine detail.

strace gave me this error!

write(1, "Posible JunkPosible JunkPosible "..., 1024) = 1024
write(1, "ble JunkPosible JunkPosible Junk"..., 1024) = 1024
brk(0xd08c000) = 0xd08c000
writev(38, [{0x80b076eb0, 4363864147304}, {0xceb4f8800000000, 707636923339738864}], 2) = 1024
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
futex(0x5594c820, FUTEX_WAKE, 2147483647) = 0
write(1, "JunkPosible JunkPosible JunkPosi"..., 912) = 912
write(1, "Trying to exit gracefully..\n", 28) = 28
write(1, "------------ Game Map Shutdown -"..., 46) = 46
write(1, "--------------------------------"..., 46) = 46
sendto(605564996889346088, 0x149, 73014394144, MSG_DONTROUTE|MSG_CTRUNC|MSG_PROXY|MSG_EOR|MSG_ERRQUEUE|MSG_DONTWAIT|MSG_CONFIRM|MSG_SYN|MSG_RST|MSG_NOSIGNAL|MSG_MORE|0xfffe0000, {...}, 0) = 329
sendto(605564996889346088, 0x149, 73014394144, MSG_DONTROUTE|MSG_CTRUNC|MSG_PROXY|MSG_EOR|MSG_ERRQUEUE|MSG_DONTWAIT|MSG_CONFIRM|MSG_SYN|MSG_RST|MSG_NOSIGNAL|MSG_MORE|0xfffe0000, {...}, 0) = 329
sendto(605564996889346088, 0x149, 73014394144, MSG_DONTROUTE|MSG_CTRUNC|MSG_PROXY|MSG_EOR|MSG_ERRQUEUE|MSG_DONTWAIT|MSG_CONFIRM|MSG_SYN|MSG_RST|MSG_NOSIGNAL|MSG_MORE|0xfffe0000, {...}, 0) = 329
sendto(-213717572648920, 0x3a, 73014394176, MSG_EOR|MSG_WAITALL|MSG_TRUNC|MSG_ERRQUEUE|MSG_CONFIRM|MSG_SYN|MSG_RST|MSG_NOSIGNAL|0xffff0000, {...}, 581332121531394976) = 58
write(1, "--------------- BSE Shutdown ---"..., 46) = 46
write(1, "--------------------------------"..., 46) = 46
munmap(0x581d4000, 229376) = 0
close(40) = 0
nanosleep({429496729600000000, 589010917325259352}, NULL) = 0
write(1, "Shutting down sound hardware\n", 29) = 29
write(1, "------ OSS Sound Shutdown ------"..., 33) = 33
write(1, "close sound device\n", 19) = 19
close(39) = 0
write(1, "--------------------------------"..., 33) = 33
munmap(0x586b2000, 2256896) = 0

<snip due to same error message>

munmap(0x583af000, 1052672) = 0
write(1, "idRenderSystem::Shutdown()\n", 27) = 27
write(38, "\217\2\17\0\1\0\0\0\1\0\2\0,\0\0\0004a\0\0\301\0\0\0\332"..., 16380) = 16380
gettimeofday({4213913822132956, 584719189916979232}, NULL) = 0
write(1, "Posible JunkPosible JunkPosible "..., 1024) = 1024
write(1, "ble JunkPosible JunkPosible Junk"..., 1024) = 1024
writev(38, [{0xad00b076eb0, 4226425193832}, {NULL, 707636923339738864}], 2) = 3752
write(38, "\217\221\3\0\1\0\0\0\1\0\0\0", 12) = 12
read(38, "\0\243z-\20\0\0\0\20\0\217\0\0\0\0\0\320\0\207\377\377"..., 32) = 32
open("/usr/share/X11/XErrorDB", O_RDONLY) = 39
fstat64(0x27, 0xffff515c) = 0
read(39, "! $Xorg: XErrorDB,v 1.3 2000/08/"..., 37893) = 37893
close(39) = 0
write(2, "X Error of failed request: GLXB"..., 49) = 49
write(2, "Major opcode of failed request: "..., 36) = 36
write(2, " (GLX)\n", 7) = 7
write(2, " ", 2) = 2
write(2, "Minor opcode of failed request: "..., 35) = 35
write(2, " (X_GLXVendorPrivate)", 21) = 21
write(2, "\n", 1) = 1
write(2, " ", 2) = 2
write(2, "Serial number of failed request:"..., 39) = 39
write(2, "\n ", 3) = 3
write(2, "Current serial number in output "..., 46) = 46
write(2, "\n", 1) = 1
munmap(0x57467000, 135168) = 0

munmap(0x5a9f8000, 1057736) = 0
munmap(0x582a3000, 42584) = 0
mmap2(0x5ac21000, 204800, PROT_NONE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0x32000) = 0x5ac21000
munmap(0x5556e000, 4096) = 0
exit_group(1) = ?

If you would like the full strace message I will be happy to supply it.
I am using this version of xserver-xorg
Version: 7.0.0-0ubuntu45

 status Rejected

Quake 4 is not supported by Ubuntu. Contact the quake developers for
debugging quake.

Changed in xorg:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers