Major problems on Dell Latitude D600 laptop

Bug #50683 reported by FuturePast on 2006-06-22
8
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

At some point before the final Dapper release my setup broke.

Symptoms were:
CPU soft lockups (sometimes mentioned tg3, so I disabled my NIC in BIOS)
Random freezes in X (mostly within 10 mins of normal use)
Continually jerky mouse movement
CPU scaling constantly on full
Laptop overheating
Broken suspend

I stuck it out hoping for a fix, but nothing changed.
In desperation I got out an old CD of Dapper LiveCD Beta 2 and booted from it and lo and behold a rock-solid, stable system.
I re-installed from the Live CD; again a stable system.
I re-enabled the NIC in BIOS; no problem.

Next step:
Upgraded to latest kernel 2.6.15-25-686; no problem.
Upgraded rest of distro except for the packages listed below; rock-solid.
Locked versions:
xserver-xorg (7.0.0-0ubuntu32)
xserver-xorg-core (1:1.0.2-0ubuntu6)
xserver-xorg-driver-all (7.0.0-0ubuntu32)
xserver-xorg-driver-ati (1:6.5.7.3-0ubuntu5)
xserver-xorg-driver-i810 (1:1.4.1.3-0ubuntu3)

So, by elimination, the problem must be something to do with changes made in X since the versions specified above.

Any ideas or steps to take to resolve this?

System:
Dell Latitude D600 laptop
1.4Ghz Pentium M
768Mb RAM/20Gb hard disk
VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL 9000] (rev 01)
Ethernet controller: Broadcom Corporation NetXtreme BCM5702X Gigabit Ethernet (rev 02)
Network controller: Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04)

Huygens (huygens-25) wrote :

I also have the same problem. It is mentionned in the following forum thread:
http://www.ubuntuforums.org/showthread.php?t=151829
and
http://ubuntuforums.org/showthread.php?t=197741

As said, it occurs mainly at my parent place where I do use Wi-Fi and mainly this is happening when I am on battery.
My system information is described in much detailed in both thread (my user name is the same on the forums and on launchpad.)

As the person mentionned it above, the CPU soft-lock-up is displayed in the log often around tg3 entries.

Huygens

JonD25 (jonathan-duenas) wrote :

Yup, I've got the same problems with an almost identical computer. Only difference is I have 512 MB of RAM and a 30 GB hard drive. I mostly get soft lock-ups, random freezes, and broken suspend.

One more addition: I thought during the Dapper testing that this problem was related to my WiFi card, so I was following closely this bug report which was looking similar:
https://launchpad.net/distros/ubuntu/+source/linux-restricted-modules-2.6.15/+bug/37773

maybe this could be a hint...

FuturePast (4uturepast) wrote :

Well, guys, I don't know what to say.
I now have a fully working, up-to-date system.

I took the following steps (as well as the ones mentioned above):
Removed xserver-xorg-driver-all and xserver-xorg-driver-i810 (and a lot of other drivers).
Upgraded xserver-xorg-core to latest.
Upgraded xserver-xorg-driver-ati to latest.
Upgraded xserver-xorg to latest.

The only other thing I did was remove and replace the memory and wifi card and completely removed the conexant modem.

This doesn't really resolve the cause of all the problems, but I no longer seem to be affected.

Cheers

Richard Bailey (rmjb) wrote :

FuturePast, can this bug be closed?

Huygens (huygens-25) wrote :

From my side, I had my motherboard changed and Ubuntu re-install from scratch. And it rocks. No more problems neither.

Yes. I also believe this is a hardware problem.

Thanks

On 10/4/06, Richard Bailey <email address hidden> wrote:
> FuturePast, can this bug be closed?
>
> --
> Major problems on Dell Latitude D600 laptop
> https://launchpad.net/bugs/50683
>

Peter Whittaker (pwwnow) wrote :

Marked as rejected owing to comments re this being a hardware problem.

Thought about "fix released", since original report seemed to imply a pre-release version of Dapper.

Changed in xorg:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers