GDM Restarts after Desktop loads while using tdfx driver

Bug #68291 reported by gameboyhippo on 2006-10-25
86
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
High
xorg (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-tdfx (Ubuntu)
Medium
Timo Aaltonen

Bug Description

In Edgy Eft, after the Gnome desktop loads using the tdfx driver Gnome freezes and GDM restarts on a new vt. If I switch to using vesa, I can run gnome just fine (minus the hardware acceleration).

I'm using a Voodoo 3 3000 16 Meg PCI card.

In Edgy Eft, after the Gnome desktop loads using the tdfx driver Gnome freezes and GDM restarts on a new vt. If I switch to using vesa, I can run gnome just fine (minus the hardware acceleration).

I'm using a Voodoo 3 3000 16 Meg PCI card.

ShaunS (shauns) wrote :

Edgy Eft Desktop CD will not work with my Voodoo 3 PCI card. I have to install with the text based installer and change the xorg.conf from the tdfx driver to the vesa driver. Then all is well.

Xorg.0.log does not seem to list any useful info.

Thanks
Shaun

ricrogz (ricrogz) wrote :

I have found the same problem, also with a voodoo 3 3000.

GDM and Gnome work fine when using vesa.

I can provide any needed logs if requested.

Sebastien PONS (sebastien-pons) wrote :

I have the same problem, also with a voodoo 3 3000.

GDM and Gnome work fine when droping 1024x768 Modes from xorg.conf, with tdfx driver.

ricrogz (ricrogz) wrote :

I tried your method, Sebastien:

I removed 1280x1024 and 1024x768 from xorg.conf and tried tdfx once again.

The first login (automatic login) failed and I got to GDM again, but the second login (manual one) worked, I got my session, but the desktop background was corrupted, and when switching to the text mode terminals, screens were also corrupted.

So I'm back to "vesa".

If you download xserver-xorg-video-tdfx_1.2.1-5_i386.deb from Debian Unstable and replace /usr/lib/xorg/modules/drivers/tdfx_drv.so with the one contained in this package, then tdfx will work correctly except with no OpenGL. I'm not suggesting that this is the fix, but it does show that the problem is likely in Ubuntu Edgy's xserver-xorg-video-tdfx package.

Javier Jardón (jjardon) wrote :

Same problem here with Xubuntu 6.10

Changed in xorg:
status: Unconfirmed → Confirmed
Antonio Pérez (skarcha) wrote :

Same problem here with kdm, Kubuntu 6.10 and Voodoo3 3000. Switching to vesa all working fine.

Booting from LiveCD I get the same problem.

Changed in xorg-server:
status: Unknown → In Progress
usr (usrlp) wrote :

"$ sudo dpkg reconfigure xserver-xorg" not work in Edgy.
It says: use dselect, but I don't know use dselect options to reconfigure the server.
Wath is the new command to reconfigure xorg in Edgy?
I have a voodoo 3 3000 graphic card and I need use the vesa driver too.
Thank you.

Piotr Olton (uel) wrote :

I have the same problem with this card only in 6.10 ( xorg 7.x ).

antsuser (enzo-smshome) wrote :

Same problem with a Voodoo 3dfx 3000 in these cases:
-> upgrading Dapper to Edge
-> Edgy Live CD (also Beta)
-> Edgy desktop cd install
-> Edgy alternate cd install

No problem with Dapper. With dpkg-reconfigure xserver-xorg choose VESA driver (no autoconfig) I have X up & running.

jhansonxi (jhansonxi) wrote :

There is a known bug in tdfx with a patch available:
https://bugs.freedesktop.org/show_bug.cgi?id=7149

To see if this is affecting you, check the gdm or kdm logs and search for an undefined symbol error realting to "getsecs":
/var/log/gdm/0.log
/var/log/kdm.log

On my systems I can use vesa but the display is corrupted at 24bpp.

Piotr Olton (uel) wrote :

when is possible it to expect patch to this driver in repositorium?

Jeff Rasmussen (jeffrasmussen) wrote :

I was able to apply the patch and create the deb package. I don't suggest that anyone

Jeff Rasmussen (jeffrasmussen) wrote :

What's the deal with the importance of this bug still being listed as undecided?

sam tygier (samtygier) wrote :

bug 63796 is linked to the same upstream bug. is it the same bug?

jhansonxi (jhansonxi) wrote :

I tested Jeff Rasmussen's xserver-xorg-video-tdfx_1.2.1-0ubuntu1_i386.deb (MD5: f3454de1b3c1dd2259786cb8cbebfa93) with a Banshee PCI, Voodoo3 2000 PCI, and a Voodoo3 3000 AGP on a SiS5598/K6-2 and Intel 440LX/Celeron system. The display managers and X errors were no longer evident. The performance of the cards with OpenGL screen savers and SuperTux was too slow to be usable but that's a different issue.

Piotr Olton (uel) wrote :

*.deb file by Jeff Rasmussen take fine with 3DFX Voodoo 2000 ( 16mb )
Thank you!

jhansonxi (jhansonxi) wrote :

Feisty Herd 1 uses the same 1.2.1 version but it crashes even worse - usually locking up X entirely.

Hello everyone,

I just finished upgrading to Edgey Eft last night and have a working install with a Voodoo Banshee. I did have to use the alternate install, but the solution was rather simple:

1) Start using "recovery mode"
2) run "wget ftp.debian.org/debian/pool/main/x/xserver-xorg-video-tdfx/xserver-xorg-video-tdfx_1.3.0-1_i386.deb" (it is possible this will work with amd64, i just don't have a 64 bit machine to try it on)
3) run "dpkg-deb --extract xserver-xorg-video-tdfx_1.3.0-1_i386.deb temp"
4) run "mv /usr/lib/xorg/modules/drivers/tdfx_drv.so /usr/lib/xorg/modules/drivers/tdfx_drv.so.bak"
5) run "cp temp/usr/lib/xorg/modules/drivers/tdfx_drv.so /usr/lib/xorg/modules/drivers/tdfx_drv.so"
6) run "nano /etc/apt/sources.list"
7) Look for the section regarding enabling the "universe" repository, as this repository contains libglide3 (libglide3 is for Voodoo3 and newer, Voodoo2 users need libglide2), which you will need for 3D acceleration. You will need to uncomment two lines, then Ctrl+O (write out) and Ctrl-X (exit)
8) run "apt-get update"
9) run "apt-get install libglide3" (or libglide2, note #7)
10) run "apt-get upgrade" (you may as well do this now instead of when you restart)
11) run "reboot"

That should be it. You're using the 1.3.0 tdfx_drv.so instead of the 1.2.1, but it has the correct symbols being exported so things work correctly. The only problem with 1.2.1 is the "getsecs" symbol not being exported, which is confirmable if you had tailed /var/log/gdm/(whatever the log file is). The error does not show in the Xorg log.

I imagine that the newer Xorg will be used for Feisty, and it's entirely possible that a fixed Xorg will be delivered to users of Edgy. It's less than optimal to be using a different version of the driver, but in this case it is necessary as tdfx_drv.so is just plain broken (for *all* distributions using the 1.2.1 version).

-Philip

usr (usrlp) wrote :

The same problem in Kubuntu Feisty Herd2

jhansonxi (jhansonxi) wrote :

Same problem in Xubuntu Feisty Herd 4

Sorry about the phenomenal bug spam, guys. Adding xorg-team@ to the QA contact so bugs don't get lost in future.

travm (travm) wrote :

Patch file here worked, still no DRI. Why isnt this patch or a better patch released, AFAIK this driver worked on older kernels.

Timo Aaltonen (tjaalton) wrote :

Can you try Feisty beta, which has a newer tdfx driver?

Changed in xorg:
assignee: ubuntu-x-swat → nobody
status: Confirmed → Rejected
Changed in xserver-xorg-video-tdfx:
assignee: nobody → tepsipakki
importance: Undecided → Medium
status: Unconfirmed → Needs Info

Ever since xserver-xorg-video-tdfx 1:1.3.0-1ubuntu1 this is fine for me.

Changed in xserver-xorg-video-tdfx:
status: Needs Info → Fix Released
Javier Jardón (jjardon) wrote :

No problems for me in Xubuntu Fesity final with voodoo3 card

usr (usrlp) wrote :

No problem in Feisty.
You can close thus bug.

Changed in xorg:
status: Invalid → Fix Released
usr (usrlp) wrote :

No problem with tdfx 1.3.0 driver.

Changed in xorg-server:
status: New → Fix Released
status: Fix Released → Unknown
Changed in xorg-server:
status: Unknown → In Progress

Hello, I'd like to report an additional instance of this bug. I've been following it with Mandriva, dealing with the DRI crashing all GLX Programs.

https://qa.mandriva.com/show_bug.cgi?id=44460

This gives all the detail I have on the problem.

jhansonxi (jhansonxi) wrote :

No 3D crashes in Xubuntu Intrepid 8.10 with 1.4 driver. Tested with Voodoo Banshee (PCI), Voodoo3
2000 (PCI), and a Voodoo3 3000 (AGP) using Chromium, Tremulous, and OpenArena (except with resolution changes, see bug #214439). Reports upstream indicate there are problems with 1.4 on other distros.

ernandes (ernandes-oliveira) wrote :

I did not had a problem like this until 9.04. I did not occur in 6.06 nor in 7.04 either in 8.10. So the solutions presented
don't apply to my case.

Tormod Volden (tormodvolden) wrote :

ernandes, please file a new bug report, preferably by running "ubuntu-bug xserver-xorg-video-tdfx".

Changed in xorg-server:
importance: Unknown → High
Changed in xorg-server:
importance: High → Unknown
Changed in xorg-server:
importance: Unknown → High
Changed in xorg-server:
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.