Lockup problems with ati driver on Radeon M300

Bug #30447 reported by Trent Lloyd on 2006-02-04
108
Affects Status Importance Assigned to Milestone
Ubuntu
High
Ubuntu-X
linux-restricted-modules-2.6.15 (Ubuntu)
Undecided
Unassigned
xorg (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned
xserver-xorg-driver-ati (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
High
Ubuntu-X

Bug Description

I have a Dell Precision M20 (from Testing Team) which has an ATI FireGL V3100
0000:01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]

On upgrade to dapper, the problem I have is that if i restart X, either through a /etc/init.d/kdm restart or logging out, the graphics freeze up, irreprably.

This is particularly bad because it happens on logout not just kdm restart.

stock with the exception of a couple extra synaptics driver options

Changed in xserver-xorg-driver-ati:
assignee: nobody → ubuntu-x-swat

interesting DRM related errors

what if you uncomment dri in xorg.conf?

Luka Renko (lure) wrote :

I have Hp nw8240 with ATI FireGL V5000 and commenting out "dri" does not help me. I still get hung machine on kdm restart.
I will also close my bug 32092 as duplicate of this one.

Changed in xserver-xorg-driver-ati:
status: Unconfirmed → Confirmed
rtaranu (rtaranu) wrote :

also getting very similar issues with xorg, i have a radeon 9800pro

xorg will freeze on system boot up (dapper-5 && breezy freeze on my machine). ctrl-alt-backspace does not kill xorg, and ctrl-alt-f1 doesn't go to console.

the system is basicly unusable since i can't even log in.

DarkMageZ (darkmagez) wrote :

i'm not sure if this is related, but when i try to logout, it doesn't work. it attempts to, but ends up with either a black screen or terminal with all those starting this and that.

dapper 5, fglrx. ati 9600se

hendry (hendry-webc) wrote :

I have a similar problem.

When X starts it is often garbled and unusable.

Ctrl+Alt+Backspace might cause the system to freeze.

However sometimes with I flick between the tty console on Ctrl+Alt+F7 the X screen redraws correctly.

My Thinkpad T30 uses a Radeon mobility too.

I am using Ubuntu dapper, so it's not KDE specific IMO.

hendry (hendry-webc) wrote :

I just updated the computer with a new ati xserver package and the problem seems fixed.

Adam Conrad (adconrad) wrote :

Trent, can you confirm that upgrading to the latest ati driver fixes this for you as well?

mym (tuxmym) wrote :

I have a similar problem, even with last ATI drivers (fglrx) in Dapper.
The difference is I use gdm and gnome rather than kdm and kde.
Near each time I logout from my gnome desktop, the screen becomes either black ou weird with a sort of vertical scrolling and horizontal lines moving everywhere on the screen.
I can generally use Ctrl+ALT+F1 to switch to a console and restart gdm. After that, I can login once again. But sometimes the system really freezes and I cannot switch to a console, not reboot with Ctrl+Alt+Suppr, nor kill Xorg with Ctrl+Alt+Bckspc, nor use the magic sys keys kernel (Alt+PrintScr+s, u and b).
This doesn't happen when reboot or shut off.

My graphic card is a X700 mobility (Acer Aspire 1694WLMI 1024).

mym (tuxmym) wrote :

The black screen doesn't appear anymore, I only have the scrolling/moving/with lines one and it's systematics.
I happens even with a failsafe session, just after typing exit into the sole terminal.
My xorg.conf has been generated with "dpkg-reconfigure xserver-xorg", and by choosing the fglrx driver.

Hi I am not sure if this is an ATI issue, but I have noticed that after I upgraded to Flight 5 onward, I am unable to reboot the system. Shutdown powerdown works fine, its only rebooting thats causes the system to hang at "Sending application the TERM signal" and progress bar gets stuck at just before it compltes.

Also, I am unbale to install Dapper 5 onward using iso dics, dapper just hangs at the boot splash and nothing happens, I have to hard shutdown.
The reboot and the installation problems happen with all Ubuntu/Kubuntu and Xubuntu Dapper 5+ rleases.

Note that I have checked the CD and tried installing the same iso on aother non-ATI machine, and it install perfectly well.

My hardware is HP compaq nw8240 ATI firgl V5000.

If this is not an ATI issue, shoudl I be filing a new bug report? or is one already there?

Many thanks,
S

pquinn (p-d-quinn) wrote :

Hi,

I just installed flight 6 (fully updated) on a Dell latitude d610 (ati x300) and I'm having similar problems.
When I log out the screen either goes black or I get a blank screen+mouse but I can't even get a console
to try and restart things. The problem extends to sleep and hibernate mode as when then I try to come out sleep I can hear the disk and dvd spin up but the screen goes black.
 I tried this with and without the fglrx drivers and I get the same problems.

Rocco Stanzione (trappist) wrote :

Same problem here. There's a similar bug filed against kdm, I think. I'll dupe it if I find it.

Rocco Stanzione (trappist) wrote :

The possibly-duplicate bug is 38096 but it looks there to be kdm-specific, so I'm not going to dupe it.

pquinn (p-d-quinn) wrote :

Sorry I made a slight error. My dell d610 works with the fglrx driver (xorg-driver-fglrx) but NOT with the standard ati driver. (I installed the fglrx package but hadn't changed the driver to fglrx in xorg.conf) sorry!!

Peter Jönsson (peterj1978) wrote :

I have the same issues on a Ati 9800Pro.
Clean installs from flight 5/6 and beta just gives a black screen with the default ati-driver.
Booting up into failsafe mode and doing 'apt-get install xorg-driver-fglrx' and then doing 'dpkg-reconfigure xserver-xorg' and switching to the fglrx driver solves this problem for me.

I did a clean install with hoary and dist-upgraded to breezy and then dist-upgraded again to breezy with having the fglrx driver installed was fully functional for me.

Here are some pastes comparing the ati-driver and fglrx driver in the logs.

FGLRX:http://paste.ubuntu-nl.org/12680
ATI-DRIVER:http://paste.ubuntu-nl.org/12679

SubNet (k-gazmaga) wrote :

Simmilar problem on my Dell Inspiron6000 with ATI M300 Graphix. Systemstart and use is fine with Dapper Beta1 but on logout I have a complete freeze of the system. No Ctrl+Alt+Bsp or Ctrl+Alt+Del will do anything. Reset is the only solution.

Bojovic Dragan (drabo) wrote :

i have the same error with a fresh installation of dapper beta gdm/gnome and selfcompiled fglrx 8.24 driver.
i can't logout or restart i only see a black screen and have to reset the pc. after a few resettings i can't login to the system after entering user/pass the gdm apears again.

I have had this happen on my machine, with both ati and fglrx drivers, using Kubuntu. I have an Inspiron 600m with ATI Mobility Radeon 9000.

Akkana Peck (akkzilla) wrote :

Is it possible that this isn't specific to the video card driver, but a more generic xorg problem? I'm seeing very similar symptoms on an S3 Savage machine (bug 41340).

it (orstavik) wrote :

i have the same problem with ati radeon mobility 9700 / ubuntu 6.06 / fglrx. I too get thrown out into a black responsless screen when I try to a) restart x with ctrl+alt+backspace or b) "/etc/init.d/gdm restart" or c) ctrl+alt+F1 or d) simply log out.

The problem of d) "logging out into a black screen" usually happens when I have made changes to the xorg.conf-file. I have been able to successfully log out and also successfully restart X with ctrl+alt+backspace (at log-in-window), but only when I havn't made changes to the xorg.conf before I log out. It seems to me that I must reboot when I make changes to the xorg.conf? (is that a bug or a feature?)

According to the log, the direct rendering support for this chipset is experimental. Perhaps there was no direct rendering support at all in Breezy, which is why this is a regression. If this is the case, we can revert to the Breezy behaviour and get stability rather than experimental features.

Lucas Nussbaum (lucas) wrote :

I can see this too on a Dell D610 (ATI Technologies Inc M22 [Radeon Mobility M300]). Using the fglrx driver is Ok, but I would rather not use a proprietary driver ...

Drel (drel) wrote :

While I don't have the chipset mentioned in the bug title, I couldn't find a more generic bug for this issue. I have a Sapphire X800^2 (squared). It's identified in /var/log/Xorg.0.log as:

(--) Chipset ATI Radeon X850 PRO (R480) (PCIE) found

Running with the fglrx driver, logging out of X, trying to shutdown, trying to switch to a VC, all of these actions would cause the computer to freeze, and my monitor to enter standby mode, as it does when the computer is turned off.

Disabling dri in /etc/X11/xorg.conf did not help. However, switching to the radeon driver (I left dri commented out) fixes the problem.

Hey folks,
Any news on this? The only thing I can add is that I was using Ubuntu (Gnome) and I don't have this problem there. It seems to be a problem with KDE and ATI. I just switched back to Kubuntu and I'm surprised to see that the problem persists.

As mentioned above, using a different driver avoids this issue. Also, I don't have the problem if I try to restart/shutdown from KDM. It only happens in a logged-in account (I've also tried creating new ones or even reinstalling Kubuntu, for that matter).

I think we should fix this for the upcoming release, it's really annoying to see the computer crashing all the time. Again, I would be happy to provide any relevant information.

Thanks.

Latest fglrx driver release by ATI claims that this should be fixed:
"Toggling between console mode and X Server graphical mode no longer results in a system hang. Further details can be found in topic number 737-22058"

http://www2.ati.com/drivers/linux/linux_8.25.18.html

Matthew Lange (matthewlange) wrote :

Fix released by ATi

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
Changed in xorg-driver-fglrx:
assignee: nobody → ubuntu-x-swat
status: Unconfirmed → Fix Released
Lucas Nussbaum (lucas) wrote :

I am not sure I understand how this bug was fixed. A fix seems to have been released by ATI, but didn't arrive into dapper (yet). Additionnally, the ati driver from xorg 7.1 seems to also include some changes that should improve the situation, but again, isn't in dapper (yet).

Reopening, waiting to details.

Thank you,

Changed in xorg-driver-fglrx:
status: Fix Released → Confirmed
Changed in xserver-xorg-driver-ati:
status: Fix Released → Confirmed
Bono Lv (bonolv) wrote :

ATI haven't fix the bug.
My video card is mobility 9700
I use fglrx 8.25.18 with ubuntu dapper RC.
logging out of X, trying to shutdown, trying to switch to a VC, all of these actions would cause the computer to freeze.

Lucas Nussbaum (lucas) wrote :

Try to summarize the bug:
There are lockup problems using both the free ati driver and the proprietary driver from ATI named fglrx.

For people willing to use the free ATI driver, disabling DRI in the Xorg configuration file seems to solve the problem.
Some people who had problems using the free ATI driver didn't see any problem using the proprietary driver (that's my case).

Some people didn't see the problem with Ubuntu/Gnome/GDM, but saw it with Kubuntu/KDE/KDM. I'm not sure, but I think it is caused by the way GDM/KDM issue a server reset (or don't) after logout. Even with GDM, I could reproduce the bug by logging out, and then hitting CTRL+ALT+Backspace in GDM.

Regarding possible solutions:
- for the xorg ati driver: xorg 7.1 includes many changes regarding stability of the ati driver. But we won't get it in Dapper.
- the fglrx seems to also include some changes in this area, but lvscar tested and could still reproduce the bug.

I find a method to solve the problem

change the option in /etc/gdm/gdm.conf
to
AlwaysRestartServer=true

and all will work fine.(at least in last 3 day. 7+ times log out)

ps:
My video card is mobility 9700
I use fglrx 8.25.18 with ubuntu dapper RC.

Jos Dehaes (jos-dehaes) wrote :

The gdm.conf workaround seems to work for me too. This is a RADEON X550 (RV370 5B63).

Paulo Tanimoto (tanimoto) wrote :

Anybody had any luck with KDM? The options seem to be right in:
/etc/kde3/kdm/kdmrc

WillyTP (willytp) wrote :

With the following options in "Device" section, my laptop seems not to freeze anymore.

Section "Device"
        Identifier "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
        Driver "fglrx"
        BusID "PCI:1:0:0"
        Option "DDCMode" "True"
        Option "MonitorLayout" "LVDS,AUTO"
        Option "RenderAccel" "True"
        Option "LVDSProbePLL" "True"
EndSection

1 comments hidden view all 141 comments
franceloc (fidel78) wrote :

After some tries, now it works!
I must preliminarly say theat I've an ATI Radeon 9600 XT, and the ati xorg driver ("ati") works perfectly (maybe because 3D acceleration isn't supported by "ati" driver for this board).
So I'm using fglrx closed source driver, and I've resolved adding this option to xorg.conf:

Option "UseInternalAGPGART" "no"

in Section "Device"

This section now appears as:

Section "Device"
 Identifier "aticonfig-Device[0]"
 Driver "fglrx"
        Option "UseInternalAGPGART" "no"
EndSection

(the section was generated by 'aticonfig --initial', I've only added the Option...).

Now Xorg doesn't freeze after a session restart.
Tested on Kubuntu 6.06 LTS

I hope this helps, you must say!

Francesco

1 comments hidden view all 141 comments
Luka Renko (lure) wrote :

HW: HP nw8240 with ATI FireGL V5000 PCIE (x700).
I have tested this again on 6.06 release (Kubuntu DVD) after clean install.

I can confirm that this problem does not occur with "ati" driver and I think that description should be changed (only fglrx) and task for xserver-xorg-driver-ati package should be Rejected.

With fglrx driver, I can say that the problem is only reproducable in 50-70% of the times that xserver is restarted (typically end of session in KDE) with latest 8.25.18 driver. With older drivers I got the hang of the system always (100% reproducable).

I have also tried the hint from Francesco (also mentioned in http://www.stanchina.net/~flavio/debian/fglrx-installer.html), but it does not help on my system. ;-(

VF (vfiend) wrote :

I had the same problem with KDM using fglrx drivers with a Radeon 9600 XT. "Option "UseInternalAGPGART" "no"" appears to have solved it.

61 comments hidden view all 141 comments
ChrisLees (christopher-lees) wrote :

These Radeon Xpress 200 cards seem to be a real problem! I've just upgraded to Dapper and I'm having the same issue with the same card, on gdm. Using my old Breezy kernel seems to be a temporary solution, but a quick check of glxinfo reveals that Direct Rendering is turned off when I use the Breezy kernel. The open-source ATI and Radeon drivers have never worked for me.

Travis B. Hartwell (nafai) wrote :

I use an ATI 9700 Pro in my desktop machine. I get no lock-ups with the recent kernels, except when I try to switch users. Since my wife and I share the computer, I need to be able to switch users. I would also like to have hardware acceleration so I can play around with Google Earth, Xgl and other things, but the free drivers do not support accelerated video on the R300 chipset-based cards.

I really would like this to work...not sure if it is an ATI issue or an Ubuntu issue, but probably it is something with the closed drivers.

Rocco Stanzione (trappist) wrote :

Adding to the list of triggers for this bug: going fullscreen in vmware

Paul (launchpad-ubuntu) wrote :

I'm also getting lockup problems now that I've upgraded from breezy to dapper, with the accompanying ATI driver upgrade. My graphics card is:

0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY

... on a Thinkpad X31. I am using the free xorg ATI driver. The bug I have (which seems to be the same as at least some of the complaints on the thread) are semi-random full lockups when there are large screen redraws, particularly things involving fullscreen.

I used to lock up after a few minutes when switching between screens in metacity or moving around large windows, but now after removing "load dri" and "load glx" and adding option "NoAccel" I've only been locking up when I am doing something in fullscreen or switching between fullscreen and non-fullscreen (my trigger for this is watching a movie with mplayer as "mplayer -vo sdl -ao sdl -framedrop foo.avi" or "mplayer -vo sdl -ao esd -framedrop foo.avi" and then hitting "f" to switch between fullscreen and non-full screen).

There also seems to be a timing element involved---fullscreen will work when I've just rebooted my machine and logged into gdm, but after a few minutes fullscreen will lock up with either the current screen, or a set of black and white dots (often with a small rectangle somewhere on the screen).

Jos Dehaes (jos-dehaes) wrote :

It seems the new ATI drivers fix this. I have not yet tried myself. See in the forums:

http://ubuntuforums.org/showthread.php?t=204910

The new ATI drivers do not fix the problem, at least for the 64-bit version of Dapper. I installed the 64-bit version of the fglrx 8.26.18 driver, and I have exactly the same problems as I described in much greater detail further up this thread: With the fglrx driver I get a hang every time I shut down, reboot or log in out twice. If I switch to the "ati" driver, there is no hang. Switch back to "fglrx" and the hang reoccurs.

So the 8.26.18 driver does _not_ fix the bug for the 64-bit version of Dapper.

Lachlan (lachlan) wrote :

I get this problem with an onboard Intel graphics card, on my 64-bit box.

Pentium 4/Pentium D,
Socket 775,
Intel 945G,
mATX,
1066MHz FSB - SKU: P5LD2VM

in xorg.conf, my driver is :

Identifier "Intel Corportation 945G Integrated Graphics Controller"
Driver "i810"

I am running gnome, and the fix mentioned here about changing the option in /etc/gdm/gdm.conf
to
AlwaysRestartServer=true
did not help.

Lachlan (lachlan) wrote :

It seems that the title of this bug is now too specific, either that or we should break out a bunch of our comments and report new bugs for them.

Iain Sheppard (iainsheppard) wrote :

8.26.18 (32-bit) drivers seem to have fixed the problem for me, now. Card details are as follows:

0000:01:05.0 VGA compatible controller: ATI Technologies Inc RS480 [Radeon Xpress 200G Series]
(0000:01:05.0 0300: 1002:5954)

llee (llee-huawei) wrote :

8.26.18 (32-bit) drivers fixes nothing for me, everything remain the same. I use a radeon 9600 on ASUS A2 laptop with debian etch.

David Rando (david-rando) wrote :

on Laptop, Fujitsu-Siemens Amilo L-1310G, Ati Xpress 200M, (non dedicated memory) lockups on 8.25 and 8.26. With 8.24 hardlock after a period after the bootup (randomnly).

Also, when it works, have this issue (that i confirmed): https://launchpad.net/distros/ubuntu/+source/linux-restricted-modules-2.6.15/+bug/41272

Using XGL freeze harder.

With the new ATI driver I have no longer "halt or freeze".

Slamd64 (Slackware 64)
Kernel: 2.6.17.1
ATI onboard: Radeon XPRESS 200
ATI Driver: 8.26.18

xorg.conf:

# === ATI device section ===

Section "Device"
    Identifier "ATI Graphics Adapter"
    Driver "fglrx"
    Option "no_accel" "no"
    Option "no_dri" "no"
    Option "mtrr" "off"
    Option "DesktopSetup" "horizontal"
    Option "ScreenOverlap" "0"
    Option "GammaCorrectionI" "0x00000000"
    Option "GammaCorrectionII" "0x00000000"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "CenterMode" "off"
    Option "PseudoColorVisuals" "off"
    Option "Stereo" "off"
    Option "StereoSyncEnable" "1"
    Option "FSAAEnable" "no"
    Option "FSAAScale" "1"
    Option "FSAADisableGamma" "no"
    Option "FSAACustomizeMSPos" "no"
    Option "FSAAMSPosX0" "0.000000"
    Option "FSAAMSPosY0" "0.000000"
    Option "FSAAMSPosX1" "0.000000"
    Option "FSAAMSPosY1" "0.000000"
    Option "FSAAMSPosX2" "0.000000"
    Option "FSAAMSPosY2" "0.000000"
    Option "FSAAMSPosX3" "0.000000"
    Option "FSAAMSPosY3" "0.000000"
    Option "FSAAMSPosX4" "0.000000"
    Option "FSAAMSPosY4" "0.000000"
    Option "FSAAMSPosX5" "0.000000"
    Option "FSAAMSPosY5" "0.000000"
    Option "UseFastTLS" "0"
    Option "BlockSignalsOnLock" "on"
    Option "UseInternalAGPGART" "yes"
    Option "ForceGenericCPU" "no"
    #Option "ChipID" "0x5951"
    Option "ChipID" "0x5974"

Finally!!!!!! :D

Using kubuntu 6.06 (always up to date), on a K7 cpu & kernel and ATI9600pro with latest fglrx package. I was experimenting trouble when rebooting or shuting down my kubuntu:
somethimes system hang up, sometimes ending terminal swithed to blue color, sometimes to white color, sometimes xserver worked well and I had kubuntu splash screen....

Thanks to FranceLoc, I add "TerminateServer=true" to "/etc/kde3/kdm/kdmrc"

After few reboots, I can say that the problem is solved. Each time I see the kubuntu splash screen.

regards

Emmanuel

Luka Renko (lure) wrote :

I have experience this bug with ati/radeon driver on up-to-date Edgy when I have switched to console #1 and back to #7 (X) in order to workaround the resolution problem from bug 40808

David M. Carney (carney1979) wrote :

The only work around that I've found is to install the latest drivers from ATI (v. 8.27.10)

David

Steven Bell (botsnlinux) wrote :

I had a similar problem with drivers 8.24 through 8.27. Roughly one in three logouts, the screen would turn completely white. At that point, Ctrl-Alt-Backspace crashed the computer. After commenting out in xorg.conf:
 #Option "VideoOverlay" "on"
 #Option "OpenGLOverlay" "off"
it seems to work fine. :-)

Laurens Simonis (laurens.s) wrote :

Could this bug be related to bug #36596?

Hi there,

Say kaname, is your card a 200G? or a 200M? (apparenttly notebooks are likely to have a 200M (mobility) and it is clearly stated at ATI that the driver supports it)

As I have a 200G (Hp desktop) that may work for me too.

On the other hand, the problems appears to happen when closing the graphic system, so if we could change the driver 'on the fly' to the normal one (without 3D) before closing this system, may be it will not freezze. As I am a newby, I do not if this can be done and how: Any Ideas?

Daniel

Uncommenting the line "TerminateServer=true" in kdmrc did the job for me. I use Kubuntu 6.06 with an ATI 9200. Only now I've realized the same workaround was suggested on this very bug report, but I was tired of reading and I started messing up with kdmrc...

Timo Aaltonen (tjaalton) wrote :

marking the "affects: Ubuntu" rejected, since this already is filed against xserver-xorg-video-ati..

tuxo (beat-fasel) wrote :

After installing Kubuntu 6.10 I have the problem of not being able to shut down my two computers using the "Turn Off Computer" button in the logout screen. Pressing the latter button leads to the computers login out of KDE but not correctly shutting down. The machines continue running, showing a black screen. However, first ending the session with "End current session" instead of pressing the "Turn Off Computer" button and then shutting down the computer from the KDM login prompt works fine.

Uncommenting the line "TerminateServer=true" in /etc/kde3/kdm/kdmrc did the job for me too. Now I can shut down the computers directly form the KDE logout screen.

My graphics cards: ATI 9250 and ATI 8500 LE
Graphics card driver: Open Source driver ati

Radeon X800 GT, Asus A8N-SLI, AMD64: I've upgraded to 6.10 now. Using "radeon" seems to fix the problem for me. "fglrx" still has the lockups.

Charon (markus-lobedann) wrote :

Have this problem too on a HP nx6125 laptop with an ATI 200m with both "ati" and "radeon" as the driver.
Logout creates visual garbage on the screen. Switching to a text-console creates the garbage too.
System is still responsive though and i can even use the text-console to shutdown the laptop (although i don't see what i am typing).

Didn't try fglrx yet but that one is not an option for me (no sleep, hibernate and setting screen-brightness).

Will provide further information if needed (dmesg, lspci, Xorg.0.log, /var/log/messages)

Thibouf (thibouf) wrote :

I confirm that using a VGA cable instead of a DVI one solve totally the Lockup problems for me.
Even if output of my graphic card is DVI, i put an adaptor. In my screen i have both input, so I can change as I want.

emil_p8 (emile-visual) wrote :

Problem still appearing since Dapper, Edgy doesn't resolve it (either fgrlx or ati). On logout, reboot, shutdown i get garbage on the screen, no switch to a tty, no kernel magic keys (Alt+sysrq+RSUIBO) However, in Dapper i felt my CRT monitor (a 15'', 1280x1024) was very quickly switching frequencies/resolutions several times on logout just before the lock (i use it in 1024, but the login screen maybe tries 1280 and/or different frequency).
So i forced it on 1024x768@60hertz only, lock completely disappeared (40+ reboots). HTH someone. Problem returned with edgy+fgrlx, one in 10+ reboots (what makes it very difficult to track down). Video overlay+opengl option doesn't resolve it, uncommenting dri makes the 3d acceleration go away.

[A troll follows :-)] I think this is an EXTREMELY serious problem, it's a deal breaker for ubuntu; linux people on forums, ircs, etc, should be concerned with such problems instead of trolling like what, anyway, linux doesn't need at all to be rebooted and such idiocies. (what about dual boot and the 200W on electricity bill).

So, i'm thinking on reverting on dapper, since edgy took away also my mic capture (on an onboard sound blaster live 24 bit). BTW, i can only boot edgy's live cd by quickly going to a console during the splash and reconfiguring x with vesa, since the option safe mode graphics locks also.

kubuntu edgy (dist-upgraded from dapper), ati x700. My other PC with a Radeon7000 works just fine (ati driver since incompatible with fgrlx).

emil_p8 (emile-visual) wrote :

forgot: i can hear the switching of the frequencies, since it's a crt, otherwise it's invisible.

Tormod Volden (tormodvolden) wrote :

I have to confess I haven't read all the 127 comments in detail, but there might be quite a lot of separate issues involved. I would suggest to open one bug for the "ati" driver, and one for the "fglrx" driver. And get only updated reports from Edgy, with Xorg.0.log and xorg.conf attached.

To get more debug info, maybe someone can try logging in over ssh and watch systems log (try "sudo cat /proc/kmsg") while the local screen freezes. Or even try to debug Xorg, see https://wiki.ubuntu.com/DebuggingProgramCrash

For a workaround to the failing Safe Graphics Mode, see https://wiki.ubuntu.com/EdgyKnownIssues

emil_p8 (emile-visual) wrote :

Well i tried to monitor via ssh. This is the output of sudo cat /proc/kmsg
:

succesful shutdown:

elena@deepthought:~$ sudo cat /proc/kmsg
Password:
<6>[17179708.412000] [fglrx] total GART = 67108864
<6>[17179708.412000] [fglrx] free GART = 51118080
<6>[17179708.412000] [fglrx] max single GART = 51118080
<6>[17179708.412000] [fglrx] total LFB = 128905216
<6>[17179708.412000] [fglrx] free LFB = 122613760
<6>[17179708.412000] [fglrx] max single LFB = 122613760
<6>[17179708.412000] [fglrx] total Inv = 0
<6>[17179708.412000] [fglrx] free Inv = 0
<6>[17179708.412000] [fglrx] max single Inv = 0
<6>[17179708.412000] [fglrx] total TIM = 0

Broadcast message from root@deepthought (Mon Nov 27 19:04:05 2006):

The system is going down for reboot NOW!
<5>[17179714.820000] apm: disabled on user request.
Connection to 10.0.0.7 closed by remote host.
Connection to 10.0.0.7 closed.

shutdown when it locks:

elena@deepthought:~$ sudo cat /proc/kmsg
Password:
<6>[17179644.604000] [fglrx] total GART = 67108864
<6>[17179644.604000] [fglrx] free GART = 51118080
<6>[17179644.604000] [fglrx] max single GART = 51118080
<6>[17179644.604000] [fglrx] total LFB = 128905216
<6>[17179644.604000] [fglrx] free LFB = 122613760
<6>[17179644.604000] [fglrx] max single LFB = 122613760
<6>[17179644.604000] [fglrx] total Inv = 0
<6>[17179644.604000] [fglrx] free Inv = 0
<6>[17179644.604000] [fglrx] max single Inv = 0
<6>[17179644.604000] [fglrx] total TIM = 0

And then ssh locks. Output seems the same.
BTW, the above is on dapper because I reverted to it (clean install) on this machine, but the problem remained.
Otherwise, i forgot to mention that on edgy, when in X i have no access to a virtual tty (ctrl+alt+Fx), it appears completely garbled, but accepts "blind" input. No such problem in dapper.
It seems to me that this problem appeared after this famous hi-panic xorg dapper upgrade which broke many ubuntus, but now i forgot to test this before patching my new dapper install.
Last thing, in dapper swithching to a console and rebooting from there never caused any problems

If I start in recovery mode and start gdm from the console I don't get
the problems. I can log out and switch to console without freeze.
I'm not sure what conclusions to draw from this - anyone?

Running edgy on a HP nw8240 with a V5000 card.

On my acer aspire 1692 (with mobility radeon x700) i have the same freezing problem when i switch to console or logout/switchuser/etc. I tried to modify gdm.conf and xorg.conf but no way.

So, like Henrik, if i start in recovery mode and lauch gdm from the console i don't get the problems.

Charon (markus-lobedann) wrote :

Just tried with Feistys daily CD-Image from the 31st of January and still have the problem (just tried in the Live-CD mode).

Tormod Volden (tormodvolden) wrote :

This has degenerated into a totally useless bug report, because of the mix of all kind of issues, cards and drivers. The original issue was probably solved with Ubuntu 6.06. Trent, can you please confirm it has been fixed?

Please file new bugs for all the other issues (first search for already reported bugs, of course). Reopen duplicate bugs if appropriate. Test with Edgy and with newest Herd-3 if you can. Attach xorg.conf and Xorg.0.log to your bug reports. Please check out https://wiki.ubuntu.com/Bugs/AtiDriver as well.

Changed in xserver-xorg-video-ati:
status: Confirmed → Needs Info
Timo Jyrinki (timo-jyrinki) wrote :

(This message will repeat three times because of different packages)

Marking as "Fix Released", the original bug most probably was fixed a long time ago (Trent can correct this is untrue). File new bugs on the issues that are still valid, _but_ please first go through the 100 already existing bug reports at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bugs to see if your issue is listed there. If it is, check if you can give new and useful information on the issue (log files etc.).

Also, if you use the closed source fglrx driver, the bug reports belong to linux-restricted-modules, not xserver-xorg-video-ati.

Changed in xserver-xorg-driver-ati:
status: Unconfirmed → Fix Released
Changed in xserver-xorg-video-ati:
status: Needs Info → Fix Released
Changed in linux-restricted-modules-2.6.15:
status: Unconfirmed → Fix Released
2 comments hidden view all 141 comments

Just a hint for people that also have lockup problems and found this page through google:

Some of them are locking issues, which can be worked around by not using radeonfb, i.e. a radeon-specific kernel framebuffer module. Appending
  video="vesa"
to the kernel helps in this case.

Sorry for the bugspam.

Timo Aaltonen (tjaalton) wrote :

closing for a bogus component, renaming as well because of a launchpad "feature"

Changed in xserver-xorg-driver-ati:
status: Unconfirmed → Rejected

I still have this problem with Kubuntu Beta.
I think that franceloc's solution should be used in case it isn't solved until the Feisty Fawn final release date.

tuxo (beat-fasel) wrote :

As of Gutsy Gibbon (7.10), this bug has been fixed for me.

Tormod Volden (tormodvolden) wrote :

Closing task for obsolete component.

Changed in xserver-xorg-driver-ati:
status: New → Invalid
Displaying first 40 and last 40 comments. View all 141 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers