Ubuntu

X server failed to start - Fatal server error: Active ring not flushed (does not release console)

Reported by Alessandro Gervaso on 2006-01-27
110
Affects Status Importance Assigned to Milestone
xlibs
Invalid
Medium
xorg (Ubuntu)
High
Paul Sladen
xserver-xorg-driver-i810 (Ubuntu)
High
Ubuntu-X

Bug Description

After upgrading to dapper with x.org 7.0, my laptop's intel 855 stopped working, showing just a blank screen. It also doesn't release the console so to reboot it i have to ssh into it or shut it down with the power button.

Worked fine in breezy, instead.

This is my config, basically the same used with breezy

This is the Xserver log.

I can confirm this, i855gm chipset. xorg.conf and log attached.

Lukas Kolbe (lucky) wrote : xorg.conf

This is the nearly unaltered config file after installing from a daily install and dist-upgrading.

Lukas Kolbe (lucky) wrote : xorg.log

... looks like the same error as above.

I hope it's ok to mark this as confirmed ...

Changed in xserver-xorg-driver-i810:
status: Unconfirmed → Confirmed
Lukas Kolbe (lucky) wrote :

Severity raised to major, because this renders the system quite unusable for me. (I think Vesa is not really an option for a modern system ...)

Alessandro Gervaso (gervystar) wrote :

I've just tried to disable the dri extension and now I get this backtrace.

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x86) [0x80b49a6]
1: [0xffffe420]
2: /usr/lib/xorg/modules/libxaa.so(XAAFillMono8x8PatternRectsScreenOrigin+0xda) [0x37837d47]
3: /usr/lib/xorg/modules/libxaa.so(XAAPaintWindow+0x492) [0x378441b2]
4: /usr/bin/X [0x8149d70]
5: /usr/bin/X(miWindowExposures+0x1e3) [0x80ff0bf]
6: /usr/bin/X [0x80c4f89]
7: /usr/bin/X(MapWindow+0x255) [0x8073957]
8: /usr/bin/X(InitRootWindow+0xb6) [0x8073bff]
9: /usr/bin/X(main+0x69b) [0x806e2c7]
10: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xd2) [0x37da3ea2]
11: /usr/bin/X(FontFileCompleteXLFD+0x81) [0x806d611]

Fatal server error:
Caught signal 11. Server aborting

Basically the same as above, same backtrace. Should be a little bit more readable.

I disabled dri and got this backtrace in the log. Wasn't able to switch consoles, only saw a blank screen as before.

I experienced a similar situation where X and Gnome just froze (no blank screen; the screen just froze). I couldn"t access a console either. Could this be the same problem? Or would this be a different issue?

Soren Hansen (soren) wrote :

I believe that is a different issue. You should file another bug with info for that.

Just a note that I keep getting the same error after reinstalling dapper flight 4. In the development of breezy something similar happened, with the same symptoms. I can't find the old bug number, unfortunatly. It was fixed shortly before the release of breezy, Daniel Stone (iirc) said it had something to do with bugs in gcc ...

Disabling DRI from the video driver options with
Option "dri" "false"
leads to another situation.
The xserver starts up, but keeps logging errors like this.
ADVANCE_LP_RING: outring (0x27) isn't on a QWord boundary(WW) I810(0): Fixing display offsets.
ADVANCE_LP_RING: outring (0x2f) isn't on a QWord boundaryADVANCE_LP_RING: outring (0x47) isn't on a QWord boundary(WW) I810(0): Fixing display offsets.
ADVANCE_LP_RING: outring (0x4f) isn't on a QWord boundary(WW) I810(0): Fixing display offsets.
ADVANCE_LP_RING: outring (0x57) isn't on a QWord boundary(WW) I810(0): Fixing display offsets.

Also everything becomes sluggish, the cursor isn't visible and there are lots of visual artifacts and bad window redraws.

Xorg log with
Option "dri" "false"

I am also having this problem on my laptop. The system is a Uniwill 223ii00 with 855GM graphics chip. Driver worked perfectly in Breezy. After Dapper dist-upgrade, X showed a black screen after started and locked the console completely. I tried booting former Kernel (2.6.12-10) and was able to start X, but was presented with a mostly black screen in KDM, and extreme screen corruption upon loading the KDE desktop (missing pixmaps, non updating sections of the display, etc). My Xorg.0.log is nearly identical to the ones posted here, but I can post it if it may be useful. I am currently having to resort to VESA drivers to have a GUI. Is there any word on an upcoming fix for this? Is anyone working on it?

Lukas Kolbe (lucky) wrote :

Thank God I'm not the only one with this laptop. Mine is an Uniwill 223II00, too.

Alessandro Gervaso (gervystar) wrote :

After today's dist-upgrade the xserver hangs with the same behaviour, but the error log is different.
I attach the latest log.

latest xorg.log

Raised to critical, because it is a true showstopper on some machines.

Animacide (animacide) wrote :

I think there is more to this bug than just the 855 graphics chip. In my various searching I've seen things like success stories for users of the Dell 700m which uses the 855gme chipset, which is the same as what my Uniwill uses. Perhaps there's something about the installation? Or perhaps a conflict with some other hardware device? Can users having this problem all post there specific hardware details? Perhaps this is model specific. I know I'm personally getting quite frustrated at the situation and am willing to do anything I can to help. I'm going to download the Flight 4 live CD and see if booting it also causes this problem. I'll post details in a few days.

Soren Hansen (soren) wrote :

I don't think it's the installation. Both I and Lukas had problems during the Breezy development cycle and I also have this frickin' rebranded Uniwill 223-thing. It does, however, seem more than plausible that it's a troublesome combination of hardware, although I haven't been able to identify it yet.
Nevertheless, I'm curious to hear the results of your tests with the Live CD. I'm a bit too busy to try it myself and my girlfriend has more or less adopted that particular laptop, so it's availability is not optimal. :-)

Animacide (animacide) wrote :

Well, it's definately nothing about my installation... both Flight 3 & 4 Live CDs have the same problem once X loads. I think Lukas' idea that it's something with gcc is probably right, because I noticed that the change in Xorg.0.log happened after an upgrade to libc and gcc, but I still think something about the 223ii0 is a part of this, over and above the i810 xorg driver. I have noticed several posts on the forums about people who had working xorg with 855 chipsets (usually compiz & XGL success stories that made me even more jealous, lol). The only thing I could think of is that maybe the intel_agp could have something to do with it? Is there any way to get a more detailed trace of what's happening? If anyone has suggestions I'll try it. Also, is there any safe way to revert Xorg to the old Xorg 6 from Breezy?

Animacide (animacide) wrote :

It looks like this is not just an ubuntu thing, it's affecting Debian testing too!

http://lists.debian.org/debian-x/2006/02/msg00374.html

It you look at his Xorg.0.log's backtrace it's nearly identical. Also, in that case it's Xorg 6.9.

I've also found the original BugZilla post from when this happened in Breezy:

http://bugzilla.ubuntu.com/show_bug.cgi?id=12716

Susan Cragin (susancragin) wrote :

Just tried Dapper flight 5 and x hangs except when defaulting to external monitor.
Acer Ferrari AMD64 (using the 64 Dapper install).
ATI Mobility Radeon x700
On the last install, I could correct by adding the following to menu.lst
        Option "MonitorLayout" "LVDS,CRT"
        Option "MetaModes" "680x480,1680x1050"
But that didn't work with Flight 5.
is bug 32474 a similar problem?

somename (x-inluo) wrote :

is this the same problem as 32368?

Susan Cragin (susancragin) wrote :

xorg reconfig does not work.

Lukas Kolbe (lucky) wrote :

this does not seem to have something to do with 32368. We have no kernel panic and also no ati graphics card.

John Fettig (jfettig) wrote :

I have a dell 700m which uses the 855gm video card:

0000:00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)

Xorg in dapper works OK for me, with two caveats: in order to get the widescreen to work, you have to use 915resolution, and in order to get dual head configs to work, you have to apply the patch I have pointed to in this bug: https://launchpad.net/distros/ubuntu/+source/xserver-xorg-driver-i810/+bug/26341

Have you tried using 915resolution? I noticed that you are setting the resolution to a widescreen resolution.

Changed in xserver-xorg-driver-i810:
status: Confirmed → Needs Info
Animacide (animacide) wrote :

I don't think this bug is related to resolution but I'm going to try 640x480 resolution in a few minutes to see if the same problem happens. When you don't use 915resolution, does your Xorg freeze or crash? If it doesn't turn out to be a resolution thing, I think this proves it's something specific to the Uniwill 233. Is anyone having this problem with any other piece of hardware?

Animacide (animacide) on 2006-03-16
Changed in xserver-xorg-driver-i810:
assignee: nobody → daniels
Daniel Stone (daniels) on 2006-03-16
Changed in xserver-xorg-driver-i810:
assignee: daniels → nobody
assignee: nobody → ubuntu-x-swat
darge0flex (christian-timmer) wrote :

Same error here. It's a known bug in xorg. Has something to do with the ValidatePci-Function...

Look at this bugreport on freedesktop.org: https://bugs.freedesktop.org/show_bug.cgi?id=5443

There is also a solution, but you have to patch the sources on two files and compile xorg for yourself...

Sven Herzberg (herzi) wrote :

Thanks for adding this information, but to make tracking of upstream bugs easier, please use the "Link to other bug tracker" function of launchpad when you refer to an upstream bug the next time.

Animacide (animacide) on 2006-03-16
Changed in xlibs:
status: Unconfirmed → Confirmed
Changed in xserver-xorg-driver-i810:
status: Needs Info → Confirmed

Attached is my xorg.conf
I have an Acer Ferrari 4005 widescreen with the components
described above.
If there is any other file you wish me to send, just ask.
Please include the path.

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/X11/fonts/misc"
 FontPath "/usr/share/X11/fonts/cyrillic"
 FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/Type1"
 FontPath "/usr/share/X11/fonts/100dpi"
 FontPath "/usr/share/X11/fonts/75dpi"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc104"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "Emulate3Buttons" "true"
EndSection

Section "Device"
 Identifier "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
 Driver "ati"
 BusID "PCI:1:0:0"
EndSection

Section "Monitor"
 Identifier "Generic Monitor"
 Option "DPMS"
 HorizSync 28-84
 VertRefresh 43-60
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
 Monitor "Generic Monitor"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1680x1050"
 EndSubSection

EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
EndSection

Section "DRI"
 Mode 0666
EndSection

I don't think this is the same bug that you're having Susan. This bug is specific to the intel chipsets, you have an ATI card... I would see if there are any open bug reports on your specific issue, with your particalar card. If not, you have discovered a new bug and should post a new bug report.

somename (x-inluo) wrote :

Susan: Try looking at the bug
https://launchpad.net/distros/ubuntu/+bug/32368
This has the same (similar?) symptoms, but specific to ATI.

To Others: Should 32368 be marked as critical as well? It has the same problem: not being able to boot into the O/S.

Susan Cragin (susancragin) wrote :

Have moved my ATI problem to Bug 32368. Thanks.

I found a "solution" in https://bugs.freedesktop.org//show_bug.cgi?id=5443

Animacide, could you try the following:

sudo apt-get build-dep xorg-server
sudo apt-get install fakeroot
apt-get source xorg-server

and then, in the file hw/xfree86/common/xf86Bus.c, find the call to "ValidatePci();" and comment it out? it should be around line 2491.

Recompile the package with "dpkg-buildpackage -rfakeroot" from within the xorg-server-directory (this should take a while) and install the resulting packages.

Then try again if it works - for me, X works now, with the i810-driver.

Thanks, Lukas! That worked perfectly. I had been trying to compile Xorg from CVS with the commented ValidatePCI call, but I couldn't get it to build. That was much easier. Now, I can watch video on my laptop again, very nice. Maybe we can get this patch applied to the official builds?

Lukas Kolbe (lucky) wrote :

I don't think that this is really a fix for the problem, it's more like a workaround which could be contra-productive on other systems (just a guess, I don't really know how that all works).

To the X-Swat: Note the line

(WW) ****INVALID MEM ALLOCATION**** b: 0xffe80000 e: 0xffefffff correcting

in the logs, around line 340. W/o the call to ValidatePci(), there is no such line.
How should we go on, help fixing this? I'd rather not compile my own X-Server for the dapper release ;)

Alessandro Gervaso (gervystar) wrote :

I can confirm that this works for me too.
Probably a simple check before calling that function is what it takes to fix it.

Same problem and Lukas' fix works for me.
My notebook is a Uniwill 259EN3 (same as Alienware Area-51 m5500).
I'm glad that the severity is deemed critical.

I might add that setting SWcursor to on in the xorg.conf allows the X server to start, but the display is corrupted. See:
http://ubuntuforums.org/showthread.php?t=154774

I have the same problem with my 855GM Intel card on Optimus MX600 laptop. It worked well on Breezy, but it freezes at startup when using i810 driver so I'm currently using vesa. Hope it will be fixed before final release. I upgraded today to 2.6.15-20, as there were rumours of sth broken in i945 Intel cards in the kernel and it was supposed to fix it and I thought it might bring the fix to my card as well, but it didn't. I also tried to install the new Fedora Core 5, and although the X server started it had serious problems with resolution (640x480 only as I recall it)

Roger Wood (roger-wood) wrote :

So I have this exact same problem. I have 915GM in an Averatec 4265. I just went and installed DApper flight 6 and the problem persists. I tried the fix, but couldn't make it work. I was told that I had an invalud firmware for IPW2200, I don't even know what that has to do with graphics.

dr.spock (dr.spock) wrote :

I can confirm this issue with an Uniwill 223iio laptop (855GM chipset). I have it working now with Vesa driver.

kadiliman (kadiliman) wrote :

I can confirm the ValidatePCI() fx above.

My laptop is this: http://www.uniwill.com/products/mobility/245ii0/245ii0.php?HL=3&M=3

I finally was able to run Dapper X_X

Definitely a show stopper - I wouldn't want to recompile my X server everytime it needs upgrading.

Today xserver-xorg-driver-i810 was updated and after upgrading my system I ran dpkg-reconfigure -phigh xserver-xorg, which changed the driver in xorg.conf form 'vesa' to 'i810' but the new version of i810 driver (1:1.4.1.3-0ubuntu3) didn't help and after rebooting my system I still can't login, as there is only black screen with no option but hard reboot. Or am I doing sth wrong? Hope the i810 driver will make it to the final dapper release. My xorg.log in the attachment.

Same problem here with the Dapper beta livecd. Output of
lspci is

0000:00:00.0 Host bridge: Intel Corp. 82852/855GM Host Bridge (rev 02)
0000:00:00.1 System peripheral: Intel Corp. 855GM/GME GMCH Memory I/O Control Registers (rev 02)
0000:00:00.3 System peripheral: Intel Corp. 855GM/GME GMCH Configuration Process Registers (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
0000:00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 83)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 03)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 03)
0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 03)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
0000:01:03.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
0000:01:07.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
0000:01:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
0000:01:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Relevant lines in xorg.conf from breezy:
Section "Device"
        Identifier "Intel Corporation 82852/855GM Integrated Graphics Device"
        Driver "i810"
        BusID "PCI:0:2:0"
EndSection

Linux Certified Laptop LC2000

Animacide (animacide) wrote :

I was looking at the upstream bug report, and it looks like they figured out exactly why this problem occurs and they have a new patch for it that is going to be applied to the 7.1 Xorg. Can we look at getting this patch added to dapper's Xorg? https://bugs.freedesktop.org/show_bug.cgi?id=6750

Soren Hansen (soren) wrote :

Animacide: Great spotted. I've created a version of xserver-xorg-core with the patch applied. Fetch it at:
http://www.linux2go.dk/ubuntu/pool/main/x/xorg-server/xserver-xorg-core_1.0.2-0ubuntu8linux2go1_i386.deb

Please test it.

There shouldn't be any dependency problems with installing it by itself. Please note, however, that if a new version turns up in the official repository, it will overwrite this one unless you put it on hold.

If you are one of the lucky people with our company repository:
deb http://www.linux2go.dk/ubuntu dapper main
in you sources.list, all you should do is apt-get update and apt-get upgrade, and hey presto! :-D If not, you can add it now.

Colin Brace (cbrace) wrote :

Soren,

I just tried installing your deb but without success. aptitude claimed it required xorg-common but said that wasn't installable. It offered to install your deb only by downgrading (?) to the ubuntu one.

I experienced a similar situation where X and Gnome just freeze upon login(no blank screen; the screen just froze). I couldn"t access a console, mouse or anything for that matter. Only a hard re-boot (pressing the power button) would release the system.I have been experiencing this problem since i tried to upgrade (sudo apt-get dist-upgrade) to Ubuntu 6.06 Dapper beta2. I have dont have any such problem on my Ubuntu 5.10 installation. I have a ATI (ATI Radeon 9600)graphics card. (Toshiba SA60 laptop). I have had to downgrade back to Ubuntu 5.10. Could this be the same problem? Or would this be a different issue?

dr.spock (dr.spock) wrote :

I have installed the patched xorg-core from linux2go.dk and yeah! it works!

But I expected to get some missing transparencies and i didn't. gdesklets keeps showing an ugly black background. Maybe something related to AGP or is this driver (with the i855GM chipset) unable to manage transparencies?

Christian Holtje (docwhat) wrote :

I tried the patch mentioned by Animacide from
https://bugs.freedesktop.org/show_bug.cgi?id=6750
and it worked.

I didn't try Soren Hansen's .deb since Colin Brace said he couldn't
get it to work.

So, hopefully the patch Animacide mentioned will be included in the
next xorg update?

Ciao!

If the fix to #6750 is what is needed, then it's already been applied in the latest Xorg CVS, 7 days ago:
http://webcvs.freedesktop.org/xorg/xserver/xorg/ChangeLog?rev=1.477&view=log
Version 1.0.99.902 includes it, so perhaps the deb on the following site might help:
http://gandalfn.club.fr/ubuntu/index.php

It's also in this repository:
deb http://xgl.compiz.info/ dapper main

I can confirm that this version works. This patch really needs to be applied for Dapper.

I added xserver-xorg-core as the affected package, since the bug has nothing to do with xserver-xorg-driver-i810. Hopefully it will prompt the people working on xserver-xorg-core to check it out.

Animacide (animacide) on 2006-05-11
Changed in xserver-xorg-core:
assignee: nobody → ubuntu-x-swat
status: Unconfirmed → Confirmed
Paul Sladen (sladen) wrote :

Only need one.

Changed in xserver-xorg-core:
status: Confirmed → Rejected
Paul Sladen (sladen) wrote :

Antoine, if you can pull out the specific patch relating to this, that would be useful.

It's from this bug report:
https://bugs.freedesktop.org/show_bug.cgi?id=6750
The proposed patch, which was applied to the X.org 7.1 branch is:
https://bugs.freedesktop.org/attachment.cgi?id=5478
There was some kind of debate on the BIOS range stuff. I'm not involved in this, so I can't tell you more, I'm just a user.

This is the patch from the package in the Linux2Go repository. It has been tested and is reported to do the trick.

Oh, this patch looks familar, I think I was in the middle of applying it before. It crops up because X has its own PCI implementation rather than just using Linux's.

Changed in xserver-xorg-driver-i810:
status: Confirmed → Rejected
Changed in xserver-xorg-core:
assignee: ubuntu-x-swat → sladen
status: Rejected → In Progress
Lukas Kolbe (lucky) wrote :

Sorry for the lack of testing in the last months. I sticked with my "patched" 1:1.0.1-0ubuntu7 which worked and only now had time to test again with th e official packets.

With 1:1.0.2-0ubuntu10, my X works again flawlessly! No problems seen so far, so for me this bug can be closed. Thanks!

Paul Sladen (sladen) wrote :

xorg-server (1:1.0.2-0ubuntu10) dapper; urgency=low

  * Backport a fix for Intel bridge handling:
  debian/patches/002_fix_for_certain_intel_chipsets.patch
  (Closes Ubuntu: #29880)

Changed in xserver-xorg-core:
status: In Progress → Fix Released
Jordan Kanter (jikanter) wrote :

This patch causes x-org to fail to start on AMD-k8 kernels

Pavel Mlčoch (pavkamlc) wrote :
  • Xlog Edit (70.7 KiB, application/x-trash)

I think its not problem for i810, but for xorg-core. Ive the same problem. Xorg crash after start.

Pavel Mlčoch (pavkamlc) wrote :

pavka@pavka:~$ lspci
...
0000:01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
0000:01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary) (rev 01)
...

Hello,

And have you found a way to solve that bug ? :P I have installed
Kubuntu by a friend of mine who wanted to switch to Linux and that bug
is the only one we met and couldn't solve by browsing the web. It is
very disappointing for a first time under Linux.

Is there another bug open for the "active ring not flushed" ?

Thanks.

Sébastien

2006/10/7, Pavel Mlčoch <email address hidden>:
> pavka@pavka:~$ lspci
> ...
> 0000:01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
> 0000:01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary) (rev 01)
> ...
>
> ** Attachment added: "xorg.conf"
> http://librarian.launchpad.net/4701354/xorg.conf
>
> --
> X server failed to start - Fatal server error: Active ring not flushed (does not release console)
> https://launchpad.net/bugs/29880
>

Sébastien Mazy (melyadon) wrote :

Forget the previous comment. I hadn't noticed that I had answered a mail sent by the bug subscription system. I guess that if Pavel Mlčoch had solved his problem, he wouldn't post here. ;)

I would appreciate if someone could delete the previous pointless one.

Bug #50576 also deals with "active ring not flushed" crash after xorg start.

ttoine (ttoine) wrote :

Install package "i810switch" with apt-get or synaptic

Then, use the command line "i810rotate" to switch between internal, external, both, etc... and use command line "i810switch" to know the current state.

It still have a bug because the image is jamed on the external diplay, see bug report #114080 about the i810switch package.

Can someone confirm that it works or if all of you have the jamed image ?

Toine

Changed in xlibs:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in xlibs:
importance: Medium → Unknown
Changed in xlibs:
importance: Unknown → Medium
Changed in xlibs:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.