External monitor on intel 945GM/Dell D620 (and D420) causes lockup.

Bug #50243 reported by charles.figura on 2006-06-18
22
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
DaveThacker
xserver-xorg-driver-i810 (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-i810 (Ubuntu)
Medium
Unassigned
Dapper
Undecided
Unassigned
Edgy
Undecided
Unassigned

Bug Description

Use of Fn-F8 key combination to switch to external display on Dell Latitude D620 under Ubuntu Dapper works for one 'cycle' only, then locks up the display.
Here's what happens, and it's repeatable -
Start with standard laptop display, plug in the external monitor or projector.
FnF8 -> CRT on only
FnF8 -> Both on
FnF8 -> (screens shut off & then back on) - Both on again
FnF8 -> CRT on only
FnF8 -> laptop on only
FnF8 -> dead. backlight may or may not come back on, but display won't.
At this point you have to power-cycle the unit to recover.

I'm running Dapper with current upgrades as of 2006/06/18. This is reproducable under both the 2.6.15-23 and 2.6.15-25 kernels.

charles.figura (charles-figura) wrote :

Oh - one other thing. When display is on BOTH laptop and external monitor/projector, the display on the computer is shifted down by about a quarter inch or so - there's a top bar of gibberish. Mouse entry, however, is not shifted down. The result is that in order to point and click on something (a hypertext link, a file folder, whatever) you must click *above* the link/item/whatever.

Jede28 (news-saring) wrote :

Hi,

I have exactly the same problems as described in the notes above. I'm using the latest Ubuntu dapper with all updates and the Linux kernel 2.6.15-25.
The notebook is a Dell Latitutde D620 with Intel GMA 950 graphic chipset. The display resolution is 1280x800. Maybe this problem happens on all GMA950 based notebooks or maybe this is a problem for this series of Dell notebooks.

Would be great when this could get fixed, otherwise the laptop is not usable for presentations.

Thanks,
Stefan

Jede28 (news-saring) wrote :

Update:

Since the ubuntu kernel was updated to 2.6.15-26 the system completely crashes when trying to switch to external screen by typing FN+F8. The cursor can't be moved, no key is working and I can't switch to console. So the workarrounds are not work anymore.
It's really strange and unusable now !

Bye,
Stefan

Sean Kelley (sean-sweng) wrote :

I can confirm this bug with Dapper and my Dell D620.

Sean

Nuno Cardoso (ncardoso-xldb) wrote :

Hello.

I can also confirm that this is exackly the behavior I see on my D620, with FC6test3 and Ubuntu Edgy Eft. I'm trying to have a dual-monitor system at my desk, but I can't cycle to the beginning, both monitors go black after a 5th or 6th fn-f8 combination.

Nuno Cardoso (ncardoso-xldb) wrote :

How long do we still must wait so that you can confirm this bug?! I guess that there's no doubt!! This makes the Dell D620 laptop unusable for dual monitors and for presentations!

BagpussNZ (bagpussnz) wrote :

Confirmed also on 6.06 and D620. I have to boot into windows to run presentations - that 6Gb of my disk wasted.

Please someone fix this!

on89 (oni89-deactivatedaccount) wrote :

I have the same problem with a Dell 640m (945GM chipset)! After the some press of FN-F8, the laptop completly freeze (music freeze, and I can't ssh in).

BTW, I don't know if it is related but I've got the same type of freeze running dumpreg (part of i855crt), a small program that try to dump the VBIOS to a file. (it mmaps, and reads, the video card pci memory address range, taken from lspci, from /dev/mem)

I wrote a little patch (uhm actually it's a dirty hack :P) to the xf86-video-i810 driver to fix this behaviour! It worked for me (I've a Dell 640m/e1405). In these day I'll wrote something better...

Achim Bohnet (allee) wrote :

I run into the same problem with the livecd of edgy with a
Dell D620. Today the same with an D420 :(

I'll install edgy and try the above patch.

Achim Bohnet (allee) wrote :

Tried the patch from Paolo and it works great with the
Dell D420 (intel 945GM gfx) on Edgy. Thx a lot Paolo!!

FWIW I attach Paolos patch as debdiff, so it's a bit
easier to update the edgy pkg sources.

Paolo: can you elaborate how dirty your fix is? Is it
from your POV clean enough to be included into a backport?

Achim Bohnet (allee) wrote :

Oh, here the debdiff

I wrote a better patch and I sent bug report to the xorg bugzilla...
The new patch: http://www.paolomeschi.com/patches/xf86-video-i810/xf86-video-i810-1.7.2-945gm-crash.patch
The bug report: https://bugs.freedesktop.org/show_bug.cgi?id=9290

Achim Bohnet (allee) wrote :

Thx a lot Paolo (again). I'll test your new version when back
at work tomorrow. I'll attach new debdiff for convevience.

@Charles: use 'debuild -us -uc' then the (harmless) error
about missing gnupg key will not happen.

Great! I've tested with an external monitor at home on my D620 with no crashes after multiple/many cycles. The problem seems to be fixed! Thanks, guys, for the great work (and the great help!)

DaveThacker (dthacker9) wrote :

Charles and all.
I found this bug while doing some triaging. I'm going to check the progress of the upstream bug and then figure out what the next status is. Sorry for the delay in getting it confirmed.

Dave

Changed in xserver-xorg-driver-i810:
assignee: nobody → dthacker9
status: Unconfirmed → Needs Info
Tully (tully.foote) wrote :

I just want to mention that this is still a problem for me using 2.6.17-10 Edgy standard install. My hardware is a Dell 640m.

Though I can sort of recover by restarting X with Ctrl-Alt-Backspace.

Nuno Cardoso (ncardoso-xldb) wrote :

I don't know why, but now my fn-f8 does not work. It doesn't do anything. I guess that my updates must have did that. Now I can't even output nothing at an external VGA. What is going on?

Nuno Cardoso (ncardoso-xldb) wrote :

Ok, i resolved this, but the problem is that I can control, the flicker and resolution of the external monitor. The image is always off-set and trembling... but I have faith on you. Is it a bug or just a bad configuration? I tried xorg.conf but I'm afraid it just doest't pay attention to the resolutions and refresh / sync values I define.

Timo Aaltonen (tjaalton) wrote :

closing bogus component.

Changed in xserver-xorg-driver-i810:
status: Needs Info → Rejected

Hello,

I'll let you know as soon as I test it. I'm sorry, I have a deadline at
the end of the week, but I'll try on my Feisty @ D620, OK?

Jérôme Guelfucci wrote:
> Thank you for your bug report. Do you still have this issue with the
> latest release of Ubuntu ?
>
> ** Changed in: xserver-xorg-video-i810 (Ubuntu)
> Importance: Undecided => Medium
> Status: Unconfirmed => Needs Info
>
>

--
Nuno Cardoso e-mail: <email address hidden>
Faculdade Ciências U.Lisboa Phone: +351 96 685 36 94
Pólo da Linguateca no XLDB Room: 6.3.30

http://www.linguateca.pt - Centro de Recursos Distribuído para o Processamento Computacional da Língua Portuguesa
http://www.tumba.pt - Pesquise na Web Portuguesa! - Portuguese Web Search
http://xldb.fc.ul.pt - XLDB Group

Faculdade de Ciências Universidade de Lisboa
Campo Grande, 1749-016 Lisboa

----
"sic transit discus mundi"
(From the System Administrator's Guide, by Lars Wirzenius)
for.

Thank you for your bug report. Do you still have this issue with the latest release of Ubuntu ?

Changed in xserver-xorg-video-i810:
importance: Undecided → Medium
status: Unconfirmed → Needs Info

Ok, thank you for answering.

The raw install of Feisty still exhibited the same problem. I applied Paolo's/Allee's patch above, and it now works without difficulty.

Ok, I'm marking this as confirmed. The problem is that the patch will break something in other laptop (cf upstream bug).

Changed in xserver-xorg-video-i810:
status: Needs Info → Confirmed
status: Unconfirmed → Rejected
status: Unconfirmed → Rejected
cbourbou (cbourbou) wrote :

Had this problem with Ubuntu 7.04, hoped it would be gone with 7.10. Alas, while testing with a beamer yesterday, my Dell Latitude D620 twice stopped after the second cycle-through with F8...I'm often running customer presentations requiring a beamer and I had to use Windows (argh) because of this bug.

Questions:
- Seeing that there was now changes in this bug report for around 4 months: Is the patch described in this bug still the best way to solve the problem?
- I'm not deep into Linux. For me it is not clear how to apply the patch. I guess I have to change (after saving a copy of the original) a certain file with the text in the patch? Do I need to recompile anything? I would much appreciate a short "how-to" on applying this patch.

Thanks a lot
Tino

unggnu (unggnu) wrote :

Could you please recheck it with Gutsy Final Live CD? In Gutsy i810 driver is deprecated and intel driver is used instead.

Changed in xserver-xorg-driver-i810:
status: New → Invalid
Changed in xserver-xorg-video-i810:
status: Confirmed → Incomplete

I wish I could tell. When I use the intel driver under gutsy, my crt/lcd switch (Fn-F8) doesn't work AT ALL. I can't switch to the external monitor/projector at all.

So, no, it's much, much worse.

Charles

I just tested what they asked me to do in bug 50243, choosing the driver 'intel' over 'i810'.
I'll update the bug, but in short, it is (in a funny way) working now.....

cheers
Tino

----- Original Message ----
From: charles.figura <email address hidden>
To: <email address hidden>
Sent: Monday, October 29, 2007 2:43:33 PM
Subject: [Bug 50243] Re: External monitor on intel 945GM/Dell D620 (and D420) causes lockup.

I wish I could tell. When I use the intel driver under gutsy, my
crt/lcd switch (Fn-F8) doesn't work AT ALL. I can't switch to the
external monitor/projector at all.

So, no, it's much, much worse.

--
External monitor on intel 945GM/Dell D620 (and D420) causes lockup.
https://bugs.launchpad.net/bugs/50243
You received this bug notification because you are a direct subscriber
of the bug.

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Peter Clifton (pcjc2) wrote :

charles,

With the setup you had (Gutsy+Intel driver) not working with the FN+F8 key combination, does it change behaviour if you:
echo 0 | sudo tee /sys/module/video/parameters/no_automatic_changes

Does it change behvaiour if you remove the ACPI video module?:
sudo rmmod video

Peter Clifton (pcjc2) wrote :

Charles, a further point..

With the "intel" driver, the expected behaviour of a video button event is to activate and setup all displays which are detected as being connected. If the external monitor isn't powered up, you may so no change at all.

cbourbou (cbourbou) wrote :

7.10: Changed the driver from 'i810' to 'intel':
I was not able to use the GUI "Admin>Screens and Graphics" which would always revert back to i810. Therefore I rebuild the xorg settings using "dpkg-reconfigure xserver-xorg", where I was able to select the intel driver and resolutions.

Then I hooked up the beamer (Dell 1024x768), pressed [FN]+[F8] - and my screen showed up. Now the funny thing: I can press [FN]+[F8] dozens of times, without any further reaction, both the LCD and the beamer always remain 'on'. The only reaction on the key combination is that the beamer's picture is flickering for maybe half a second. So in my case, [FN]+[F8] is not cycling through - but is not crashing either. Since the beamer sports a 'blank screen' feature (as many modern models do), I can blank out the beamer when I need to work in privacy. So, I can work.

After some reflection, maybe this behavior has to do with this little handy command I found:
I've stumbled upon the article: "XrandR 1.2 means decent Linux Screen Management at Last", which seems to answer a number of resolution and output target problems. I intend to test it more fully in the upcoming days.
http://lilserenity.wordpress.com/2007/10/15/ecstatic-xrandr-12-means-decent-linux-screen-management-at-last/

Thanks for your help
Tino

cbourbou (cbourbou) wrote :

Did some testing with xrandr - this stuff works!

With a beamer attached, I can control on/off and resolution using:
cbourbou@cbourbou-ch:~$ xrandr --output VGA --off
cbourbou@cbourbou-ch:~$ xrandr --output VGA --mode 1024x768
And it doesn't even need root level....The notebook's LCD can even run on a different resolution, but it's better to set them both to 1024x768....

+ Tested it with my external monitor Dell 1905FP connected to the DVI output, also there setting on/off resolution works (screen name="TMDS-1")
+ And finally, also the notebook's LCD (screen name="LVDS") is controllable likewise.

Pretty handy tool! I plan to set up corresponding shells, so I can switch easily....
Cheers, Tino

Peter -

I've tried both of your suggestions, and there is no effect - Fn-F8 does not function at all.

unggnu (unggnu) wrote :

I am closing this bug because it seems to be fixed. Feel free to open it again if the issue still happens with Gutsy Gibbon and the new Intel driver.

@charles.figura
Your new problem seems to be already reported under Bug #144225.

Changed in xserver-xorg-video-i810:
status: Incomplete → Fix Released
apease (adampease) wrote :

I'm having problems with the intel 950 chipset and "intel experimental modesetting driver" on Ubuntu 7.10 on a Toshiba A205-S4777 laptop. The graphics quality is poor both on the laptop monitor and external monitor. It almost looks like the resolution or sync rate isn't set properly for each - "1" characters are randomly thick or thin as though they are falling on pixel boundaries without anti-aliasing. Window effects like maximize/minimize are clunky compared to a new desktop machine I have also running Ubuntu 7.10. Also, using the external monitor is problematic. On reboot, the laptop does not display on the external monitor, *unless* I open preferences->administration->screens and graphics sometime before rebooting, and then it reboots fine with display to the monitor. Very strange.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers