Ubuntu

Slow movement regression of synaptics touchpad on v0.14.3+seriouslythistime

Reported by Sarah Kowalik on 2006-01-16
244
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Medium
Unassigned

Bug Description

I move my finger across the touchpad, which would ordinarily move the cursor from the bottom corner of the screen to the opposite top corner, or a large amount of the way, yet with this version, moving my finger diagonally across the touchpad in exactly the same way only moves it around an inch each time, if that.

This problem does not occur by removing xserver-xorg-input-synaptics, and installing xorg-driver-synaptics - but hopefully there is a better fix than this!

Machine is a toshiba A10 satellite laptop.

I tried Azriphale's solution at http://ubuntuforums.org/showthread.php?t=115460 but it didnt seem to make any difference. Mouse scrolling is still slow

description: updated
Changed in xserver-xorg-input-synaptics:
status: Unconfirmed → Confirmed
Jeroen Lamain (jeroenlamain) wrote :

Also seen on Dell Latitude D600. Changing mouse settings via Preferences does not help.
Attached USB mouse works normally.
Also TAP to click does not work. See also bug #28617

Arthur Peters (amp) wrote :

I am experiencing the same problems on a Compaq R3000z with Dapper daily 20050125.

Work around by editing /etc/X11/xorg.conf

See http://www.ubuntuforums.org/showthread.php?p=673281#post673281

More people showing this error at http://ubuntuforums.org/showthread.php?t=122700

Igor Zubarev (igor.zubarev) wrote :

On Sony VAIO VGN-FS115MR the same problem in Dapper 3

Trent Lloyd (lathiat) wrote :

Also happens on my Dell Inspiron 8600, i believe it affects all ALPS touchpads

This is a serious regression that needs to be fixed.

Jerome S. Gotangco (jsgotangco) wrote :

Confirmed on Toshiba Tecra M2.

Stephan Adig (sadig) wrote :

confirmed on toshiba portege r200

Trent Lloyd (lathiat) on 2006-02-02
Changed in xserver-xorg-input-synaptics:
assignee: nobody → ubuntu-x-swat
pirast (pirast) wrote :

confirmed on fsc amilo pro v2030

Please stop this "me too, me too". I found the issue i will have a fix (that you can all test) in the archive within today.

Fabio

Can every body please use the default config and add the following 3 lines to the synpatic section of xorg.conf

Option "MinSpeed" "1.0"
Option "MaxSpeed" "1.0"
Option "AccelFactor" "0.3"

In some cases this will speed up too much.

Fabio

Žarko Iličić (zakili) wrote :

same bug with Dapper Flight 4 on Sony Vaio PCG-FR415S

This is still a known issue in Flight 4 for the laptop testing team

https://lists.ubuntu.com/archives/laptop-testing-team/2006-February/000442.html

Alexandre Payment (alp) wrote :

Adding the option in the xorg.conf solve the slowness, but something is still wrong because i'm not able to click or doubleclick with the touchpad.

Daniel Vollmer (maven) wrote :

Fabio,
the fix works, although I would argue that the AccelFacor is too much. I left that at the default (which seems to be around 0.1 - 0.15) and only added the MinSpeed and MaxSpeed directives to the xorg.conf.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

* Martin Jürgens <email address hidden>:
  [2006-02-28 18:03:46 -0000]

> Public bug report changed:
> https://launchpad.net/malone/bugs/32058
>
> Comment:
> #28648 is a Dapper only problem so I marked this as a duplicate.
>
> Touchpad Press has been disabled self-aware as far as I know. You can
> change this by edititing your xorg.conf file.

Just FYI, I added all the options from README.alps and my ALPS
GlidePoint (Vaio VGN-T2XP) started to behave correctly after
rebooting. Please, see bug 32058.

-----BEGIN PGP SIGNATURE-----

iD4DBQFEBKiqLdxCGS3zaBERAmfVAJ9rTrTWObfcLiA1/f2gEAqPBG8vTwCWLXx4
jfoz6b+HKm9hLJj2nVv08A==
=jZNt
-----END PGP SIGNATURE-----

Jaap Haitsma (jaap) wrote :

Fabio,

You're suggested fix

Option "MinSpeed" "1.0"
Option "MaxSpeed" "1.0"
Option "AccelFactor" "0.3"

works on my Dell D410

thanks

Loïc Corbasson (cnb) wrote :

Another fix:

Comment the "Synaptics Touchpad" InputDevice section in xorg.conf if (like me) you have a "Configured Mouse" section too:

-- snip --
Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ImPS/2"
        Option "Emulate3Buttons" "true"
        Option "ZAxisMapping" "4 5"
EndSection

#Section "InputDevice"
# Identifier "Synaptics Touchpad"
# Driver "synaptics"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/psaux"
# Option "Protocol" "auto-dev"
# Option "HorizScrollDelta" "0"
#EndSection
-- /snip --

Works on my Sony Vaio PCG-FR285E.

Arthur Peters (amp) wrote :

The recommended fix works on Compaq R3000z.

I added:

Option "MinSpeed" "1.0"
Option "MaxSpeed" "1.0"
Option "AccelFactor" "0.3"

Chris Weiss (cweiss) wrote :

the recomended fix (and leaving off AccelFactor) also works on my HP zv5000

disabling the synaptics driver also works.

Jonathan Jesse (jjesse) wrote :

Confirmed with an Dell Latitude D810 on Dapper flight 4 plus recent updates of Kubuntu. USB mouse works fine. No matter what I adjust in the mouse settings it doesn't change

Morgan Collett (morgan) wrote :

Still broken in flight 5 on my Sony Vaio VGN-S460.

cleentrax (cleentrax) wrote :

Still broken in Flight 5 Live on my Dell Inspiron 8600

Drew Woodard (drew-woodard) wrote :

this bug, and the solution to it (filling in the xorg.conf InputDevice area) also applies to the Toshiba s100 family of laptops under dapper flight 5

Adriaan Peeters (apeeters) wrote :

I tried this fix on my Dell Latitude D505 on Dapper Flight 5 live cd (which does not include this fix yet btw) and it works. Acceleration is a bit too much, but I guess I could find working values.

If I remember correctly, this bug did not occur on Flight <= 4, will try to confirm that soon.

Adriaan Peeters (apeeters) wrote :

I was wrong, it does occur on Flight 4.

One problem with the solution though: it fixes the problem, but changing the mouse preferences does not cause changing touchpad behaviour.

Alex Muntada (alex.muntada) wrote :

As a result of adding the options from README.alps to the TouchPad section, the USB mouse didn't work anymore.

I followed Loïc's suggestion of removing the whole touchpad section and leave only the default mouse as input device and now I have both the USB and my touchpad working ok for me: the touchpad tapping works fine, but the scrolling doesn't (anyway, I don't like the touchpad scrolling).

Constantine Evans (cevans) wrote :

Adding 'me too' comments won't help, as Fabio said earlier. This seems to be a well known issue and is even noted in the xserver-xorg-input-synaptics documentation - read README.alps. I am rather certain this is the problem here.

However, I don't understand Fabio's fix for this. It seems to me that the problem here is that the configuration options need to be added when xorg is being configured.

Andrew Conkling (andrewski) wrote :

"It seems to me that the problem here is that the configuration options need to be added when xorg is being configured."

This would seem to solve the problem, but if so, the question is: are these sane defaults? And a few people above mentioned that the solution isn't ideal--it doesn't seem to allow for changing the mouse preferences via the GUI settings and it seems to cause at least one problem with someone's USB mouse. (I haven't tested the former problem, and didn't have the latter.)

But barring anything else, I think this seems like a good idea.

Constantine Evans (cevans) wrote :

Oops - in editing my comment I removed some words that should have been there. Defaults similar to those shown should be added only if there is an ALPS touchpad detected. The settings are certainly not sane for real Synaptics touchpads.

The settings could be tweaked a bit. One option allows for changing settings via a GUI without restarting X, but there does not appear to be any suitable program for doing so (ksynaptics, tpconfig, etc), and the changes aren't persistent if I remember correctly.

This works now as of 0.14.3+seriouslythistime-0ubuntu3 for Toshiba Tecra M2 (Canonical supplied)

Corey Burger (corey.burger) wrote :

Can all those who had this issue please update and check with xserver-xorg-input-synaptics_0.14.3+seriouslythistime-0ubuntu3?

Changed in xserver-xorg-input-synaptics:
status: Confirmed → Needs Info
Jelle Raaijmakers (jelle-gmta) wrote :

This seems to have fixed the problem. Working perfectly now.

Corey Burger (corey.burger) wrote :

Three of us have had the issue fixed. If anybody else still has this issue, please reopen the bug.

Changed in xserver-xorg-input-synaptics:
status: Needs Info → Fix Released
Adriaan Peeters (apeeters) wrote :

Another 'Fixed' me too. Nice work!

Loïc Corbasson (cnb) wrote :

Works here too. Thanks!

Hezekiah Carty (hez) wrote :

This seems to be fixed on my laptop as well (Sony Vaio VGN-S260)

endy (endy-linux) wrote :

I hope this doesn't fall into the "me too" category of comments but this is still a problem with the Flight 6 Live CD on my 12" Powerbook G4 and renders the Live CD pretty much useless.

Corey Burger (corey.burger) wrote :

reopening, as per previous comment. *grumble* Just when I thought this bleeding issue has dead...

Changed in xserver-xorg-input-synaptics:
status: Fix Released → Confirmed
Matt Zimmerman (mdz) on 2006-04-14
Changed in xserver-xorg-input-synaptics:
assignee: ubuntu-x-swat → nobody

Can anyone still confirm this with Beta. This really should have been fixed already.

pirast (pirast) wrote :

I can't confirm this. It has been fixed for me.

Adriaan Peeters (apeeters) wrote :

I have to revert my previous 'Fixed' comment. I recentrly upgraded from Breezy to the latest version of Dapper and the touchpad is still a bit 'clicky'. It happens that I am just moving the mouse when I happen to click somewhere unintentionally. It doesn't happen very often, but it is a bit annoying.

Danny O'Brien (danny-spesh) wrote :

I can confirm this on a 12" G4 Powerbook (PowerBook6,8) on Flight 6. Trackpad is unusable slow when using Flight 6 LiveCD.

Matt Lee (mattl) wrote :

Still not working on PowerBook G4 (15inch, 1.67Ghz on final release of Dapper)

Andrew Conkling (andrewski) wrote :

Matt,
Does the workaround posted above help in your case?

Quoted here:

"Can every body please use the default config and add the following 3 lines to the synpatic section of xorg.conf

Option "MinSpeed" "1.0"
Option "MaxSpeed" "1.0"
Option "AccelFactor" "0.3"

In some cases this will speed up too much."

In my case, setting AccelFactor to 0.1 was a bit more conservative.

Matt Lee (mattl) wrote :

On 01/06/06, Andrew Conkling <email address hidden> wrote:
> Does the workaround posted above help in your case?

It makes it move faster, but still very jumpy.. making it easy to get
across the screen, but clicking on icons proved quite difficult.

I tried 0.3 and 0.1 - both gave similar results.

matt

--
Matt Lee
CNUK Media Foundation - http://cnuk.org/

Adriaan Peeters (apeeters) wrote :

The speed is alright on my Dell Latitude D505, but I accidentally click when I did not mean to. Should I open another bug for this?

Andrew Conkling (andrewski) wrote :

No, this is a matter of configuration. You can check here: http://ubuntuforums.org/showthread.php?t=76585&highlight=maxtaptime

There are other posts scattered across the forums, but this one seemed good after a quick search. Short answer: set MaxTapTime to 0.

Andrew Ash (ash211) wrote :

Is this still a problem for anyone? fwiw, I'm not seeing this on my touchpad using version 0.14.6-0ubuntu7 on feisty.

David (djst) Tenser (djst) wrote :

This is definitely a problem on my Dell Latitude D620. Moving the finger diagonally over the touch pad makes the mouse cursor move about 1/4th of the screen's total diagonal length. Very annoying.

Also, it seems to mistake some movements as mouse clicks. I need to press firmly with the finger to avoid accidental clicks.

Hezekiah Carty (hez) wrote :

The patches applied by Ubuntu seem to fix the problem for me. The same patch fixes the problem under Etch as well.

I have an Alps touchpad, and things seem to work cleanly under Feisty.

With my ALPS touchpad (Dell D810) I had the problem with feisty but
solved it with the following xorg.conf option in the Synaptics Touchpad
section:

 Option "MinSpeed" "0.60"
 Option "MaxSpeed" "1.10"
 Option "AccelFactor" "0.030"

This solution works fine for me although I would rather set these
options from the a tab in the mouse preferences box.

I also set "MaxTapTime" to "0" because it was not working very well.

Jonathan Jesse (jjesse) wrote :

Good evening,

I've been trying to get caught up on bugs that I'm subscribed to and am not having problems with my touchpad on Gutsy. So the problem is fixed for me on my Dell. Can we get some updates on this?

Thanks,

Jonathan

On 10/3/07, Jonathan Jesse <email address hidden> wrote:
>
> I've been trying to get caught up on bugs that I'm subscribed to and am
> not having problems with my touchpad on Gutsy.

I'm still having this problem on my Dell laptop on a clean install of Gutsy
Beta.

Kevin McGehee (kevin-mcgehee) wrote :

The problem still exists with my Dell Latitude D630 running 64-bit Ubuntu Gutsy RC. Manual fix above still works (though I'd like to be able to visually edit it with a GUI utility). [q,g]synaptics has no impact on the speed.

raam (bassem-atalla) wrote :

Confirmed on Toshiba Tecra A3, with latest Gutsy updates.
This only started to happen after I apdated on the 13th ( I update daily)

(no longer using that laptop, so can't confirm if it is fixed or not. looks to be, when i last ran a test install of tribe 3 on it though)

Brien Voorhees (brienv) wrote :

Confirmed on Dell XPS M170. Fresh install of Gutsy. gsynaptics also was ineffective. Required adding minspeed/maxspeed to xorg.conf.

Upon upgrading to gutsy, I had similar problems - the mouse cursor jumps around at times as though acceleration were set much too high; the scroll on the touch pad no longer works; selecting by tapping on the touchpad (eg. to drag) no longer works. At times there seem to be other strange effects. Definitely not "it just works." I will try the workarounds suggested here.

Theodore Book (tbook) wrote :

The workaround with the following options did seem to fix most of the problem:

        Option "MinSpeed" "0.3"
        Option "MaxSpeed" "0.6"
        Option "AccelFactor" "0.0002"

Sorry to put so many notes onto the bug, but I had a few other (unfortunate) observations. With the new settings (as before) the pointer occasionally hangs for a few seconds, or jerks wildly. Also, occasionally, and without any clear reason, it sometimes switches from being extremely responsive to being very slow. I know it sounds like a hardware problem, but since it began when I switched to gutsy, I am assuming it is software.

ALittleSlow (john3-17) wrote :

Motion is still a problem with gutsy on a Dell D600.

Just did a fresh install of Gutsy Gibbon on Dell D600. Tapping and scrolling work fine, Motion is smooth but painfully slow. Mouse GUI doesn't affect touchpad motion, but does affect knob motion, and the range is good. Tried adding this to Synaptics section of my otherwise unadulterated xorg.conf:
        Option "MinSpeed" "0.3"
        Option "MaxSpeed" "0.6"
        Option "AccelFactor" "0.0002"
Had no noticable effect on touchpad motion.

Changed above lines to this:
        Option "MinSpeed" "1.0"
        Option "MaxSpeed" "1.0"
        Option "AccelFactor" "0.3"
And the result was immediately noticeable, and much improved.

Tried this:
        Option "MinSpeed" "0.8"
        Option "MaxSpeed" "0.8"
        Option "AccelFactor" "0.03"
I liked the 1.0 speeds better, but I think the AccelFactor is still too high, as I keep overshooting my target.

Couldn't find any version of 0.14.3+seriouslythistime-0ubuntu3 to test, sorry.

This bug also affected me using Hardy on an IBM X60, which uses a trackpoint not a touchpad..

/proc/bus/input/devices does not mention synaptics, instead I have:
I: Bus=0011 Vendor=0002 Product=000a Version=0000
N: Name="TPPS/2 IBM TrackPoint"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse1 event6
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

The MinSpeed/MaxSpeed/AccelFactor workaround worked for me.

Slava (kook-mail) wrote :

Solution with setting the "MinSpeed", "MaxSpeed", "AccelFactor", does not work in my case. I have a TabletPC tx11200us

#cat /proc/bus/input/devices

I: Bus=0003 Vendor=093a Product=2510 Version=0111
N: Name="PIXART USB OPTICAL MOUSE"
P: Phys=usb-0000:00:0b.0-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:0b.0/usb2/2-1/2-1:1.0/input/input2
U: Uniq=
H: Handlers=mouse1 event2
B: EV=17
B: KEY=70000 0 0 0 0
B: REL=103
B: MSC=10
---------------------------------------------
I: Bus=0003 Vendor=0eef Product=0001 Version=0210
N: Name="eGalax INC. USB TouchController"
P: Phys=usb-0000:00:0b.1-2.3/input0
S: Sysfs=/devices/pci0000:00/0000:00:0b.1/usb1/1-2/1-2.3/1-2.3:1.0/input/input3
U: Uniq=
H: Handlers=mouse2 event3
B: EV=1b
B: KEY=401 30000 0 0 0 0
B: ABS=f
B: MSC=10
------------------------------------------
I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input11
U: Uniq=
H: Handlers=mouse3 event11
B: EV=b
B: KEY=6420 70000 0 0 0 0
B: ABS=11000003

As you can see i have 3 input devices, a touchpad, a touchscreen , and a usb optical mouse. I would like if all three could work together, but in these conditions i have to choose to use or the `Optical USB mouse` or `touchscreen`. I thought this was a bug only with the `usb optical mouse`. But somehow it is conflicting with the touchscreen driver, the mouse speed was slow, the scroll button wasn't working at all, and the touchscreen - dead.

In my xorg.conf file where enabled all three input devices, I tried adding the "MaxSpeed", "MaxSpeed", "AccelFactor" options into the `mouse` section but nothing happend.

After commenting in xorg.conf :

Section "ServerLayout"
 Identifier "Default Layout"
 screen "Default Screen"
 Inputdevice "Synaptics Touchpad"
 #Inputdevice "touchscreen" # <- HERE
 Inputdevice "Configured Mouse"
EndSection

the usb optical mouse worked fine, besides, the new "MaxSpeed", "MaxSpeed", "AccelFactor" Options added, weren't useful anymore because the speed set from gdm already affected the usb optical mouse as well.

I've attach the xorg.conf file, it may help...

William Grant (wgrant) wrote :

Please try this in Ubuntu 8.10.

Changed in xserver-xorg-input-synaptics:
milestone: ubuntu-6.06 → none
status: Confirmed → Incomplete
Slava (kook-mail) wrote :

Works fine, after upgrade to Ubuntu 8.10 !!!
All three are working: touchpad, touchscreen, usbmouse without any problems, and the mouse speed can be tuned and affects both, usbmouse and the touchpad.

Cool :)

William Grant (wgrant) wrote :

Excellent, thanks.

Changed in xserver-xorg-input-synaptics:
status: Incomplete → Fix Released
Kevin McGehee (kevin-mcgehee) wrote :

I used the above fix to adjust the xorg.conf in 8.04, but in an upgrade to 8.10, the same problem has re-emerged (though this time I can't just patch the xorg.conf). I can change the acceleration/sensitivity in the System -> Preferences -> Mouse configuration, but I can't get the touchpad to feel as smooth as it did before and increasing the acceleration negatively impacts my external mouse. It's usable - it takes about three full-pad scrolls from one side of a 1440x900 screen - but it's not as natural as it was before or it is in Windows. Can you suggest a way to modify the touchpad sensitivity now that things are managed through HAL?

William Grant (wgrant) wrote :

See https://wiki.ubuntu.com/X/Config#hal for doing the same things you could do in xorg.conf.

You may consider trying my Alps driver in
   [URL="www.medini.org/software/alps/alps.html"]http://www.medini.org/software/alps/alps.html[/URL]
-- yotam

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.