[x700] fails to infer lvds for primary connector on acer ferrari 4005 | card detected, but driver fails to use right output port

Bug #22985 reported by Lakin Wecker on 2005-10-02
286
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
High
xorg (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
High
Ubuntu-X

Bug Description

During the install I get asked for the resolution to use similar to this problem:
https://bugzilla.ubuntu.com/show_bug.cgi?id=14974

However, it does include the proper resolution (1680x1050) in the list.

The problem is that even after selecting this, X fails to start properly. It
has to do with X mis-detecting which is the primary display and which is the
secondary display. Typically adding the following lines to the xorg fix it:
Option "CRT2Position" "clone"
Option "MonitorLayout" "LVDS,CRT"

I actually think that only the last line is necessary, but am unsure. If I
install the fglrx packages and then use fglrxconfig to build the xorg.conf then
it works fine as well.

Dennis Kaarsemaker (dennis) wrote :

*** Bug 22995 has been marked as a duplicate of this bug. ***

Lakin Wecker (lakin) wrote :

To clarify, X does start. It just turns off the LCD display, so the screen goes
completely black. It seems like the external display was working when I plugged
in my external monitor, but I didn't bother switching to resolution to confirm.
 I can do this if need be.

Daniel Stone (daniels) wrote :

thanks for your report; we're also seeing this upstream. it looks like it's
just this type of laptop that's pathologically broken in terms of hardware.

I just built X.org 7.0 on an Acer Ferrari 4005 running Debian AMD64. The
-configure detected the video card (a Radeon Mobility X700 on PCI express), but
after that the screen stays blank. A xev from the network shows mouse and
keyboard events, and Ctrl-Meta-Backspace kills the server, so it is mostly fine,
but the screen is completely blank (not black, off).

On the same system, with Debian X.org 6.8, the fglrx driver works... let's just
say it works, and the vesa driver works in some extents.

Apart from the straightforward parts, the detected xorg.conf shows:

Section "Device"
        #<snip comments of available driver options>
        Identifier "Card0"
        Driver "ati"
        VendorName "ATI Technologies Inc"
        BoardName "Radeon Mobility X700 (PCIE)"
        BusID "PCI:1:0:0"
EndSection

The corresponding lspci output is:

0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility
X700 (PCIE) (prog-if 00 [VGA])
        Subsystem: Acer Incorporated [ALI]: Unknown device 007e
        Flags: bus master, fast devsel, latency 0, IRQ 209
        Memory at c8000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 9000 [size=256]
        Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at c0120000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2
        Capabilities: [58] #10 [0001]
        Capabilities: [80] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
0000:01:00.0 0300: 1002:5653
        Subsystem: 1025:007e

I'll attach the full server log in a comment.

Regards,

--
  Nicolas George

Created an attachment (id=4209)
server log

The Acer Ferrari 4005 has too many outputs and confuses the screen detection.
You have to tell it to try the LVDS first to get the LCD panel to come up - in
the ATI driver section in your xorg.conf set MonitorLayout to "LVDS, NONE".

Thank you, that did the trick.

Now that I know what to look for, the problem is obvious in the log, but in the
tens of lines, I did not remark it at all. Was there any document I should have
read before posting here, and that would have set me on the track?

Regards, and happy new year,

--
  Nicolas George

The only documentation is the various mailing list and web forums where this
has come up before. I know mainly because I've had to use this on my Ferrari
4005. I'm re-opening this bug, because I think it's a bug that you have to
do this and that the detection built into the driver fails to detect the panel
if you don't.

Daniel,

Although I realize the problem is due to hardware which seems to be really broken, it is a regular problem on this laptop. If other people with this card, but different laptops are experiencing similar problems, would it be possible to detect this card and include some changes to the default xorg.conf file in order for it to work? Even if it is only this laptop, it seems like the card and laptop combination can be detected fairly easily(lspci -v -v?), so it should be possible to include a slightly modified xorg.conf that works for this laptop.

What needs to be provided/worked on by us laptop owners in order for this to work?

i can confirm this

Changed in xserver-xorg-driver-ati:
assignee: daniels → nobody
status: Unconfirmed → Confirmed
Asraniel (asraniel) wrote :

i realy hope that this will be fixed in dapper. i have the same problem with travelmate 8103

mihai.ile (mihai.ile) wrote :

Acer 1694wlmi also needs this line:
Option "MonitorLayout" "LVDS,Auto"

I can confirm this bug. I have a Targa Traveller 826 laptop, it's got a Mobility
Radeon X700 chipset. It's got two additional outputs, VGA and S-video. Without
the MonitorLayout workaround X gets started on the VGA output, even when no
monitor is connected to it. Let me know if you need more information, like
logfiles etc.

Atm, this prevents me from installing fedora core 5 test 3, the console-based
installer is horribly broken.

Regards,
Dominik

Hi

I also have this laptop, before I had an acer aspire 1691wmli. On that laptop in hoary X had a similar issue, but breezy (and dapper) solved this and didn't have to tweak the xorg.conf file. It would be great if this copuld be fixed in this laptop (acer ferrari 4005).

I'm willing to solve this bug, so if you need any kind on information about the hardware of this machine, please ask.

Thanxs

Swinster (swin) wrote :

I have a Rock Quaddra T64 with ATI x700 mobility gaphics and a 17" widescreen 1440x900 LCD screen (Samsung possibly).

I have had similar problems in boh Breazy and Dapper with blank screen on install. I tied switching to "vesa" drivers instead of the detected "ati" but this simply gave an error something like:

VESA :No matching modes
Screens found, but none have usable configurations

I eventuall found this and other similar bug reports so replaced the following line the "monitors" section in xorg.conf.

Option "DMPS"

to

Option "MonitorLayout" "LVDS"

Not sure if I needed to repalce the DPMS thing or leave it, but with the other line in palce I managed to get KDE running at 1024x768. I can set the resolution to 1440x990 but the screen then goes a bit weird and seems to wrap left to right.

Giuseppe Pennisi (giupenni78) wrote :

I have very similar bug, see bug 37236 .
I must insert in monitor section this line:
Option "MonitorLayout" "LVDS,AUTO" .

I have a Ati Mobility Radeon X700 and a display 15" widescreen 1680x1050 .

If I install fglrx driver (or use vesa driver in xorg.org) and reconfigure X without the line Option "MonitorLayout" "LVDS,AUTO", the display run but not at the optimal resolution and with lose performances.

Regards,
gp

1 comments hidden view all 234 comments
Paul Sladen (sladen) wrote :

Could we just hardcode (set by default):

  Option MonitorLayout LVDS,AUTO

in all instances of detecting an ATI driver?

Asraniel (asraniel) wrote :

i would support this. would make my life much easier at school when i want to convince people of linux. they all have a travelmate 8100 which needs this line:

Option MonitorLayout LVDS,AUTO

hope this can be fixed for dapper since we have 6 more weeks and this is a bug that should be possible to fix.. its just about adding one line in a config file for a specific laptop

bailey3003 (btermers) wrote :

I have a Compaq Presario 2100. It has this for its video card, Radeon® IGP 320. I have the same problem, lcd goes black but if i plug in secondary monitor that works. When I get home I will try out what you guys have said to do and I will post back here on my results.

I have seen other people with presario 2100s that have the same problem. Yet some claimed that it worked right out of the box...maybe they had a different video card in theres...

Paul Sladen (sladen) wrote :

Hi Bailey, you have a different type of laptop so it's not related. If laptops are booted with an external monitor plugged in they normally turn off the internal (LCD) display.

bailey3003 (btermers) wrote :

No, it is the same problem I think, I just wasnt clear enough in my last post. The lcd goes black as soon as the login screen comes on. I never see it. But if i hook my crt up to my laptop, the crt does get the picture.

bailey3003 (btermers) wrote :

Ok I got it working by adding that line to the xorg.conf file...thanks for the help

1 comments hidden view all 234 comments
mihai.ile (mihai.ile) wrote :

you can CTRL+ALT+F1 then login and add the line in xorg.conf but I really hope it will work out of the box BEFORE the release of Dapper.
This bug is really old, in breezy was the same thing :(
Just to remember:
Acer 1694wlmi also needs this line:
Option "MonitorLayout" "LVDS,Auto"
for more info about this laptop:
https://wiki.ubuntu.com/LaptopTestingTeam/AcerAspire1694WLMi

Cyclops (rms) wrote :

Also happens on an HP Compaq NX9010. I was bitten by this problem today.

Rui

dmesg for my laptop, where this problem is happening too.

In previous versions of xfree/xorg this problem didn't happen.

I can confirm that this bug hits also Dapper Beta AMD64 on an Acer Aspire 5024 WLMI (nice Turion64 laptop...). Adding 'Option "MonitorLayout" "LVDS,Auto"' to the "Device" section of /etc/X11/xorg.conf does fix this issue.
Also noteworthy : the resolutions proposed do not include 1280x800, which is the only "natural" resolution for the screen. Btw, the Gnome wigdet used for setting screen resolution only displays 1280x800, with an absurdly large negative value for refresh rate...
All of this renders the use of Dapper Live on this machine a bit problematic... If the live CD use is considered a main goal, this should be a RC bug.

Phil Bull (philbull) wrote :

Assigning to X-SWAT.

Changed in xserver-xorg-driver-ati:
assignee: nobody → ubuntu-x-swat
Luka Renko (lure) wrote :

Kubuntu Daily CD 20060504 still comes up with blank screen on HP nw8240 (ATI FireGL V5000) and you have to add:
Option "MonitorLayout" "LVDS,AUTO"

rodniy (tine-kump) wrote :

None of the proposed solutions works on nx7010 laptop (radeon 9200). Tried with everything, but no luck.

Primary display works only when xorg.conf is configured with "radeon" and not with "fglrx". Fglrx otherwise works fine, only on seconday monitor.

Alle 12:58, Sunday 14 maggio 2006, rodniy ha scritto:
> None of the proposed solutions works on nx7010 laptop (radeon 9200).
> Tried with everything, but no luck.
>
> Primary display works only when xorg.conf is configured with "radeon"
> and not with "fglrx". Fglrx otherwise works fine, only on seconday
> monitor.
It's my xorg.conf, adapts it to your requirements:

===============================================

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 # path to defoma fonts
    FontPath "/usr/share/X11/fonts/misc"
    FontPath "/usr/share/X11/fonts/100dpi:unscaled"
    FontPath "/usr/share/X11/fonts/75dpi:unscaled"
    FontPath "/usr/share/X11/fonts/Type1"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath "/usr/local/share/fonts"
EndSection

Section "Module"
 Load "GLcore"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "it"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "Device"
 Identifier "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
 Driver "fglrx"
 BusID "PCI:1:0:0"
EndSection

Section "Monitor"
 Identifier "Monitor Generico"
 Option "DPMS"
 HorizSync 28-84
 VertRefresh 43-60
        Option "MonitorLayout" "LVDS,AUTO"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
 Monitor "Monitor Generico"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1680x1050"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1680x1050"
 EndSubSection
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
EndSection

Section "DRI"
 Mode 0666
EndSection

======================================

GP

Download full text (3.8 KiB)

It's my xorg.conf, adapts it to your requirements:

===============================================

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        # path to defoma fonts
    FontPath    "/usr/share/X11/fonts/misc"
    FontPath    "/usr/share/X11/fonts/100dpi:unscaled"
    FontPath    "/usr/share/X11/fonts/75dpi:unscaled"
    FontPath    "/usr/share/X11/fonts/Type1"
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath    "/usr/local/share/fonts"
EndSection

Section "Module"
        Load    "GLcore"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "it"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "Device"
        Identifier      "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
        Driver          "fglrx"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "Monitor Generico"
        Option          "DPMS"
        HorizSync       28-84
        VertRefresh     43-60
        Option          "MonitorLayout"   "LVDS,AUTO"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
        Monitor         "Monitor Generico"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1680x1050"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1680x1050"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1680x1050"
        EndSubSection
        SubSection "Display"
            ...

Read more...

rodniy (tine-kump) wrote :

Thanks for your help. But.. it's not working. I have replacedmy xorg.conf with yours, but nothing changed (displays are basically the same).
So.. Where else can I look in order to find the problem? Xorg..0.log shows no errors and I did a complete reinstall of xorg-driver-fglrx and ati's driver more than once.
If I do dmesg I get this:

root@che:/etc/X11# dmesg | grep fglrx
[4294790.244000] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[4294790.250000] [fglrx] Maximum main memory to use for locked dma buffers: 431 MBytes.
[4294790.250000] [fglrx] module loaded - fglrx 8.24.8 [Apr 11 2006] on minor 0
[4294790.790000] [fglrx] Internal AGP support requested, but kernel AGP support active.
[4294790.790000] [fglrx] Have to use kernel AGP support to avoid conflicts.
[4294790.790000] [fglrx] Kernel AGP support doesn't provide agplock functionality.
[4294790.791000] [fglrx] AGP detected, AgpState = 0x1f000217 (hardware caps of chipset)
[4294790.792000] [fglrx] AGP enabled, AgpCommand = 0x1f000314 (selected caps)
[4294790.804000] [fglrx] free AGP = 256126976
[4294790.804000] [fglrx] max AGP = 256126976
[4294790.804000] [fglrx] free LFB = 37359616
[4294790.804000] [fglrx] max LFB = 37359616
[4294790.805000] [fglrx] free Inv = 0
[4294790.805000] [fglrx] max Inv = 0
[4294790.805000] [fglrx] total Inv = 0
[4294790.805000] [fglrx] total TIM = 0
[4294790.805000] [fglrx] total FB = 0
[4294790.805000] [fglrx] total AGP = 65536

Susan Cragin (susancragin) wrote :

Hi. I have an Acer Ferrari 4005 too. I did a fresh install, accepted the generated xorg.conf, and added the following two lines near the end of xorg.conf.

Option "MonitorLayout" "LVDS,CRT"
Option "MetaModes" "680x480,1680x1050"

Works like a charm.
Susan

HTH.
All Acer Ferraris in the 4000 range SHOULD be able to work with ONLY those two lines appended near the end, that is:

Option "MonitorLayout" "LVDS,CRT"
Option "MetaModes" "680x480,1680,1050"

PeppeP and Rodniy, you are using the closed-source, proprietary "fglrx" driver. This bug is about the open-source "ati" driver. Please post "fglrx" issues somewhere else. (And dont paste files into comments, use Add Attachment.)

Giuseppe Pennisi (giupenni78) wrote :

Sorry!!!

Paul Sladen (sladen) wrote :

Speaking to somebody at LinuxTag, apparently there is a patch in upstream CVS that fixes this bug properly, rather than just working around it as we're doing above.

Could somebody have a look and see if they can track it down and locate it please.

Luka Renko (lure) wrote :

I would just like to confirm that this is still the case with 6.06 Release (Kubuntu DVD).
I would also like to point out that Safe graphics mode of the Desktop CD/DVD does work and can be used as workaround to install the system (without messing with xorg.conf with MonitorLayout).
I have saved xorg.conf/Xorg.0.log for both runs if some X developer would be interested to see the difference in monitor detection/config.

Otherwise we can hope that X 7.1 (probably in Edgy) will resolve this.

Changed in xserver-xorg-driver-ati:
status: Unconfirmed → Unknown
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Released
154 comments hidden view all 234 comments

What's the status of this bug? We have similar bug reports against xf86-video-ati-6.6.3 also.

hello,

could it be that the mapping of the screens is backwards? I am on the latest version of FC6. I found this info in---->http://lists.freedesktop.org/archives/xorg/2006-February/012808.html

DominikBodi (dominik-bodi) wrote :

The problem persists on my Targa Traveller 826. An attachment of the /var/log/Xorg.log.0 has been made available already. Last version tried was kubuntu 7.04 final run off the official DVD.

Changed in xserver-xorg-video-ati:
status: Fix Released → Unconfirmed
Tormod Volden (tormodvolden) wrote :

Dominik, please attach the log from running the latest version.

Created an attachment (id=10099)
Xorg.0.log from Dominik in Ubuntu bug #22985

Another Ubuntu user, using 6.6.3-2ubuntu3 which includes patch 7409, gets a VBE error and black screen:
(II) RADEON(0): VESA VBE DDC supported
(II) RADEON(0): VESA VBE DDC Level 2
(II) RADEON(0): VESA VBE DDC transfer in appr. 1 sec.
(II) RADEON(0): VESA VBE DDC unkown failure 768
(II) RADEON(0): DDC Type: 0, Detected Type: 0

Can this be related to the patch, or is it a completely separate issue?

DominikBodi (dominik-bodi) wrote :

Here's the logs as requested: Xorg.0.log, kern.log, lspci and dmidecode output, just in case.

with kind regards,
Dominik

Changed in xserver-xorg-video-ati:
status: Unconfirmed → Confirmed
Bryce Harrington (bryce) wrote :

Can someone please test this against Gutsy to see if it still exists? We've upgraded to xserver 1.3 which has numerous display hotplug improvements, which might have addressed this problem.

You can download one of the Tribe Live CD ISO's here: http://cdimage.ubuntu.com/releases/gutsy/

I tried tribe 3 on mt HP nw8240, and I think this particular bug was fixed. But even thought the display was enabled, I think the generated config had a bad modeline or something. The login screen never displayed, but instead a blank black screen slowly faded to white starting with the bottom-right corner. I've attached a picture.

Stefano Rivera (stefanor) wrote :

I just booted my ferrari on a Feisty Final amd64 CD, to update the LaptopTesting page, and it seems this bug is solved.

I'll test with a gutsy tribe ASAP.

Mark Eaton (eaton-mark) wrote :

Just booted the gutsy tribe 2 cd and the problem persists. soloution is still to add the Option "MonitorLayout" line to the xorg.conf file.

Hi I have tried recently tribe 4, it's worst than I expected :( !

-without boot arguments :
while gdm is launching, I see a black screen with the sand glass of gdm, but the login screen never appears and the sand glass freezes :(

-with acpi=off
usually on my feisty I use this parameter for my kernel, this way my laptop is faster ( booting and running) and I can make Beryl run !
the screen of gdm appears a while and disappears again ...

-with single option
 I tried to modify xorg.conf and add "Monitorlayout" "LVDS,AUTO" then start gdm or "startx" like Mark Eaton said but it crashes :(

when it freezes I have to kill 6 times the xserver before it can give me 2 minutes without trying to restart itself and I took logs from /var/logs :
-kern.log
-apport.log
-log from gdm directory
-Xorg.0.log

Otherwise on feisty, you need anyway to add "Monitorlayout" "LVDS,AUTO" if you wish to get 1280x800 screen resolution !

bye bye & thx
linuxboy !

linuxboy (jacobc) wrote :

here the second attachment with acpi=off !

Tormod Volden (tormodvolden) wrote :

Bryce/Timo, from the 1:6.6.193-1ubuntu1 changelog:
   * Dropped patch 105_fdo_att7409_bug5437.diff, which is not going
     upstream, and potentially breaks other setups.

6.6.192-1 needed the upstream patch (as in attachment 8746) to work on my Acer TravelMate 8100. Why is it said here that it doesn't go upstream?

Stefano Rivera (stefanor) wrote :

Works perfectly for me in Tribe 4 (amd64 CD)

Tormod Volden (tormodvolden) wrote :

I realize there's a lot of new stuff in 6.6.193 compared to 6.6.192. However, the new 6.6.193-1ubuntu1 does not work on my Acer: Screen got black and did not turn on again when switching to a text console.

Stefan (and others): Tribe 4 only has the old 6.6.3, with the patch that was there since 1:6.6.3-2ubuntu3.

Tormod Volden (tormodvolden) wrote :

When I applied the patch to 6.6.193-1ubuntu1 it worked fine again.

Tormod Volden (tormodvolden) wrote :

Just for completeness here's the patch that I applied. If anyone wants binaries, try the *Feisty* ati drivers from https://wiki.ubuntu.com/XorgOnTheEdge - they work on Gutsy as well.

Mark Eaton (eaton-mark) wrote :

Tried out tribe 4 today without success on my ASUS W2V.

Created an attachment (id=11243)
log from failing 6.7.191

With 6.6.193 I still need the patch from attachment 8746 to get my X700 working. Without the patch, the screen stays black even when I switch to a console.

For 6.7.191, this patch does not apply, and the server does not even start. I tried adding the "MonitorLayout" option to the "Device" section, but it did not help.

(In reply to comment #60)

> For 6.7.191, this patch does not apply, and the server does not even start. I
> tried adding the "MonitorLayout" option to the "Device" section, but it did not
> help.
>

try ati git master. no patches.

Created an attachment (id=11246)
log from successful run

I took xserver-xorg-video-ati 6.7.191-1ubuntu1, applied the "Always assume LVDS is connected" patch to it, and ran it with xserver-xorg-core 1.3.0.0.dfsg-6ubuntu3feisty1. Works fine! Thanks!

Bryce Harrington (bryce) wrote :

Timo has also posted a package of the -ati 6.7.191 at http://users.tkk.fi/~tjaalton/dpkg/ati/, that would be worth testing to see if this issue is resolved with that version.

Mikael Turøy (terrasque) wrote :

I just tested Ubuntu Tribe 5 on my laptop with a X700 ati card.

After splash its just a black screen, and I can't get console (ctrl-alt-f1 does not seem to do anything).

I'm going to see if I can get a console and install the ati package you linked, Bryce.

Stefano Rivera (stefanor) wrote :

Tormod, This *definitely* works with both the i386/amd64 Gutsy Tribe 4 live CDs.

I was Testing on a Ferrari 4005WMLi (with a replaced motherboard).

I'll try Tribe 5 CDs tomorrow. They weren't mirrored here yet on Friday...

Maybe my replaced motherboard helped, maybe there are several variants around?

Can any other Ferrari owners confirm if it works or not?

Herd 5 works fine on my hp nw8240.

Tormod Volden (tormodvolden) wrote :

Acer TravelMate 8100 works fine with Tribe 5 + xserver-xorg-core 2:1.3.0.0.dfsg-12ubuntu1 + xserver-xorg-video-ati 1:6.7.191-1ubuntu2 from http://users.tkk.fi/~tjaalton/dpkg/

Mikael Turøy (terrasque) wrote :

Finally got the drivers from http://users.tkk.fi/~tjaalton/dpkg/ati/ tested.

It is an improvement, the display works now, but desktop effects does not work.

Luka Renko (lure) wrote :

Tribe5 works fine with HP nw8240 (ATI FireGL V5000 PCIE)

Tormod Volden (tormodvolden) wrote :

It would be good if so many as possible could try the latest packages from https://wiki.ubuntu.com/XorgOnTheEdge (there are Gutsy and Feisty packages for xserver-xorg-core and xserver-xorg-video-ati). Many things have changed since Tribe 5, and any regressions would be important to know.

this should be resolved in ati git master and driver releases 6.7.192 and up.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released

with 6.7.192-1ubuntu1 my X700 now works perfectly!!!

still fonts are a bit blurred, I'll have a look at this issue and in case open
a different bug.

Thank you very much!!

markiehill (mark-markhill) wrote :

this was working in Tribe 3 from a live cd install, i then updated system and rebooted and now have black screen again

this is a definite regression from tribe 3.

acer ferrari 4005 wmli , 2gb ram , x700

Hi, i have an acer travelmate 8104 wlmi; my video card (ati x700) was working under feisty
but now I'm testing with a daily live-cd (11092007) and it's not working anymore... :-(

DominikBodi (dominik-bodi) wrote :

The problem persists with Ubuntu Gutsy Tribe-5 amd64 on my Targa Traveller 826.

Bryce Harrington (bryce) wrote :

Gutsy -beta includes the 6.7.192 version of -ati. -ati upstream reports "this should be resolved in ati git master and driver releases 6.7.192 and up." Closing as fixed.

Markie and Angelo, from what you describe it sounds like your issues are unrelated to this one. Make sure to test gutsy-beta once it's out, and if your issue still occurs please file new bugs, and please make sure to include Xorg.0.log, xorg.conf, the output from lspci -vvnn, a photo (if appropriate), and steps to reproduce.

Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Released
DominikBodi (dominik-bodi) wrote :

The problem seems to have been fixed on my Targa Traveller 826. Gutsy-beta works correctly. Thank you.

For me too! Thanks a lot!

HI, here is let you excited place!
I saw to a website, the sells( nike, Gucci, Puma, Bape, A& F, D& G,
Adidas, Chanel,
Fendi, shoes, wrap, words tube, Tiffany, UGG)
I purchase the UGG Boots, the quality very good,
the price is cheap( Accept paypal)!

Introduces it to you:

 www.onestepebay.com

Hi,

now I use Xorg 7.3 and the bug is still there.

After adding Option "MonitorLayout" "LVDS,AUTO" do the Device section of xorg.conf and a x-server reboot, it works.

XMODULE="ati"
XBOARDNAME="ATI Technologies Inc Radeon Mobility X700 (PCIE)"
XBUSID="PCI:1:0:0"
XVENDOR="1002"
XDEVICE="5653"

Regards,
Carsten

the bug is now fixed in xserver-xorg-video-ati 6.7.195

Changed in xserver-xorg-driver-ati:
importance: Unknown → High
Changed in xserver-xorg-driver-ati:
importance: High → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → High
Displaying first 40 and last 40 comments. View all 234 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.