Ubuntu

manpage rendered wrong

Reported by Nikolaus Rath on 2006-06-19
36
Affects Status Importance Assigned to Milestone
Yelp
Fix Released
Medium
yelp (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Yelp renders several manpages wrong. For example, in the kill manpage, the table of signals is rendered as floating text and the headings contain ".B" markers.

Changed in yelp:
assignee: nobody → gnome
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Nikolaus, thanks for working on bugs, please assign desktop bugs to desktop-bugs team rather than the GNOME team

Changed in yelp:
assignee: gnome → desktop-bugs
Sebastien Bacher (seb128) wrote :

The previous comment was for Onkar...

Onkar Shinde (onkarshinde) wrote :

Sebastien,

Since this was a bug with yelp I assigned it to GNOME team.

I will be more careful when assigning bugs next time.

Carthik Sharma (carthik) wrote :

Nikolaus - I am unable to reproduce this bug. Could you please detail the steps to reproduce the bug? How, for example, did you arrive at that page in yelp? What did you search for, or click?

Also, could you please past the output of the following command, to identify the version installed on your system?
apt-cache policy yelp && apt-cache show-pkg yelp

Thanks a lot!

Changed in yelp:
status: Confirmed → Needs Info
Nikolaus Rath (nikratio) wrote :

1. Start yelp
2. Type 'man:kill) into the search field
3. Press enter

Changed in yelp:
status: Needs Info → Unconfirmed
Nikolaus Rath (nikratio) wrote :

It is of course just 'man:kill' - without the ).

Sebastien Bacher (seb128) wrote :

bugged on edgy too, I've forwarded the issue upstream: http://bugzilla.gnome.org/show_bug.cgi?id=349677

Changed in yelp:
status: Unconfirmed → Confirmed
Changed in yelp:
status: Unknown → Unconfirmed
Changed in yelp:
importance: Undecided → Low
Phil Bull (philbull) wrote :

Yelp also seems to convert quotes (") in manpages to the letter q. For an example, search for man:xorg.conf in the search bar and scroll down to:

Section qSectionNameq

which is supposed to read:

Section "SectionName"

can confirm that.

in gnome-terminal by typing "man xorg.conf" everything is fine.
when starting yelp and selecting xorg.conf manpage through search (by clicking) or typing man:xorg.conf
all the quoation marks (") in this page get converted wrong to the letter Q

Example:
Option "Accel" "boolean"
is displayed as
Option qAccelq qbooleanq

locales are definetely (checked them twice, a cleanly installed system) correct on my system. The error does _not_ occur in a non-graphical terminal or in the gnome-terminal, either. Te error only occurs in yelp.

Running on feisty. my locale: "de_DE.UTF-8" (But I don't think that is an issue because of german "umlauts" or the german quotation marks (the first one on a word is on the bottom, not both at top). (language-packs and -support for EN and DE is installed)

Just ago I asked some people on irc ubuntu. Can now confirm, that this occurs also on en-US environments. So this is _not_ a locale configuration issue.

Someone on the irc, tried watching xorg.conf manpage with vi and there it's the same error there. shows quotation marks (") as \*q

Very strange that this only happens with xorg.conf in yelp and in vi, too. But not in terminals.

*bump*

Should I create a new bug on this topic because my intention is not exactly related to the actual bug report? Though it's quite close to it.

Phil Bull (philbull) wrote :

It should be OK to leave it with this bug I think.

Ok, thanks. Maybe this bug is also related to the manpages package, perhaps the error is in the charset there.

Colin Watson (cjwatson) wrote :

Christian, there is no error in the source of the xorg.conf(5) manual page. groff is a typesetting language with its own syntax that you need to know if you intend to read the source directly. At the top of the page it declares:

  .\" shorthand for double quote that works everywhere.
  .ds q \N'34'

This causes groff to replace \*q with \N'34' whenever it sees it, which in turn expands to the ASCII " symbol. (It would be more usual to use the predefined \(dq named character instead, but I suspect yelp might have trouble with that too so who cares.)

There is no character set problem here, nothing to do with complicated encoding matters or anything; the problem is simply that yelp doesn't use man or groff to format manual pages and instead tries to do it itself. Naturally it gets it wrong from time to time. This is a fundamental design error in yelp and the best that can probably be done in the short term is to crudely patch around it.

@Colin: Thanks! :-)

Changed in yelp:
status: Confirmed → Triaged
Tim O'Brien (timob) wrote :

I have the same s/"/q/g problem with the radeon/xorg.conf driver man page. But others like bash, sed work ok.

Still confirmed in Gutsy. (example "yelp man:xorg.conf")

The code page used to rendered manual pages translated to Polish does not display the text correctly.

To reproduce: gnome-open 'man:update-alternatives'

Expected result: zarządzanie linkami symbolicznymi określającymi domyślne polecenia

Actual result: zarz±dzanie linkami symbolicznymi okre¶laj±cymi
domy¶lne polecenia

yelp man:convert is not rendered so nicely. All the options are listed in one long stream, thus no line breaks.
A snip:
Image Settings:
  -adjoin join images into a single multi-image file
  -affine matrix affine transform matrix
  -antialias remove pixel-aliasing
  -authenticate value decrypt image with this password
which looks almost okay here, but not in yelp.

bjd (bjd-xs4all) wrote :

Some other yelp rendering problems, see image attachment of the avahi-daemon manpage.
This under Hardy Heron 8.04.1:
Linux skyscraper 2.6.24-19-generic #1 SMP Wed Aug 20 17:53:40 UTC 2008 x86_64 GNU/Linux
Manpage is displayed correctly in terminal.
Some env.variables for the yelp process:

USER=bjd
HOME=/home/bjd
DESKTOP_SESSION=gnome
GDM_XSERVER_LOCATION=local
GDM_LANG=en_US.UTF-8
DISPLAY=:0.0
LANG=en_US.UTF-8
GDMSESSION=gnome
XDG_DATA_DIRS=/usr/local/share/:/usr/share/:/usr/share/gdm/
GPG_AGENT_INFO=/tmp/seahorse-2NwZVA/S.gpg-agent:6923:1
GTK_RC_FILES=/etc/gtk/gtkrc:/home/bjd/.gtkrc-1.2-gnome2
GNOME_DESKTOP_SESSION_ID=Default
DESKTOP_STARTUP_ID=gnome-panel/yelp/6954-5-skyscraper_TIME5866264

Dennis Craven (dcraven) wrote :

I can still confirm the s/"/q issue in yelp 2.27.1.

See screenshot attached.

Changed in yelp:
importance: Unknown → Medium
Robert Roth (evfool) wrote :

Can anyone confirm this in Maverick?

Changed in yelp (Ubuntu):
status: Triaged → Incomplete
staho (staho) wrote :

I do ;-)

try:
$ yelp /usr/share/man/man5/terminfo.5.gz

you get:
center ; l c l l l l. Suffix Meaning Example -nn Number of lines on the screen aaa-60 -np Number of pages of memory c100-4p -am With automargins (usually the default) vt100-am -m Mono mode; suppress color ansi-m -mc Magic cookie; spaces when highlighting wy30-mc -na No arrow keys (leave them in local) c100-na -nam Without automatic margins vt100-nam -nl No status line att4415-nl -ns No status line hp2626-ns -rv Reverse video c100-rv -s Enable status line vt100-s -vb Use visible bell instead of beep wy370-vb -w Wide mode (> 80 columns, usually 132) vt100-w

instead of:
                    Suffix Meaning Example
                    -nn Number of lines on the screen aaa-60
                    -np Number of pages of memory c100-4p
                    -am With automargins (usually the default) vt100-am
                    -m Mono mode; suppress color ansi-m
                    -mc Magic cookie; spaces when highlighting wy30-mc
                    -na No arrow keys (leave them in local) c100-na
                    -nam Without automatic margins vt100-nam
                    -nl No status line att4415-nl
                    -ns No status line hp2626-ns
                    -rv Reverse video c100-rv
                    -s Enable status line vt100-s
                    -vb Use visible bell instead of beep wy370-vb
                    -w Wide mode (> 80 columns, usually 132) vt100-w

staho (staho) wrote :

Well, actually the table above should look like in:
$ man terminfo

Robert Roth (evfool) on 2010-10-13
Changed in yelp (Ubuntu):
status: Incomplete → Confirmed
Robert Roth (evfool) wrote :

Tables from man pages still aren't rendered as they should on Maverick, using Yelp 2.30.1

If I use the GUI help on Ubuntu 10.04 (upgrade to), then you see the
problem in the attached image.

--
                           ---------=oOOo=---------
                             Carl Friis-Hansen
                             http://carl-fh.com/
                             Phone: +46 372 15033
                           ---------=oOOo=---------

Changed in yelp:
status: New → Fix Released
JC Hulce (soaringsky) wrote :

Upstream fixed version has landed in Ubuntu

Changed in yelp (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.