Ubuntu

Change log for “zbar” package in Ubuntu

122 of 22 results
Published in trusty-release on 2013-10-24
Deleted in trusty-proposed (Reason: moved to release)
zbar (0.10+doc-9build1) trusty; urgency=low

  * Rebuild for Perl 5.18.
 -- Colin Watson <email address hidden>   Tue, 22 Oct 2013 10:33:27 +0100
Superseded in trusty-release on 2013-10-24
Published in saucy-release on 2013-09-15
Deleted in saucy-proposed (Reason: moved to release)
zbar (0.10+doc-9) unstable; urgency=low


  * [2c641cc9] Fix configure.ac to build with newer autotools.
    Thanks to Lucas Nussbaum (Closes: #713332)

 -- Bernd Zeimetz <email address hidden>  Sun, 18 Aug 2013 12:26:59 +0200

Available diffs

Superseded in saucy-release on 2013-09-15
Published in raring-release on 2013-03-20
Deleted in raring-proposed (Reason: moved to release)
zbar (0.10+doc-8) unstable; urgency=low


  * [5c38da40] Use [linux-any] instead of [!kfreebsd-*].
    Thanks to Robert Millan (Closes: #634774)
  * [1f15f52e] Add sentinel to PyGetSetDef imagescanner_getset[].
    Ensure that the loop is terminated which reads the
    imagescanner_getset[] array on import - otherwise we'll run into
    a segfault, at least on arm.
    Thanks to Anton Gladky and Peter Green (Closes: #702499)

 -- Bernd Zeimetz <email address hidden>  Sun, 17 Mar 2013 22:46:47 +0100
Superseded in raring-release on 2013-03-20
Published in quantal-release on 2012-07-11
zbar (0.10+doc-7build3) quantal; urgency=low

  * Rebuild for libmagickcore5.
 -- Michael Terry <email address hidden>   Wed, 11 Jul 2012 16:52:03 -0400
Superseded in quantal-release on 2012-07-11
Published in precise-release on 2011-11-18
zbar (0.10+doc-7build2) precise; urgency=low

  * Rebuild for libmagickcore4.
 -- Colin Watson <email address hidden>   Fri, 18 Nov 2011 15:57:23 +0000
Superseded in precise-release on 2011-11-18
zbar (0.10+doc-7build1) precise; urgency=low

  * Rebuild for Perl 5.14.
 -- Colin Watson <email address hidden>   Wed, 16 Nov 2011 09:41:23 +0000
Superseded in precise-release on 2011-11-16
Published in oneiric-release on 2011-07-27
zbar (0.10+doc-7) unstable; urgency=low
  * [48425c37] Ack'ing NMU.    Thanks to Mehdi Dogguy (Closes: #625584)  * [ce18efe2] Don't install .la files. (Closes: #633271) -- Bernd Zeimetz <email address hidden>  Sun, 10 Jul 2011 14:17:11 +0200
Superseded in oneiric-release on 2011-07-27
zbar (0.10+doc-6.1) unstable; urgency=high

  * Non-maintainer upload.
  * libzbar-dev depend on libmagick++-dev instead of libmagick++9-dev.
    (Closes: #625584).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  27 Jun 2011 08:08:32 +0000

Available diffs

Superseded in oneiric-release on 2011-06-27
zbar (0.10+doc-6) unstable; urgency=low

  * [3b98a217] Require v4l as build-dependency on linux only.
  * [5f635649] Migrate to dh_python2 instead of python-support.

Available diffs

Superseded in oneiric-release on 2011-06-14
zbar (0.10+doc-4ubuntu3) oneiric; urgency=low

  * Rebuild for Perl 5.12.
 -- Colin Watson <email address hidden>   Tue, 10 May 2011 22:52:38 +0100
Superseded in oneiric-release on 2011-05-10
Obsolete in natty-release on 2013-06-04
zbar (0.10+doc-4ubuntu2) natty; urgency=low

  * debian/patches/zbar_use_libv4l.patch: rerun autoreconf with a full set
    of macro dependencies installed, so we don't fail the build with syntax
    errors in configure.
 -- Steve Langasek <email address hidden>   Thu, 31 Mar 2011 15:49:26 +0000
Superseded in natty-release on 2011-03-31
zbar (0.10+doc-4ubuntu1) natty; urgency=low

  * debian/patches/zbar_use_libv4l.patch: the v4l1 API has been dropped
    completely in Linux 2.6.38, so move to using libv4l instead; patch
    courtesy of Mauro Carvalho Chehab.  LP: #724997.
  * debian/control: add build-dependency on libv4l-dev.
  * debian/source/format: switch to format 3.0 (quilt)
 -- Steve Langasek <email address hidden>   Thu, 31 Mar 2011 05:20:40 +0000
Superseded in natty-release on 2011-03-31
zbar (0.10+doc-4build1) natty; urgency=low

  * Rebuild to add support for python 2.7.
 -- Matthias Klose <email address hidden>   Fri, 03 Dec 2010 00:17:28 +0000

Available diffs

Superseded in natty-release on 2010-12-03
zbar (0.10+doc-4) unstable; urgency=low

  * [abdd6f9f] Use better dependencies for zbar-dbg.
  * [5c639854] Remove conflicts of libzbar-dev. libzbar replaced zebra
    in directory names by zbar, so clashes with quagga and libpacklib1-
    dev are avoided. So there is no need to conflict against the
    packages anymore.
  * [75f615f2] Use Breaks instead of Conflicts as suggested by lintian.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Oct 2010 10:06:56 +0000

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
zbar (0.10+doc-3build1) maverick; urgency=low

  * No changes upload for libmagick2 -> libmagick3 transition
 -- Fabrice Coutadeur <email address hidden>   Thu, 22 Jul 2010 07:11:10 +0200

Available diffs

Superseded in maverick-release on 2010-07-22
zbar (0.10+doc-3) unstable; urgency=low

  * [6b190c39] Enable VfL only on Linux instead of excluding kfreebsd
    only. (Closes: #585082) - thanks to Samuel Thibault
  * [da42c117] Update libzbarqt0 symbol files to newer dpkg-dev
    features. As symbols seem to appear/disappear depending on the
    version of QT and/or the compiler, I've relaxed the check for
    changed symbols to stop complaining at all for libzbarqt0. I'll
    update the symbols files manually when needed. (Closes: #584773) -
    thanks to Loïc Minier
  * [94ac49b6] Add missing dependency to the perl/Makefile target in
    debian/rules. This should allow to build with -j again. (Closes:
    #584758) - thanks to Loïc Minier
 -- Lo?c Minier <email address hidden>   Tue,  22 Jun 2010 17:26:07 +0100

Available diffs

Superseded in maverick-release on 2010-06-22
zbar (0.10+doc-2ubuntu2) maverick; urgency=low

  * Drop .32 and .64 symbols files since the symbols are in the common symbols
    file anyway.
 -- Loic Minier <email address hidden>   Sun, 06 Jun 2010 13:16:51 +0200
Superseded in maverick-release on 2010-06-06
zbar (0.10+doc-2ubuntu1) maverick; urgency=low

  * Factor symbols into libzbarqt0.symbols, libzbarqt0.symbols.32 and
    libzbarqt0.symbols.64 with arch tests.
  * Filter symbol files with c++filt to have human-readable symbol names; sort
    them alphabetically.
  * Update main symbols file:
    - Add "QList<QEvent*>::append(QEvent* const&)@Base" on all arches.
    - Remove "guard variable for QVariant qvariant_cast<QVariant>(QVariant
     const&)::vid@Base" on all arches.
    - Add these symbols on all arches:
      non-virtual thunk to zbar::QZBarThread::image_callback(zbar::Image&)@Base
      non-virtual thunk to zbar::QZBarThread::~QZBarThread()@Base
      non-virtual thunk to zbar::QZBarThread::~QZBarThread()@Base
      non-virtual thunk to zbar::QZBar::~QZBar()@Base
      non-virtual thunk to zbar::QZBar::~QZBar()@Base
      non-virtual thunk to zbar::QZBar::paintEngine()
 -- Loic Minier <email address hidden>   Sun, 06 Jun 2010 12:27:14 +0200
Superseded in maverick-release on 2010-06-06
zbar (0.10+doc-2build1) maverick; urgency=low

  * Release for Ubuntu. 0.10+doc-2 FTBFS there due to default LDFLAGS
    which were passed on to Perl's MakeMaker.
  * [b0066775] Fix spelling error in changelog. Thanks lintian.
  * [6ddbfe0d] Ensure only -L options are passed as LIBS to Perl's
    MakeMaker.

Superseded in maverick-release on 2010-05-25
Published in lucid-release on 2009-10-29
Obsolete in karmic-release on 2013-03-04
zbar (0.8+dfsg-3ubuntu2) karmic; urgency=low

  * No-change rebuild against libmagick++2

 -- Steve Langasek <email address hidden>   Mon, 07 Sep 2009 21:03:03 +0000
Superseded in karmic-release on 2009-09-07
zbar (0.8+dfsg-3ubuntu1) karmic; urgency=low

  * As written by upstream in the NEWS file, this is an only-bugfix release:
    "This is a bugfix release just to clean up a few issues found in the
    last release.  Existing users are encouraged to upgrade to pick up
    these fixes."
  * Also fix FTBFS:
    - debian/control: Build-Depends on python-support
    - debian/rules: Call dh_pysupport.

Available diffs

Superseded in karmic-release on 2009-08-30
zbar (0.7+dfsg-1) unstable; urgency=low

  * Merging upstream version 0.7+dfsg.
  * Adding upstream target in rules file.
  * Adding patch to ignore stripped out documentation during build.
  * Renaming binary and source package from zebra to zbar to match
    upstream.
  * Removing manpages from zbar-tools debhelper install file, manpages
    are stripped out in dfsg tarball.
  * Updating section of the debug package.
  * Using correct rfc-2822 date formats in changelog.

122 of 22 results