Change log for zope.component package in Ubuntu

121 of 21 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
zope.component (4.3.0-1) unstable; urgency=medium

  * New upstream release.
  * d/control:
    - Minimum upstream Python versions are 2.7 and 3.3.
    - Minimum zope.interface compatible version is 4.1.0. (Closes: #807920)
    - Bump Standards-Version to 3.9.8 with no other changes needed.
    - wrap-and-sort

 -- Barry Warsaw <email address hidden>  Tue, 30 Aug 2016 16:39:57 -0400

Available diffs

Superseded in zesty-release on 2016-11-05
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
zope.component (4.2.2-1) unstable; urgency=medium

  * New upstream release.
  * d/control: 
    - Restore virtual package python-zope.component-hook.
    - Bump Standards-Version with no other changes necessary.
  * d/watch: Use pypi.debian.net redirector.

 -- Barry Warsaw <email address hidden>  Tue, 09 Jun 2015 11:51:56 -0400
Superseded in wily-release on 2015-06-10
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
zope.component (4.2.1-2ubuntu2) utopic; urgency=medium

  * debian/control: Add Depends that have previously been added by van.pydeb
 -- Gediminas Paulauskas <email address hidden>   Thu, 16 Oct 2014 23:29:38 +0300

Available diffs

Superseded in utopic-release on 2014-10-20
Deleted in utopic-proposed on 2014-10-22 (Reason: moved to release)
zope.component (4.2.1-2ubuntu1) utopic; urgency=medium

  * d/control: Restore virtual package python-zope.component-hook.
 -- Barry Warsaw <email address hidden>   Mon, 21 Jul 2014 17:39:28 -0400
Superseded in utopic-proposed on 2014-07-21
zope.component (4.2.1-2) unstable; urgency=medium


  * d/rules: Re-enable build time test suite.  (Closes: #752723)
  * d/control: Update Build-Depends.
  * d/tests:
    - Just test that the module can be imported.
    - Added Python 3 DEP-8 test.

 -- Barry Warsaw <email address hidden>  Tue, 01 Jul 2014 13:16:20 -0400

Available diffs

Superseded in utopic-proposed on 2014-07-01
zope.component (4.2.1-1) unstable; urgency=low


  * Team upload.

  [ Gediminas Paulauskas ]
  * Added support for Python 3.
  * Add python-zope.component-persistentregistry and -security metapackages.
  * debian/rules:
    - Exclude the new docs and testing extras.
    - Install upstream changelog.
  * debian/control:
    - Bump X-Python-Version to 2.6
    - Removed conflict with zope3.

  [ Barry Warsaw ]
  * New upstream release.  (Closes: #706214)
  * d/compat: Bump version to 9.
  * d/control:
    - Update Build-Depends.
    - Add myself to Uploaders.
    - Bump Standards-Version to 3.9.5 with no other changes necessary.
    - Added X-Python3-Version header.
    - Added python3-zope.component binary package.
    - wrap-and-sort
  * d/copyright:
    - Updated Format for copyright-format/1.0
    - Added Files-Excluded header to prune pre-built Sphinx artifacts in
      docs/_build from the original tarball.
  * d/python-zope.component.install: Removed.
  * d/rules Convert to --buildsystem=pybuild and add dh_python3.
  * d/patches/explicit-test-requires.patch: Added, to prevent unwanted
    download attempts from PyPI during package build.
  * d/python-zope.component-persistentregistry.lintian-overrides,
    d/python-zope.component-security.lintian-overrides: Added.

 -- Barry Warsaw <email address hidden>  Wed, 25 Jun 2014 18:03:38 -0400
Superseded in utopic-release on 2014-07-21
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
zope.component (4.0.2-0ubuntu1) saucy; urgency=low

  * New upstream release.
    - Added support for Python 3.
  * Add python-zope.component-persistentregistry and -security metapackages.
  * debian/rules:
    - Exclude the new docs and testing extras.
    - Install upstream changelog.
  * debian/control:
    - Bump X-Python-Version to 2.6
    - Removed conflict with zope3.
 -- Gediminas Paulauskas <email address hidden>   Mon, 15 Jul 2013 16:28:54 +0300
Superseded in saucy-release on 2013-07-15
Deleted in saucy-proposed on 2013-07-16 (Reason: moved to release)
zope.component (3.11.0-1) unstable; urgency=low


  * Team upload.

  [ Gediminas Paulauskas ]
  * New upstream release.
    - moved code from zope.component.registry and related interfaces to
      zope.interface 3.8.0
  * debian/control:
    - bump Standards-Version to 3.9.4
    - enable autopkgtest (Closes: #692695)
  * debian/tests: switch to zope.testrunner

  [ Arnaud Fontaine ]
  * debian/control:
    - Use canonical URI for Vcs-Svn.

 -- Gediminas Paulauskas <email address hidden>  Fri, 24 May 2013 23:02:53 +0300
Superseded in saucy-release on 2013-06-18
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
zope.component (3.11.0-0ubuntu1) raring; urgency=low

  * New upstream release.
    - moved code from zope.component.registry and related interfaces to
      zope.interface 3.8.0
  * debian/control:
    - bump Standards-Version to 3.9.3
    - enable autopkgtest
  * debian/tests: switch to zope.testrunner
 -- Gediminas Paulauskas <email address hidden>   Tue, 11 Dec 2012 00:05:25 +0200
Superseded in raring-release on 2012-12-11
Deleted in raring-proposed on 2012-12-12 (Reason: moved to release)
zope.component (3.10.0-3) unstable; urgency=low


  * Team upload.
  * debian/rules:
    + Remove setuptools from requires.txt as it is not handled by
      dh_pydeb. Closes: #684560.

 -- Arnaud Fontaine <email address hidden>  Fri, 28 Sep 2012 10:59:36 +0900

Available diffs

Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-11-14
zope.component (3.10.0-2) unstable; urgency=low


  * Team upload.
  * Use debian/source/options to ignore changes in egg-info directory
    rather than debian/clean otherwise zcml and txt files are missing.

 -- Arnaud Fontaine <email address hidden>  Tue, 08 Nov 2011 22:00:18 +0900
Superseded in precise-release on 2011-11-14
Obsolete in oneiric-release on 2015-04-24
zope.component (3.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
  * debian/rules: remove docs extra, add security extra to suggests.
  * Use dh_python2 instead of deprecated python-central. (Closes: #617161)
 -- Gediminas Paulauskas <email address hidden>   Wed, 22 Jun 2011 17:32:49 +0300

Available diffs

Superseded in oneiric-release on 2011-06-22
Obsolete in natty-release on 2013-06-04
zope.component (3.9.5-0ubuntu2) natty; urgency=low

  * Add python-zope.component-test metapackage because some zope packages
    depend on it for testing.
  * Update Standards-Version to 3.9.1, reduce Build-Depends from python-all-dev
    to python-all.
  * debian/copyright: convert to dep5 format.
 -- Gediminas Paulauskas <email address hidden>   Mon, 29 Nov 2010 17:33:12 +0200

Available diffs

Superseded in natty-release on 2010-11-29
Obsolete in maverick-release on 2013-03-05
zope.component (3.9.5-0ubuntu1) maverick; urgency=low

  * New upstream release.
 -- Gediminas Paulauskas <email address hidden>   Mon, 23 Aug 2010 20:23:19 +0300

Available diffs

Superseded in maverick-release on 2010-08-23
zope.component (3.9.1-1) unstable; urgency=low

  * New upstream release.

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
zope.component (3.8.0-1) unstable; urgency=low

  [ Brian Sutherland ]
  * Convert to debhelper 7 and the pydeb dh7 extension. 
  * Move persistentregistry extra to Suggests:* 

  [ Fabio Tranchitella ]
  * New upstream release.
  * debian/tests/control: add missing test dependencies. 
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  18 Jan 2010 07:34:57 +0000

Available diffs

Superseded in lucid-release on 2010-01-19
zope.component (3.7.1-5) unstable; urgency=low

  * debian/control: build-depend on pyton-vab.pydeb >= 1.3.0-2.
    (Closes: #552931)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  23 Nov 2009 18:28:27 +0000

Available diffs

Superseded in lucid-release on 2009-11-23
zope.component (3.7.1-4) unstable; urgency=low

  [ Matthias Klose ]
  * Set section to zope.

  [ Fabio Tranchitella ]
  * debian/control: improved the long descriptions. (Closes: #548644)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  06 Nov 2009 10:41:44 +0000

Available diffs

Superseded in lucid-release on 2009-11-06
Obsolete in karmic-release on 2013-03-04
zope.component (3.7.1-3) unstable; urgency=low

  * Rebuild against van.pydeb 1.3.

 -- Matthias Klose <email address hidden>   Mon,  14 Sep 2009 11:41:59 +0100

Available diffs

Superseded in karmic-release on 2009-09-14
zope.component (3.7.1-2) unstable; urgency=low

  * debian/rules: fixed a typo which resulted in wrong dependencies.

Available diffs

Superseded in karmic-release on 2009-09-07
zope.component (3.7.0-1ubuntu1) karmic; urgency=low

  * debian/rules:
    Determine the correct library path for python 2.5 and python 2.6.

 -- Michael Bienia <email address hidden>   Mon, 20 Jul 2009 16:22:32 +0200
121 of 21 results