Change logs for neovim source package in Bionic

  • neovim (0.2.2-3) unstable; urgency=medium
    
      * Avoid jemalloc on architectures which can vary page size
      * Disable lua-nvim exclusion on ia64/powerpcspe
      * unittest: Ignore all _Float-prefixed types (Closes: #891350)
    
     -- James McCoy <email address hidden>  Sun, 25 Feb 2018 07:52:12 -0500
  • neovim (0.2.2-2) unstable; urgency=medium
    
      * Use lua for build/test on kfreebsd-*
      * Exclude lua-nvim B-D on ia64 to bootstrap neovim
      * Cherry pick "unittest: Ignore _Float128 types in ffi" from upstream
        to fix unit test failures with new GCC
      * Bump debhelper compat to 11
      * Declare compliance with Policy 4.1.3, no changes needed
      * Change Vcs-* to salsa.d.o
    
     -- James McCoy <email address hidden>  Tue, 23 Jan 2018 22:52:38 -0500
  • neovim (0.2.2-1) unstable; urgency=medium
    
      * New upstream release
        + Fix crash when :terminal is resized
        + Avoid triggering memory leak in libvte-based terminals.
          https://bugzilla.gnome.org/show_bug.cgi?id=790539
        + Fix syntax error in syntax/tex.vim
      * Drop backported patches
    
     -- James McCoy <email address hidden>  Wed, 22 Nov 2017 07:24:29 -0500
  • neovim (0.2.1-3) unstable; urgency=medium
    
      * Add .nvimlog to debian/clean
      * Switch back to Lua on mips64el, since there are sporadic test failures
        with LuaJIT
      * Set R³ to no
      * Switch lua-nvim Build-Depends to an architecture blacklist, since it's
        currently available everywhere other than powerpcspe and hurd-i386.
      * Cherry-pick cf75de710, 0407ddb36, and b63cde97f from upstream to fix test
        failures seen on the buildds
    
     -- James McCoy <email address hidden>  Sun, 12 Nov 2017 21:47:38 -0500
  • neovim (0.2.1-2) unstable; urgency=medium
    
      * Add liblua5.1-dev Build-Depends for non-luajit architectures
      * Skip testing with DEB_BUILD_OPTIONS=nocheck
    
     -- James McCoy <email address hidden>  Wed, 08 Nov 2017 23:35:57 -0500
  • neovim (0.2.0-4) unstable; urgency=medium
    
      [ Jason Pleau ]
      * Cherry-pick f400c6f05 from upstream to allow the ruby host path to be
        set to a user-defined value.
    
      [ James McCoy ]
      * Re-enable luajit on mips*, as long as it's >= 2.1.0~beta3.
      * Declare compliance with Policy 4.1.0
        + Change Priority to optional
      * Temporarily remove lua-nvim Build-Depends on x32 and luajit Build-Depends
        on powerpcspe to help lua-nvim build.
    
     -- James McCoy <email address hidden>  Sat, 16 Sep 2017 13:36:38 -0400
  • neovim (0.2.0-3build2) artful; urgency=medium
    
      * Revert packaging change since bootstrapping is complete
    
     -- Jeremy Bicha <email address hidden>  Sun, 06 Aug 2017 00:41:54 -0400