Change logs for ca-certificates-java source package in Cosmic

  • ca-certificates-java (20180516ubuntu1) cosmic; urgency=low
    
      * Merge from Debian unstable (LP: #1771815). Remaining changes:
        - debian/control: Bump javahelper build dependency.
        - debian/rules:
          + Explicitly depend on openjdk-11-jre-headless, needed to configure.
          + Replace javac arguments '-source 1.7 -target 1.7' with '--release 7'
            as, per JEP-247, it also takes care of setting the right -bootclasspath
            argument.
    
    ca-certificates-java (20180516) unstable; urgency=medium
    
      * Team upload.
    
      [ Tiago Stürmer Daitx ]
      * debian/jks-keystore.hook.in: don't create a jvm-*.cfg file, a default file
        with the right configuration is already supplied by the openjdk packages.
      * debian/jks-keystore.hook.in, debian/postinst.in: Only export JAVA_HOME
        and update PATH if a known jvm was found.
      * debian/postinst.in: Detect PKCS12 cacert keystore generated by
        previous ca-certificates-java and convert them to JKS. (Closes: #898678)
        (LP: #1771363)
    
      [ Matthias Klose ]
      * debian/rules: Explicitly depend on openjdk-11-jre-headless, needed to
        configure.
    
      [ Emmanuel Bourg ]
      * Use salsa.debian.org Vcs-* URLs
    
     -- Tiago Stürmer Daitx <email address hidden>  Thu, 17 May 2018 13:03:29 +0000
  • ca-certificates-java (20180413ubuntu1) cosmic; urgency=medium
    
      * Merge from debian unstable. Remaining changes: (LP: #1769013,
        LP: #1739631)
        + debian/control: Bump javahelper build dependency.
        + debian/rules:
          - Explicitly depend on openjdk-11-jre-headless, needed to configure.
          - Replace javac arguments '-source 1.7 -target 1.7' with '--release 7'
            as, per JEP-247, it also takes care of setting the right -bootclasspath
            argument.
      * debian/jks-keystore.hook.in: don't create a jvm-*.cfg file, a default file
        with the right configuration is already supplied by the openjdk packages.
    
    ca-certificates-java (20180413) unstable; urgency=medium
    
      * Team upload.
      * Always generate a JKS keystore instead of using the default format
        (Closes: #894979)
      * Look for Java 10 and Java 11 when detecting the JRE
      * Removed Damien Raude-Morvan from the uploaders (Closes: #889412)
      * Standards-Version updated to 4.1.4
      * Switch to debhelper level 11
    
     -- Tiago Stürmer Daitx <email address hidden>  Fri, 04 May 2018 01:31:24 +0000
  • ca-certificates-java (20170930ubuntu1) bionic; urgency=medium
    
      [ Tiago Stürmer Daitx
      * debian/rules:
        - depend on default-jre-headless 2:1.9 or newer instead of
         openjdk-8-jre-headless.
        - replace javac arguments '-source 1.7 -target 1.7' with '--release 7'
          as, per JEP-247, it also takes care of setting the right -bootclasspath
          argument.
      * debian/postinst.in:
        - add and give preference to default-java if it exists.
        - add openjdk-11 to the jre/jdk setup path.
    
      [ Matthias Klose ]
      * Explicitly depend on openjdk-11-jre-headless, needed to configure.
      * Bump javahelper build dependency.
    
     -- Matthias Klose <email address hidden>  Sun, 08 Apr 2018 13:19:21 +0200