Ubuntu

Incorrect entry in 45-libsane.rules

Reported by Geoff Hoff on 2006-05-16
4
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Medium
Martin Pitt
Dapper
Medium
Unassigned

Bug Description

The file /etc/udev/rules.d/45-libsane.rules in the libsane package had a invalid entry. The lines

# Hewlett-Packard|PSC 750
SYSFS{idVendor}=="03f0", SYSFS{idProduct}=="1411", MODE="664", GROUP="scanner"

need to be removed. This entry is for a HP multifunction printer scanner. If the group is changed from lp (default) to scanner, hplip isn't able to work, thus the hpaio scanner driver won't work and the device can't be used.

Geoff Hoff (gahoff) wrote :

I own a HP PSC 750 and have confirmed that this change fixes scanning on this multifunction printer/scanner.

Changed in sane-backends:
assignee: nobody → keybuk
status: Unconfirmed → Confirmed
Changed in sane-backends:
assignee: keybuk → pitti
Martin Pitt (pitti) wrote :

I'd prefer if we added the hplip user to the scanner group, so that we don't need to rip apart the automatic rules generation.

For edgy this is not a problem any more anyway, since edgy's hplip uses libusb instead of /dev/* and runs as root again (yes, this is a regression, but little we can do about it).

Changed in sane-backends:
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

Adding dapper task, it's a simple matter of adding the hplip user to 'scanner'.

Mert Dirik (mertdirik) wrote :

Adding the hplip user to scanner doesn't work. But removing the entry of PSC 750 works.

Changed in hplip:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Rolf Leggewie (r0lf) on 2011-10-03
Changed in hplip (Ubuntu Dapper):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers