Change logs for ircii-pana source package in Dapper

  • ircii-pana (1:1.1-4ubuntu0.2) dapper-security; urgency=low
    
      * SECURITY UPDATE: fully solve remote IRC command execution.
        - Updated debian/patches/remote_exec_fix.patch: corrected the
          check, thanks to Kurt Roeckx (CVE-2007-3360).
    
     -- Kees Cook <email address hidden>   Sat, 17 Jan 2009 08:27:02 -0800
  • ircii-pana (1:1.1-4ubuntu0.1) dapper-security; urgency=low
    
      * SECURITY UPDATE: remote IRC servers could execute arbitrary commands
        by sending malicious data containing NICK and EXEC strings.
      * Add 'debian/patches/remote_exec_fix.patch' to prevent exceeding the
        bounds of the hash table.
      * References
        CVE-2007-3360
    
     -- Luca Falavigna <email address hidden>   Tue, 02 Oct 2007 23:18:40 +0200
  • ircii-pana (1:1.1-4) dapper; urgency=low
    
      * debian/control
        + Build on libmysqlclient15-dev and Suggest libmysqlclient15off.
          (Closes: Malone #45057)
    
     -- Chuck Short <email address hidden>   Wed, 17 May 2006 20:55:21 -0400
  • ircii-pana (1:1.1-3) unstable; urgency=low
    
    
      * Replace xlibs-dev dependency (Closes: #346692).
    
     -- Daniel Jacobowitz <email address hidden>  Tue, 17 Jan 2006 02:42:40 +0000
  • ircii-pana (1:1.1-2) unstable; urgency=low
    
    
      * Use quilt to manage patches.
      * Add a patch from Andreas Jochens to support gcc 4.0 (Closes: #290365).
      * Add an SSL_CERTIFICATES variable which allows the client to supply
        a certificate.
    
     -- Daniel Jacobowitz <email address hidden>  Wed, 27 Jul 2005 22:47:14 -0400