Segfault when saving files on AMD64

Bug #56161 reported by Antonio Censi on 2006-08-12
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mousepad (Ubuntu)
Medium
Cody A.W. Somerville
Dapper
Medium
Cody A.W. Somerville

Bug Description

Binary package hint: mousepad

When a user attempts to save a file using mousepad (included in the Xubuntu distribution) on x86_64, a segfault occurs and the user's data is lost (ie. not saved).

Very easy to reproduce, just try to save a file in AMD64 version

Bug is reported to be corrected in 4.3.90.2 release from xfce.org:

http://www.xfce.org/release_notes/4.4beta2_changelog.txt

Text Editor (mousepad)
----------------------
 * Fix segfault on file save on x86_64.
 * Fix compilation errors.

xfce4 SVN Revision 22299 fixs this bug:
http://svn.xfce.org/listing.php?repname=xfce4&path=%2Fmousepad%2Ftrunk%2Fsrc%2F&rev=22299&sc=1

Jani Monoses (jani) wrote :

so it is fixed in edgy but the bug is in dapper. It is likely this will be put in dapper-updates too for those who don't yet upgrade to edgy.

Dapper-updates in the natural place, isn't it?

On 8/31/06, Jani Monoses <email address hidden> wrote:
>
> so it is fixed in edgy but the bug is in dapper. It is likely this will
> be put in dapper-updates too for those who don't yet upgrade to edgy.
>
> --
> Segfault when saving files on AMD64
> https://launchpad.net/bugs/56161
>

--
A. C. Censi
accensi [em] gmail [ponto] com
accensi [em] montreal [ponto] com [ponto] br
accensi [em] gmail [ponto] com - Google Talk

Jani: Did the fix for this ever makes it's way into dapper?

Changed in mousepad:
status: Unconfirmed → Confirmed
Jani Monoses (jani) wrote :

no, it's not in dapper. It should be though, but I am not sure whether via dapper-updates
(package needs to stay a week in dapper-proposed and needs permission from mdz) or
ask the backports team to add it to dapper-backports.
Either of these approaches needs someone taking care of it, would you?

Sure.

I'm going to take the SRU route since this bug, under realistic circumstances, directly causes a loss of user data and an SRU would make sure that virtually everyone gets the update.

I'll see about doing this, this weekend.

Changed in mousepad:
assignee: nobody → cody-somerville
status: Confirmed → In Progress
Changed in mousepad:
importance: Undecided → Medium
Changed in mousepad:
assignee: cody-somerville → nobody
importance: Medium → Undecided
status: In Progress → Rejected
assignee: nobody → cody-somerville
importance: Undecided → Medium
status: Unconfirmed → In Progress
description: updated
Jani Monoses (jani) wrote :

I'd say we just backport whatever version is in edgy, as I think its not much in that new version besides this bugfix.

Don't we have to consider commercial users who may not have backports
enabled?

On 12/3/06, Jani Monoses <email address hidden> wrote:
>
> I'd say we just backport whatever version is in edgy, as I think its not
> much in that new version besides this bugfix.
>
> --
> Segfault when saving files on AMD64
> https://launchpad.net/bugs/56161
>

--

Firefox (www.getfirefox.com) -- A browser you can trust

Jani Monoses (jani) wrote :

backports not necessarily via the backports repo, but the package rebuilt and uploaded to dapper-updates. As for commercial users (I doubt they are any for xubuntu, and if so they can enable the backports repo themselves).

Colin Watson (cjwatson) wrote :

Cody, could you please undo all the comment syntax changes (replacing // with /* ... */ or #if 0 ... #endif)? I realise that // is illegal C89 (though it's legal C99), but even if it causes compiler warnings it built on Dapper once so I'm assuming that it should do so again without the need for this correction. I'd like dapper-proposed changes to be restricted to exactly what is needed to fix the bug.

Jani, I'm sorry, but we won't approve such an upload to dapper-updates. Please see http://wiki.ubuntu.com/StableReleaseUpdates for what is allowed. Cody is on the right track here.

Jani Monoses (jani) wrote :

Colin, I have not followed closely what is happening with this bug, so If Cody is on the right track, fine :) . By dapper-updates I meant dapper-proposed first, that's the only thing I knew about the new policy. Thanks both for taking care of this

Alrighty. I'll get this done sometime this week.

Changed in mousepad:
assignee: nobody → cody-somerville
importance: Undecided → Medium
status: Rejected → In Progress
Colin Watson (cjwatson) wrote :
Daniel T Chen (crimsun) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 2 Dec 2006 20:32:59 -0400
Source: mousepad
Binary: mousepad
Architecture: source
Version: 0.2.2-2ubuntu5.1~proposed
Distribution: dapper-proposed
Urgency: low
Maintainer: Debian Xfce Maintainers <email address hidden>
Changed-By: Cody A.W. Somerville <email address hidden>
Description:
 mousepad - simple Xfce oriented text editor
Changes:
 mousepad (0.2.2-2ubuntu5.1~proposed) dapper-proposed; urgency=low
 .
   * Applied upstream svn revision 22299 to fix a segmentation
     fault when saving a file on 64bit pc. (Closes Ubuntu: #56161)
   * SRU Request: 56161
   * Reference:
    http://svn.xfce.org/listing.php?repname=xfce4&path=%2Fmousepad%2Ftrunk%2Fsrc
%2F&rev=22299&sc=1
Files:
 22928005cc31dfcc5c4697bc5ca55386 877 editors optional mousepad_0.2.2-2ubuntu5.1
~proposed.dsc
 5a0f2d279d6ed964af9e57abdf1178ee 18788 editors optional mousepad_0.2.2-2ubuntu5
.1~proposed.diff.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFFohWUe9GwFciKvaMRAuGqAJ9hJxQ64JQ6ejioCw3hMIzz6lvU3wCfZHnT
mp0MeXeq4FoQ2EL8iphgkOk=
=jJAE
-----END PGP SIGNATURE-----

Tollef Fog Heen (tfheen) wrote :

Please do not subscribe ubuntu-archive before an upload has been made.

Tollef Fog Heen (tfheen) wrote :

Oops, sorry, my fault, I looked in the wrong queue. Accepted into dapper-proposed now.

Changed in mousepad:
status: In Progress → Fix Committed
Simon Law (sfllaw) wrote :

This SRU disturbs me because the debdiff doesn't appear to be a minimal change.

To satisfy me, you will have to pare down the patch to its bare essentials.

1. Do the substitution from gint to gsize.
2. Move "selected_fi = NULL" after its g_free() call in selector.c.
3. Fix any compilation errors.

I won't accept a debdiff that contains changes to commenting style, different function names (xfce_file_chooser_new to gtk_file_chooser_dialog_new), or other functionality changes.

Thanks for your work!

Changed in mousepad:
status: Fix Committed → In Progress

I hope this addresses the issues you brought up.

Simon Law (sfllaw) wrote :

This diff is OK, please upload to dapper-proposed. Thanks!

Daniel T Chen (crimsun) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 20 Jan 2007 00:18:46 -0400
Source: mousepad
Binary: mousepad
Architecture: source
Version: 0.2.2-2ubuntu5.1~proposed2
Distribution: dapper-proposed
Urgency: low
Maintainer: Debian Xfce Maintainers <email address hidden>
Changed-By: Cody A.W. Somerville <email address hidden>
Description:
 mousepad - simple Xfce oriented text editor
Changes:
 mousepad (0.2.2-2ubuntu5.1~proposed2) dapper-proposed; urgency=low
 .
   * Addressed issues raised by QA Team. (See Ubuntu: #56161)
Files:
 293b729937e84a9de94adc47f9538a0a 879 editors optional mousepad_0.2.2-2ubuntu5.1
~proposed2.dsc
 580f9574f71a41cf3afa220934ed6f02 18268 editors optional mousepad_0.2.2-2ubuntu5
.1~proposed2.diff.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFFuu63e9GwFciKvaMRAooAAJ0SKCgaTagXj3vv1T7uWcKhfPb73ACfTszJ
hjiOIfpaCJguvoegxd25f90=
=p0Xx
-----END PGP SIGNATURE-----

Martin Pitt (pitti) wrote :

Closing Feisty task, if it is fixed in Edgy it is hopefully fixed in Feisty, too.

Changed in mousepad:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Accepted -proposed2 upload into dapper-proposed, please go ahead with QA testing.

Changed in mousepad:
status: In Progress → Fix Committed
Simon Law (sfllaw) wrote :

Regression tested on Dapper. Please upload immediately to dapper-updates.

Thanks.

Could a member of ubuntu-main-sponsors please upload?

Thanks,

Cody A.W. Somerville

Daniel Holbach (dholbach) wrote :

 mousepad (0.2.2-2ubuntu5.1) dapper-updates; urgency=low
 .
   * regression tested by Simon Law.
 .
 mousepad (0.2.2-2ubuntu5.1~proposed2) dapper-proposed; urgency=low
 .
   * Addressed issues raised by QA Team. (See Ubuntu: #56161)
 .
 mousepad (0.2.2-2ubuntu5.1~proposed) dapper-proposed; urgency=low
 .
   * Applied upstream svn revision 22299 to fix a segmentation
     fault when saving a file on 64bit pc. (Closes Ubuntu: #56161)
   * SRU Request: 56161
   * Reference:
    http://svn.xfce.org/listing.php?repname=xfce4&path=%2Fmousepad%2Ftrunk%2Fsrc%2F&rev=22299&sc=1

Changed in mousepad:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted into dapper-updates.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers