Binary package “libboost-mpi-dev” in ubuntu disco

C++ interface to the Message Passing Interface (MPI) (default version)

 This package forms part of the Boost C++ Libraries collection.
 .
 The Boost.MPI library provides a C++ interface to MPI that
 supports modern C++ development styles, including complete support for
 user-defined data types and C++ Standard Library types, arbitrary function
 objects for collective algorithms, and the use of modern C++ library
 techniques to maintain maximal efficiency.
 .
 This package is a dependency package, which depends on Debian's default
 Boost version (currently 1.67).