Change logs for libmoosex-undeftolerant-perl source package in Disco

  • libmoosex-undeftolerant-perl (0.21-1) unstable; urgency=medium
    
      [ upstream ]
      * New release.
    
      [ Salvatore Bonaccorso ]
      * Update Vcs-* headers for switch to salsa.debian.org.
    
      [ gregor herrmann ]
      * Update URLs from {search,www}.cpan.org to MetaCPAN.
      * Update GitHub URLs to use HTTPS.
    
      [ Jonas Smedegaard ]
      * Simplify rules.
        Stop build-depend on devscripts cdbs.
      * Update git-buildpackage config: Filter any .git* file.
      * Update watch file:
        + Bump to file format 4.
        + Rewrite usage comment.
        + Use substitution strings.
      * Update copyright info:
        + Use https protocol in Format and Upstream-Contact URLs.
        + Extend coverage of packaging.
      * Stop build-depend on dh-buildinfo.
      * Relax to (build-)depend unversioned on libmoose-perl:
        Needed version satisfied even in oldstable.
      * Mark build-dependencies needed only for testsuite as such.
      * Drop obsolete lintian override regarding debhelper 9.
      * Tighten lintian overrides regarding License-Reference.
      * Declare compliance with Debian Policy 4.3.0.
      * Enable autopkgtest.
      * Set Rules-Requires-Root: no.
      * Wrap and sort control file.
      * Stop build-depend on libtest-nowarnings-perl.
    
     -- Jonas Smedegaard <email address hidden>  Wed, 20 Feb 2019 15:13:21 +0100
  • libmoosex-undeftolerant-perl (0.20-1) unstable; urgency=low
    
      [ upstream ]
      * New release.
        + Repository migrated to the github moose organization.
    
      [ Salvatore Bonaccorso ]
      * Change Vcs-Git to canonical URI (git://anonscm.debian.org)
      * Update Vcs-Browser URL to cgit web frontend
    
      [ Jonas Smedegaard ]
      * Upstream homepage to reflect upstream reorganization.
      * Update copyright info:
        + Add alternate git source URL.
        + List issue tracker as preferred upstream contact.
        + Use License-Grant and License-Reference fields. Thanks to Ben Finney.
        + Extend coverage of packaging.
        + Tighten packaging license to GPL-3+.
      * Stop track md5sum of upstream tarball: Compare against VCS instead.
      * Add lintian override regarding license in License-Reference field.
        See bug#786450.
      * Bump debhelper compatibility level to 9.
      * Add lintian override regarding debhelper 9.
      * Declare compliance with Debian Policy 3.9.6.
      * Include CDBS snippet perl-build.mk (not perl-makemaker.mk).
      * Update package relations:
        + Tighten build-dependency on cdbs.
        + Build-depend on libmodule-build-tiny-perl.
        + (Build-)depend on libnamespace-autoclean-perl.
      * Remove empty manpages.
    
     -- Jonas Smedegaard <email address hidden>  Sat, 24 Oct 2015 21:26:39 +0200