pydance failed to with "pygame.error: SDL_ttf render failed"

Bug #67427 reported by Tamas Gervai on 2006-10-21
10
Affects Status Importance Assigned to Milestone
pydance (Debian)
Fix Released
Unknown
pydance (Ubuntu)
Undecided
Unassigned
Edgy
Undecided
Unassigned

Bug Description

When I try to start pydance, it gives that error:

crown@diszno:~$ pydance
0 joystick(s) found.
pydance 1.0.3 <email address hidden> - irc.freenode.net/#pyddr
W: Psyco optimizing compiler not found.
Searching for songs in /usr/share/games/pydance/songs
Searching for songs in ~/.pydance/songs
Searching for songs in /usr/local/share/games/pydance/songs
Searching for courses in /usr/share/games/pydance/courses
Searching for courses in ~/.pydance/courses
Searching for courses in /usr/local/share/games/pydance/courses
Traceback (most recent call last):
  File "/usr/games/pydance", line 205, in ?
    if __name__ == '__main__': main()
  File "/usr/games/pydance", line 159, in main
    songs = load_files(screen, song_list, "songs", SongItem, (False,))
  File "/usr/games/pydance", line 86, in load_files
    pbar = TextProgress(FONTS[60], message, colors.WHITE, colors.BLACK)
  File "/usr/share/games/pydance/fontfx.py", line 149, in __init__
    self.text = font.render(message, False, [255, 0, 0], self.notcolor)
pygame.error: SDL_ttf render failed

ii pydance 1.0.3-3 dancing simulation game similar to the kind
ii python-pygame 1.7.1release-4 SDL bindings for games development in Python

This supposed to be an old, and fixed error, but with the latest packages, the error just come up all the time.

description: updated
Singpolyma (singpolyma) wrote :

I am getting this same exact error. I am on Ubuntu Edgy Eft.

wm_eddie (wm-eddie) wrote :

This is fixed in http://ftp.debian.org/debian/pool/main/p/pydance/pydance_1.0.3-4.diff.gz (the version in Feisty. This is a critical bug in this program, the fix should be backported. (It's only two lines in fontfix.py anyway.)

Gnuton (antonio-aloisio) wrote :

The Ubuntu sources don't need to patch the man file;

The patch works fine without this lines:

--- pydance-1.0.3.orig/docs/man/pydance.6
+++ pydance-1.0.3/docs/man/pydance.6
@@ -8,7 +8,7 @@
 Display a brief summary of command line options.
 .IP \-\-version,\ \-v
 Display the version of pydance (and features found, e.g. Psyco).
-.IP \-\-filename\, \-f
+.IP \-\-filename,\ \-f
 Load and play a single file, then quit. By default, this is in
 SINGLE (4 panel) mode, on BASIC difficulty.
 .IP \-\-mode,\ \-m

--- pydance-1.0.3.orig/debian/control
+++ pydance-1.0.3/debian/control
@@ -0,0 +1,33 @@
+Source: pydance
+Section: games
+Priority: optional
+Maintainer: Debian QA Group <email address hidden>
+Build-Depends: debhelper (>= 5.0.37.1), imagemagick, python-support (>= 0.2.3),
+ python-dev (>= 2.3.5-7)
+Standards-Version: 3.7.2
+XS-Python-Version: current
+
+Package: pydance
+Architecture: all
+Depends: ${python:Depends}, python-pygame (>= 1.5.6), pydance-music
+Suggests: ddrmat-source, mp32ogg, python-psyco
+XB-Python-Version: ${python:Versions}
+Description: dancing simulation game similar to the kind in arcades
+ pydance is a dancing simulator, in which you must step on particular arrows
+ on the floor in time with music playing in the background. pydance supports
+ multiple difficulty levels for each song, background images and movies,
+ lyrics, freeze arrows, BPM changes and stops, and many common modifiers like
+ 2x, drop, stealth, and so on.
+ .
+ pydance is interoperable with other dancing games, and can play the
+ popular DWI, SM, and KSF formats. It is capable of playing games similar
+ to Dance Dance Revolution, Pump It Up, ParaParaParadise, Dance ManiaX,
+ and Technomotion. It also implements several unique modes. You can also
+ make your own steps for songs in the .dance format.
+ .
+ Many Playstation to USB (or parallel) adapters are supported for play. If
+ you lack a dance pad, you can also play with the keyboard.
+ .
+ This package does not contain any songs to play pydance with. For that,
+ see the pydance-music package. You may also install your own separate
+ data files (for example, if you own other proprietary dancing games).

Mikko Saarinen (mikk0) wrote :

I get the same error.

Could someone please backport this or give specific instructions for us not-so-technical-people for how to fix this.

Let the dance begin =)

On 12/6/06, Mikko Saarinen <email address hidden> wrote:
> I get the same error.

It works for me, so the patch is fine.

> Could someone please backport this or give specific instructions for us
> not-so-technical-people for how to fix this.

Just a short doc, hope it's help:

locate fontfx.py (use the "locate" command)

Edit the file.
In line 144, change, this:
self.text = font.render(message, False, [255, 0, 0], self.notcolor)
to that:
self.text = font.render(message, 1, [255, 0, 0], self.notcolor)

In line 155
base = font.render(message, 0, fontcolor, self.notcolor)
base = font.render(message, 1, fontcolor, self.notcolor)

as root, because they are installed files.

As I remember, that's pretty much all...

--
good luck
tamas

Mikko Saarinen (mikk0) wrote :

Thanks Tamas, it worked =)

The file to edit was /usr/share/games/pydance/fontfx.py
In my version the lines were 147 and 158, though.

Mikko

Kai Kasurinen (kai-kasurinen) wrote :

Thanks for the bug report.

I'm closing this bug because it has been fixed in Feisty.

pydance (1.0.3-4) unstable; urgency=low

  * Apply patch from Luca Bruno to workaround Pygame bug. (Closes: #375651)
  * Set maintainer to Debian QA group.
  * Update for new new new new new new new new new Python policy.

 -- Ubuntu Archive Auto-Sync <email address hidden> Tue, 07 Nov 2006 03:28:52 +0000

Changed in pydance:
status: Unconfirmed → Fix Released
Kai Kasurinen (kai-kasurinen) wrote :

If you need a fix for this bug in Edgy, please follow the
instructions in the "How to request new packages" section of the
Backports wiki page:
        https://wiki.ubuntu.com/UbuntuBackports

Changed in pydance:
status: Unknown → Fix Released
Hew McLachlan (hew) wrote :

Ubuntu Edgy Eft is no longer supported, so a SRU will not be issued for this release. Marking Edgy as Won't Fix.

Changed in pydance:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.