Ubuntu

New timezone data 2007b

Reported by Martin Pitt on 2007-02-15
8
Affects Status Importance Assigned to Milestone
tzdata (Ubuntu)
Undecided
Martin Pitt
Dapper
Undecided
Unassigned
Edgy
High
Martin Pitt

Bug Description

Binary package hint: tzdata

There is a new timezone data tarball: 2007b.

Martin Pitt (pitti) wrote :

For Feisty (2007a->2007b) this only fixes a leap second.

Changed in tzdata:
assignee: nobody → pitti
status: Unconfirmed → In Progress
assignee: nobody → pitti
importance: Undecided → High
status: Unconfirmed → In Progress
Martin Pitt (pitti) wrote :

This is the effective diff of the upstream tzdata tarballs 2006p -> 2007b. The new tarball will just be put into edgy's tzdata and dapper's langpack-locales source packages; this new tarball with attached diff and debian/changelog will be the only source package changes.

upstream tzdata changes look sane:
- fixed spelling of two timezones, added compatibility links to the old names
- updated DST rules
- fixed leap second

Martin Pitt (pitti) wrote :

 tzdata (2007b-0ubuntu1) feisty; urgency=low
 .
   * New upstream release: Just fixes a leap second. (LP: #85394)
   * debian/control: Updated Maintainer field.

Changed in tzdata:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Edgy-proposed update prepared:

--- /tmp/NURaZqoLCI/tzdata-2006p/debian/changelog 2007-02-15 19:28:40.000000000 +0100
+++ /tmp/NyfdvbqxLd/tzdata-2007b/debian/changelog 2007-02-15 19:28:41.000000000 +0100
@@ -1,3 +1,13 @@
+tzdata (2007b-0ubuntu0.6.10~proposed1) feisty; urgency=low
+
+ * Upload of 2007b to Edgy:
+ - Corrects two timezone names and adds transitional links for them.
+ - Updates some DST rules.
+ - Updates a leap second.
+ - (LP: #85394)
+
+ -- Martin Pitt <email address hidden> Thu, 15 Feb 2007 19:26:26 +0100
+
 tzdata (2006p-0ubuntu6.10) edgy-updates; urgency=low

   * No-change upload of the -proposed version to -updates.

(plus the new tarball, of course, see attached diff).

Martin Pitt (pitti) wrote :

Erm, last diff with s/feisty/edgy-proposed/, of course. Sorry

Martin Pitt (pitti) wrote :

dapper-proposed package prepared:

--- /tmp/qMkzW6zM4L/langpack-locales-2.3.18.1/debian/changelog 2007-01-15 16:13:06.000000000 +0100
+++ /tmp/AODX4UHyFs/langpack-locales-2.3.18.2~prop1/debian/changelog 2007-02-15 19:32:22.000000000 +0100
@@ -1,3 +1,13 @@
+langpack-locales (2.3.18.2~prop1) dapper-proposed; urgency=low
+
+ * Replace debian/tzdata2006p.tar.gz with new version tzdata2007b:
+ - Corrects two timezone names and adds transitional links for them.
+ - Updates some DST rules.
+ - Updates a leap second.
+ - (LP: #85394)
+
+ -- Martin Pitt <email address hidden> Thu, 15 Feb 2007 19:31:51 +0100

(plus the new tarball, of course, see attached diff).

Changed in tzdata:
status: Unconfirmed → In Progress
Colin Watson (cjwatson) wrote :

OK for dapper-proposed and edgy-proposed.

Martin Pitt (pitti) wrote :

Uploaded and accepted into dapper/edgy-proposed.

Changed in tzdata:
status: In Progress → Fix Committed
status: In Progress → Fix Committed

Hi Simon,

as explained in detail in bug #85394 I just uploaded the most current
timezone data to dapper/edgy-proposed. No TZ merges/splits or other
complicated stuff this time, mostly just DST rule adaptions.

I tested the packages, of course. It would be nice to get this into
-updates before March, so that the rule changes can apply when the
DST rule changes actually happen.

Thanks,

Martin

--
Martin Pitt http://www.piware.de
Ubuntu Developer http://www.ubuntu.com
Debian Developer http://www.debian.org

Michael Vogt (mvo) wrote :

Thanks for this verfication request.

I tested this and it installs fine. I also checked that DST changes for America/Nassau are applied after the update. This is the case, time switches from EDT to EST depending on date.

I will mark this verification-done now.

Cheers,
 Michael

Michael Vogt (mvo) wrote :

Please note that I did only verify dapper-proposed (there is a open task for edgy too, but there seems to be no files).

Michael Vogt (mvo) wrote :

I did a verification of tzdata on edgy-proposed now too. It seems to be working fine. I was confused because there was no speperate debdiff for edgy.

Cheers,
 Michael

Michael Vogt (mvo) wrote :

I did the same verification steps as for dapper (timezone set to America/Nassau, switch date and see if EDT/EST changes).

Martin Pitt (pitti) wrote :

Uploaded and accepted into edgy-updates.

Changed in tzdata:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Uploaded and accepted into dapper-updates.

Changed in tzdata:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers