Change logs for chromium-browser source package in Eoan

  • chromium-browser (76.0.3809.100-0ubuntu1~snap1) eoan; urgency=medium
    
      * debian/chromium-browser.preinst: handle gracefully a failure to connect the
        password-manager-service (LP: #1838821)
    
     -- Olivier Tilloy <email address hidden>  Tue, 13 Aug 2019 12:32:48 +0200
  • chromium-browser (76.0.3809.87-0ubuntu1~snap1) eoan; urgency=medium
    
      * debian/chromium-browser.desktop: remove the MimeType entry to avoid the
        wrapper being listed as an application able to handle web links in
        gnome-control-center (LP: #1838628)
    
     -- Olivier Tilloy <email address hidden>  Thu, 01 Aug 2019 16:20:53 +0200
  • chromium-browser (75.0.3770.142-0ubuntu1~snap1) eoan; urgency=medium
    
      * debian/apport/chromium-browser.py: update hook to call 'snap connections'
        instead of the deprecated 'snap interfaces'
      * debian/chromium-browser.preinst: connect the password-manager-service
        interface for package upgrades only (LP: #1836616)
    
     -- Olivier Tilloy <email address hidden>  Wed, 24 Jul 2019 14:21:16 +0200
  • chromium-browser (75.0.3770.80-0ubuntu1~snap2) eoan; urgency=medium
    
      * Make the wrapper script update the default web browser if needed
    
     -- Olivier Tilloy <email address hidden>  Wed, 12 Jun 2019 12:49:09 +0200
  • chromium-browser (75.0.3770.80-0ubuntu1~snap1) eoan; urgency=medium
    
      * Upstream release: 75.0.3770.80
        - CVE-2019-5828: Use after free in ServiceWorker.
        - CVE-2019-5829: Use after free in Download Manager.
        - CVE-2019-5830: Incorrectly credentialed requests in CORS.
        - CVE-2019-5831: Incorrect map processing in V8.
        - CVE-2019-5832: Incorrect CORS handling in XHR.
        - CVE-2019-5833: Inconsistent security UI placement.
        - CVE-2019-5834: URL spoof in Omnibox on iOS.
        - CVE-2019-5835: Out of bounds read in Swiftshader.
        - CVE-2019-5836: Heap buffer overflow in Angle.
        - CVE-2019-5837: Cross-origin resources size disclosure in Appcache.
        - CVE-2019-5838: Overly permissive tab access in Extensions.
        - CVE-2019-5839: Incorrect handling of certain code points in Blink.
        - CVE-2019-5840: Popup blocker bypass.
      * Install the chromium snap in place of the debian packages, and make the
        wrapper script rename the desktop file in well-known desktop launchers
        (currently GNOME Shell and Unity)
    
     -- Olivier Tilloy <email address hidden>  Wed, 12 Jun 2019 09:57:03 +0200
  • chromium-browser (74.0.3729.169-0ubuntu2) eoan; urgency=medium
    
      * debian/patches/revert-gn-4960.patch: added
      * debian/patches/revert-gn-4980.patch: added
    
     -- Olivier Tilloy <email address hidden>  Wed, 22 May 2019 10:12:13 +0200
  • chromium-browser (74.0.3729.169-0ubuntu1) eoan; urgency=medium
    
      * Upstream release: 74.0.3729.169
      * debian/tests/data/HTML5test/index.html: mock whichbrowser.net to remove
        external test dependency
    
     -- Olivier Tilloy <email address hidden>  Wed, 22 May 2019 08:35:30 +0200
  • chromium-browser (74.0.3729.157-0ubuntu1) eoan; urgency=medium
    
      * Upstream release: 74.0.3729.157
    
     -- Olivier Tilloy <email address hidden>  Tue, 14 May 2019 22:48:28 +0200
  • chromium-browser (74.0.3729.131-0ubuntu2) eoan; urgency=medium
    
      * debian/control: remove libgnome-keyring-dev build dependency (LP: #1828192)
      * debian/rules: build with use_gnome_keyring=false
      * debian/known_gn_gen_args-*: change use_gnome_keyring build flag to false
    
     -- Olivier Tilloy <email address hidden>  Wed, 08 May 2019 12:15:30 +0200
  • chromium-browser (74.0.3729.131-0ubuntu1) eoan; urgency=medium
    
      * Upstream release: 74.0.3729.131
        - CVE-2019-5824: Parameter passing error in media player.
    
     -- Olivier Tilloy <email address hidden>  Wed, 01 May 2019 08:27:06 +0200
  • chromium-browser (74.0.3729.108-0ubuntu2) eoan; urgency=medium
    
      * debian/patches/flashplayer-syscall-restrictions-update.patch: added
        (LP: #1825497)
    
     -- Olivier Tilloy <email address hidden>  Tue, 30 Apr 2019 09:50:17 +0200
  • chromium-browser (74.0.3729.108-0ubuntu1) eoan; urgency=medium
    
      * Bump version number for the new development release
        (Ubuntu 19.10, the Eoan EANIMAL)
      * debian/control: update Vcs-Bzr field
      * debian/patches/fix-extra-arflags.patch: updated
    
     -- Olivier Tilloy <email address hidden>  Thu, 25 Apr 2019 12:43:58 +0200
  • chromium-browser (73.0.3683.103-0ubuntu1) disco; urgency=medium
    
      * Upstream release: 73.0.3683.103
      * debian/patches/gn-add-missing-arm-impl-files.patch: removed, no longer
        needed
    
     -- Olivier Tilloy <email address hidden>  Fri, 05 Apr 2019 07:12:20 +0200