Ubuntu

“linux-source-2.6.22” 2.6.22-15.58 source package in The Gutsy Gibbon

Publishing history

2.6.22-15.58
SUPERSEDED: Gutsy pocket Updates in component main and section devel
  • Removed from disk on 2008-10-29.
  • Removal requested on 2008-10-28.
  • Superseded on 2008-10-27 by linux-source-2.6.22 - 2.6.22-15.59
  • Published on 2008-08-26
2.6.22-15.58
SUPERSEDED: Gutsy pocket Security in component main and section devel
  • Removed from disk on 2008-10-28.
  • Removal requested on 2008-10-28.
  • Superseded on 2008-10-27 by linux-source-2.6.22 - 2.6.22-15.59
  • Published on 2008-08-25

Builds

Changelog

linux-source-2.6.22 (2.6.22-15.58) gutsy-security; urgency=low

  [Stefan Bader]

  * mm: Fix zero length segment loop
    - LP: #249340
    follow-up for CVE-2008-0598

  [Upstream Kernel Changes]

  * Fix compiler warning on 64-bit
    follow-up for CVE-2008-1673
  * netfilter: nf_nat_snmp_basic: fix a range check in NAT for SNMP
    follow-up for CVE-2008-1673

linux-source-2.6.22 (2.6.22-15.57) gutsy-security; urgency=low

  [Upstream Kernel Changes]

  * (CVE-2008-2812) TTY: fix for tty operations bugs
  * (CVE-2008-3272) sound: ensure device number is valid in
    snd_seq_oss_synth_make_info
  * (CVE-2008-3275) vfs: fix lookup on deleted directory

 -- Stefan Bader <email address hidden>   Thu, 14 Aug 2008 10:11:31 -0400