Binary package “nvidia-legacy-kernel-source” in ubuntu hardy

NVIDIA binary 'legacy' kernel module source

 This package builds the NVIDIA XFree86 4.x/X.Org binary kernel module needed
 by nvidia-glx. This package is not needed on an Ubuntu system because
 a pre-compiled kernel module is supplied by the linux-restricted-modules
 packages.
 .
 This is the 'legacy' driver for older chipsets. Unless your chipset is
 explicitly listed in the nvidia-glx-legacy description, please use the
 nvidia-glx driver, which is much more up to date.