Change logs for nbd source package in Hardy

  • nbd (1:2.9.9-1ubuntu1.1) hardy-security; urgency=low
    
      * SECURITY UPDATE: arbitrary code execution via long request (LP: #718300)
        - nbd-server.c: fix buffer size checking.
        - https://github.com/yoe/nbd/commit/3ef52043861ab16352d49af89e048ba6339d6df8
        - CVE-2011-0530
     -- Marc Deslauriers <email address hidden>   Wed, 20 Apr 2011 10:08:22 -0400
  • nbd (1:2.9.9-1ubuntu1) hardy; urgency=low
    
      * Build nbd-client-udeb for lpia as well. (We don't use it at present, but
        it's the easiest way to avoid a build failure.)
    
     -- Colin Watson <email address hidden>   Thu, 10 Jan 2008 18:34:33 +0000
  • nbd (1:2.9.9-1) unstable; urgency=low
    
      * New upstream release
        - Fixes PID file naming; Closes: #450430.
        - Fixes segfault on multiple exports in config file; Closes: #451231.
      * Add experimental LSB headers. Initscript dependency info should really be
        calculated dynamically, but at least this is better than nothing.
        Closes: #448225.
    
    nbd (1:2.9.8-1) unstable; urgency=low
    
      * New upstream release
    
    nbd (1:2.9.7-2) unstable; urgency=low
    
      * Set scheduler for the nbd blockdevice to "deadline"; Closes: #447638.
    
    nbd (1:2.9.7-1) unstable; urgency=low
    
      * New upstream release; contains patch for a segfault bug fixed by Ubuntu in
        nbd 1:2.9.6-1ubuntu2.
      * Updated translations:
        - Dutch, by myself.
        - French, by Christian Perrier; Closes: #439756
        - German, by Helge Kreutzman; Closes: #438412
        - Portuguese, by "Traduz - Portuguese Translation Team"; Closes: #438583
        Apologies to all translators for failing to send them the final version of
        the .po file last time. I suck, suck suck!
      * Add lpia to nbd-client's architecture; Patch pulled from Ubuntu.
      * Fix dh_installman usage: insall nbd-server.5 as well. Patch pulled from
        Ubuntu, slightly modified by $SELF.
    
    nbd (1:2.9.6-2) unstable; urgency=low
    
      * debian/nbd-server.postrm: don't break if ucf isn't available.
        Closes: #431517.
      * debian/nbd-server.postinst, debian/nbd-server.config,
        debian/nbd-server.templates: overhaul config file generation. Rather than
        generating an old-style config file and then converting that to the new
        style (ugly, ugly), add a function to convert old-style config files to
        the new style and then generate new-style config files. Still leave stuff
        there for migration, however. Clarify templates regarding the new setup.
      * debian/nbd-server.postinst: Don't forget to create the nbd system user
        which we refer to in the default config file.
      * debian/control: depend on adduser for the above
      * Updated debconf translations:
        - Dutch, by myself.
        - Vietnamese, by Clytie Siddall; Closes: #436412.
        - French, by Christian Perrier; Closes: #436832.
        - Czech, by Miroslav Kure; Closes: #437224.
        - German, by Helge Kreutzmann; Closes: #430700, #437689
      * New debconf translation: Portuguese, by Américo Monteiro; Closes: #435301
      * debian/rules: use DEB_HOST_GNU_SYSTEM rather than `uname -s`, to improve
        crosscompilability.
    
     -- Steve Langasek <email address hidden>   Wed,  28 Nov 2007 09:10:51 +0000
  • nbd (1:2.9.6-1ubuntu3) gutsy; urgency=low
    
      * Add proper dh_installman handling, include nbd-server.5 man page.
    
     -- Scott Balneaves <email address hidden>   Tue, 28 Aug 2007 21:56:24 -0500