Change logs for avant-window-navigator source package in Intrepid

  • avant-window-navigator (0.2.6-7ubuntu1) intrepid; urgency=low
    
      * debian/patches
       - 91-delete-themes.patch : From upstream, allow to delete themes
         other than the current one (LP: #134397).
       - 92-custom-icon-slash-title.patch : From upstream, handle slash in
         custom icons title (LP: #228036).
    
     -- Julien Lavergne <email address hidden>   Sun, 07 Sep 2008 16:33:59 +0200
  • avant-window-navigator (0.2.6-7) unstable; urgency=medium
    
      * debian/control
       - Set a dependency on a composite manager rather than just suggest it. 
         (Closes: #483673). Urgency set to medium as it's a RC bug.
      * debian/README.debian
       - Document how to enable composite manager for each application.
      * debian/patches/90_null_awn_cairo.patch
       - From upstream, fix a possible crash when a applet return wrong 
         informations.
    
     -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  10 Jun 2008 07:25:18 +0100
  • avant-window-navigator (0.2.6-6) unstable; urgency=low
    
      * debian/patches/04-fix-colormap.patch
       - Fix crash in awn-manager if colormap == None. Thanks Emme for the 
         patch. (Closes: #482030) 
    
    avant-window-navigator (0.2.6-5) unstable; urgency=low
    
      * debian/control
       - Drop the depends of awn-data on awn binary to avoid circular dependency. 
         Only the depends of awn on awn-data is needed. (Closes: #478709).
       - Add a debug binary.
      * debian rules
       - Add the strip command to the libawn0-dbg binary.
    
    avant-window-navigator (0.2.6-4) unstable; urgency=medium
    
      * debian/patches/03-python-import.patch : Import correct version of python
        at runtime. Thanks Luca Bruno for the patch. (Closes: #476400, #476829)
      * debian/control
       - Set dbus-x11 as Recommends rather than Depends, not needed if D-Bus 
         is running.
       - Add awn-applets-c-core and awn-applets-python-core to Recommends to
         install a set of applets.
       - Bump awn-manager version to (0.2.6-3) needed for the applets.
       - Add python2.5 as Build-Depends if python-elementtree is not installed.
    
    avant-window-navigator (0.2.6-3) unstable; urgency=low
    
      * debian/patches
       - 02-awn-manager-applets.patch : Search for applets installed in /usr/share.
       - 01-gconf-not-empty.patch : Update with upstream changes.
      * debian/control
       - Set a correct short description for libawn-doc (Closes: #472333).
      * debian/watch
       - Switch to http, require by Launchpad.
    
    avant-window-navigator (0.2.6-2) unstable; urgency=low
    
      * Add python-xdg Depends for awn-manager (Closes: #471372).
    
    avant-window-navigator (0.2.6-1) unstable; urgency=low
    
      * New upsteam release.
      * Create new man pages: awn-launcher-editor.1 and awn-schema-to-gconf.1
      * debian/patches:
       - Drop 01-Fix-desktop-exec-path.patch, merged upstream.
       - Drop 02-Fix-encode-in-desktop.patch, merged upstream.
       - 01-gconf-not-empty.patch: Don't install gconf schemas with empty entries.
      * debian/control:
       - Add gtk-doc-tools, valac (>= 0.1.6) and python-elementtree Build-Depends 
         needed by the new version.
       - Add doc-base Build-Depends for the documentation.
       - Add binaries vala binding, libawn-doc and avant-window-navigator-data 
         binaries.
       - Add avant-window-navigator-data and dbus-x11 Depends for 
         avant-window-navigator.
       - Add python-awn Depends for awn-manager.
       - Add ${shlibs:Depends} to libawn-dev.
       - Replace "current" by ">= 2.4" for Build-Depends and XS-Python-Version.
       - Add a Provide: ${python:Provides} for the python-awn module.
       - Add depends on libawn0 for all bindings.
       - Fix spelling error.
      * debian/rules:
       - Bump libawn0 shlibs to >= 0.2.6
       - Add LDFLAGS= "-Wl,-z,defs -Wl,--as-needed" to reduce depends.
       - Add extras configure flags for backward compatibility.
       - Add awn-launcher-editor.1 and awn-schema-to-gconf.1 as man pages.
       - Only call pycentral with binary-post-install for python binaries.
      * debian/awn-manager.install:
       - Add awn-launcher-editor and awn-schema-to-gconf.
       - Add awn-manager icon.
      * debian/avant-window-navigator.install
       - Add the gconf schemas.
       - Move locales and images to avant-window-navigator-data, an 
         arch-independent binary.
      * debian/libawn-dev
       - Install only *.h files.
      * debian/copyright:
       - All libawn/* is now LGPL-2.
       - Update Copyright and Upstream Authors.
       - Remove note about the repack.
      * Add libawn-doc.install and libawn-doc.doc-base to install documentation.
    
    avant-window-navigator (0.2.1-dfsg1-1) unstable; urgency=low
    
      * Initial release version (Closes: #428246)
      * debian/patches:
       - 01-Fix-desktop-exec-path.patch : Fix lintian warning in 
      applets/taskman.desktop.in.in
       - 02-Fix-encode-in-desktop.patch : Remove Encoding in the *.desktop files
      * Original tarball repack due to the licence of the icon.
    
     -- Andrew Starr-Bochicchio <email address hidden>   Thu,  29 May 2008 14:07:05 +0100
  • avant-window-navigator (0.2.1-0ubuntu2) hardy; urgency=low
    
      * debian/watch : Fix the URL.
      * debian/control
       - Promote Recommends to Depends to force installation of awn-manager as
      Ubuntu doesn't install Recommends by default.
       - Add gnome-menus and librsvg2-common to awn-manager depends to fix
      crash on startup and adding new launcher.
       - Convert Maintainer field to respect Maintainer field specification.
       - Wrap Build-Depends, Depends and Suggests.
       - Add metacity (>= 2.21.5) which have compositor support to Suggests.
       - Add version >= 4.2 to xfwm4, the first version with compositor support.
       - Bump to 3.7.3 Standards-Version (no changes needed).
    
     -- Julien Lavergne <email address hidden>   Sat, 26 Jan 2008 00:01:55 +0100