Ubuntu

“geany” 0.16-0ubuntu4~intrepid1 source package in The Intrepid Ibex

Publishing history

0.16-0ubuntu4~intrepid1
OBSOLETE: Intrepid pocket Backports in component universe and section devel
  • Removed from disk on 2013-02-27.
  • Removal requested on 2013-02-20.
  • Published on 2009-05-06

Builds

Changelog

geany (0.16-0ubuntu4~intrepid1) intrepid-backports; urgency=low

  * Automated backport upload; no source changes.

geany (0.16-0ubuntu4) jaunty; urgency=low

  * debian/patches: add 40_fix_crashes_and_mem_corrup_at_exit.dpatch to
    fix a lot of crashes and memory corruption at exit. This patch is
    from upstream SVN r3656 and upstream strongly suggested to get it
    in. (LP: #361537)

geany (0.16-0ubuntu3) jaunty; urgency=low

  * debian/patches/:
    - 00list: add the new patch.
    - add 30_dont_leave_around_copies_of_geany_run_script.dpatch
      to prevent geany from leaving around copies of geany_run_script.sh
      after user runs script with F5 and aborts with CTRL-C. Patch comes from
      upstream commit 066f9079ca7cd7ebd6859d10c45f36af55bc5f6f. (LP: #348174)

geany (0.16-0ubuntu2) jaunty; urgency=low

  * debian/patches/:
    - add 01_fix_ubuntu_bug_147151.dpatch to fix a crash when
      changing the encoding to "none". (LP: #147151)
    - 00list: add the new patch.

geany (0.16-0ubuntu1) jaunty; urgency=low

  * New upstream release:
    - We changed the configuration directory path to ~/.config/geany.
      Geany will move your old configuration directory automatically
      on the first start.
    - Tree-like symbol view in the sidebar
    - New toolbar which is much more flexible and customisable
    - Add auto-closing of braces, brackets and quotes
      (Guillaume de Rorthais)
    - Support multiple positions in Snippets
      (Thomas Martitz)
    - New filetypes Ada, CMake, Matlab, NSIS, Vala and YAML
    - Add Split Window 'Split Vertically' command
      (thanks to Moritz Barsnick).
    - Updated translations: bg, ca, cs, de, en_GB, fr, hu, it,
      ja, pt_BR, sv, ru, tr, vi, zh_CN.
  * debian/patches: update the two patches for the new release.
  * debian/control: build-depend on glib >= 2.16 as GIO is required now.

geany (0.15-1ubuntu1) jaunty; urgency=low

  * Merge from debian experimental, remaining change:
    - patches/20_add_debdiff_as_diff_type.dpatch: Also recognize .dpatch files
      as diff's
    - debian/geany.xpm: Replace icon with a .xpm of the new one

geany (0.15-1) experimental; urgency=low

  * New upstream release
    - Allow loading projects from command line (Closes: #498854)
    - Fix a problem disabling the save icon inappropriately (Closes: #482875)
    - Detect makefiles from shebang and force using tabs
      for their indentation (Closes: #481198)
  * Remove Apps from doc-base section
  * Change homepage and related links to the new www.geany.org official domain

 -- J?r?me Guelfucci <email address hidden>   Wed, 06 May 2009 17:09:49 +0100