Ubuntu

“libaqbanking” 3.3.0+dfsg-1 source package in The Intrepid Ibex

Publishing history

3.3.0+dfsg-1
SUPERSEDED: Intrepid pocket Release in component universe and section libs
  • Removal requested on 2008-05-30.
  • Superseded on 2008-05-03 by libaqbanking - 3.4.1-1
  • Published on 2008-04-28
  • Copied from ubuntu hardy in Primary Archive for Ubuntu

Changelog

libaqbanking (3.3.0+dfsg-1) unstable; urgency=low

  * New upstream release
  * Repackage source tarball to get rid of non-free binary in the pristine
    .orig.tar.gz (closes: #469131). See new file debian/README.Debian-source
    for further details.
  * Add patch 01_drop_aqyellownet_for_dfsg which changes the build system to
    build without directories removed for DFSG compliance.
  * Add script debian/make-dfsg-free-source.sh useful for easy repackaging of
    future upstream versions.
  * debian/control:
    - add version requested by ./configure to build dep on Gwenhywfar
    - add dpatch to build dependencies needed for the patch mentioned above
  * debian/rules:
    - include CDBS rules for dpatch
    - touch aclocal.m4, Makefile.in and configure in post-patches:: hook to
      avoid autotools invocation after patching the build system
    - add check for absence of aqyellownet to ensure a DFSG source tarball in
      clean:: hook.
    - remove sed invocation on Doxyfile introduced in 3.0.1-2
      (the resulting change is included upstream)
  * update doc-base file for libaqbanking-doc to be consistent with current
    doc-base sections (thanks to lintian).

libaqbanking (3.2.1-1) unstable; urgency=low

  * New upstream release

libaqbanking (3.2.0-1) unstable; urgency=low

  * New upstream release
    - now entirely free of libofx artefacts -> remove build-dep on libofx-dev.
    - bumps soname, thus rename package libaqhbci12 -> libaqhbci13

libaqbanking (3.1.0-1) unstable; urgency=low

  * New upstream release
    - AqBanking has now its own implementation of OFX, but unfortunately the
      file src/plugins/backends/aqofxconnect/plugin/provider.c does still
      #include <libofx/libofx.h>. Thus keep build-dep on libofx-dev until
      upstream fixed that.
  * Vcs-Svn: Switch to raw svn:// url (without ssh). For general read access
    you don't need ssh based authentication.

libaqbanking (3.0.1-4) unstable; urgency=low

  * Adapt Vcs-{Svn,Browser} fields to new SVN urls (experimental -> trunk)
  * Re-introduce debian/watch file adapted to new download location
  * Add postinst script for package libaqbanking-data replacing empty
    directory /usr/share/aqhbci/xml by symlink to new location of hbci.xml on
    upgrades (closes: #458450). The directory is a possible remainder of
    AqBanking 2.x, which dpkg cannot replace automatically.

libaqbanking (3.0.1-3) unstable; urgency=low

  * Upload to Debian unstable
  * Complete instructions for key file updates

libaqbanking (3.0.1-2) experimental; urgency=low

  * bump standards version from 3.7.2 to 3.7.3 (no changes needed)
  * Make use of the new Homepage field and drop the pseudo fields.
  * Add a NEWS file giving users a hint about the moved configuration files
    and describing the steps making the old configuration files working again.
  * Add file README.keyfile-update to package aqbanking-tools, preliminaryly
    pointing to the information needed for updating key files.
  * debian/control:
    - add transitional package aqbanking-tool depending on aqbanking-tools
      making upgrades as smooth as possible (closes: #455261)
    - let package aqbanking-tools suggest package gwenhywfar-tools because
      README.keyfile-update refers to it
    - add Vcs-{Svn,Browser} fields
    - add Georg W. Leonhardt to Uploaders.
  * debian/rules:
    - clean up the clean target
    - disable doxygen's generation of mostly empty subdirs in apidoc.
  * Upstream moved downloads to a new place which isn't watch-able yet, thus
    drop the debian/watch file.
  * Delete spurious whitespace in debian/libaqbanking-doc.doc-base which would
    cause a part of the description to be unintentionally displayed verbatim
    (thanks to the lintian authors)

libaqbanking (3.0.1-1) experimental; urgency=low

  * New upstream release
  * Remove files SICHERHEITSHINWEISE and README from aqbanking-tools docs
    (deleted upstream).

libaqbanking (3.0.0-2) experimental; urgency=low

  * Make package libaqbanking-data usable by AqBanking 2 too:
    - install symlink to old path of hbci.xml
    - install missing config files from AqBanking 2 at old places
  * Split plugins linked against Qt or X libraries into separate plugin
    package libaqbanking20-plugins-qt

libaqbanking (3.0.0-1) experimental; urgency=low

  * New upstream release. This is a rewrite making use of the new Gwenhywfar
    library, switching from OpenSSL to GnuTLS and Gcrypt (closes: #340564).
    This finally allows AqBanking to stop linking against OpenSSL (finally
    closes: #372183).
  * debian/rules: ./configure with backends aqofxconnect (this introduces
    package libaqofxconnect4 and closes: #396305), aqnone and aqhbci and
    frontend qbanking. The other backends/frontends aren't working yet.
  * move all files in /usr/lib/aqbanking/plugins/ (previously cluttered around
    in diverse library packages) into new common plugin package
    libaqbanking20-plugins.
  * debian/control:
    - adapt build dependencies and build depend on libgwenhywfar >= 3.0.0-2~,
      which is the first version shipping without troublesome libgwenhywfar.la
    - drop packages for backends/frontends not being built any more
    - drop package aqbanking16-qt-wizard and move its content into the new
      package libaqbanking20-plugins
    - rename library packages due to bumped sonames
    - clean up old conflicting deps with packages available prior to Etch.
    - merge package libaqnone0 into package libaqbanking20. Upstream promised
      to keep their sonames in sync now.
    - Allow uploads by Debian Maintainers of this package.
  * rename package aqbanking-tool to aqbanking-tools because users might want
    to install the old aqbanking-tool, which contains the binary
    aqbanking-tool, which is missing in the current upstream release.
    Fortunately aqbanking-tool and aqbanking-tools have no files in common,
    thus no conflicting/replacing dependencies.
  * delete debian/TODO (all done)

 -- Reinhard Tartler <email address hidden>   Fri,  04 Apr 2008 11:39:21 +0100