Ubuntu

Change logs for “pyopengl” source package in Intrepid

  • pyopengl (3.0.0~b3-1ubuntu2) intrepid; urgency=low
    
      * Fix broken glRenderMode() with patch 4_fix_broken_glRenderModer.dpatch
        (Closes LP: #283717) (thanks Robert Ancell)
    
     -- Fabrice Coutadeur <email address hidden>   Thu, 16 Oct 2008 07:13:40 +0200
  • pyopengl (3.0.0~b3-1ubuntu1) intrepid; urgency=low
    
      * Merge from Debian unstable. Remaining Ubuntu changes:
          * debian/rules: don't use fixed pyversion for building docs
          * debian/control: changed Maintainer field, set to Ubuntu Motu.
    
    pyopengl (3.0.0~b3-1) unstable; urgency=low
    
      * New upstream release (Closes: #454988)
      * debian/control
        - update standard version to 3.8.0, no changes necessary
        - change dependency on python-ctypes to
          python-ctypes | python (>= 2.5) (Closes: #485594)
        - only build-depend on python-dev, not python-all-dev
      * Handle missing Togl module gracefully,
        do not break the Python help system (Closes: #455896)
    
     -- Andrea Gasparini <email address hidden>   Fri, 04 Jul 2008 12:33:49 +0200
  • pyopengl (3.0.0~b1-2ubuntu1) intrepid; urgency=low
    
      * Merge from Debian unstable.(LP: #239858) Remaining Ubuntu changes:
          * Make python-ctypes a recommendation (python2.5 includes it).
          * Modify Maintainer value to match the DebianMaintainerField
            specification.
          * debian/rules:
              - clean target:
              - remove workaround for cdbs bug, which is fixed already
              - Do not remove setup.cfg from PyOpenGL.egg-info/SOURCES.txt.
                I could not find a reference why it was added and other packages
                do not remove it, too.
    
      * changelog: removed spurious file
      * debian/rules: don't use fixed pyversion for building docs
    
    pyopengl (3.0.0~b1-2) unstable; urgency=low
    
      * debian/rules
        - remove special renaming of *.egg-info directory, is now
          handled by python-central (Closes: #472042).
      * debian/control
        - depend on python-central >= 0.6.0
      * debian/python-opengl-doc.doc-base
        - change section to Programming/Python
    
    pyopengl (3.0.0~b1-1) unstable; urgency=low
    
      [ Piotr Ożarowski ]
      * Homepage field added
      * Rename XS-Vcs-* fields to Vcs-* (dpkg supports them now)
    
      [ Sandro Tosi ]
      * debian/watch
        - added file
      * debian/control
        - uniforming Vcs-Browser field
    
      [ Torsten Marek ]
      * New upstream release.
      * Added suggestion for libgle3
      * Updated standards version to 3.7.3, no changes necessary.
      * Added patch to remove setuptools-dependency on ctypes in setup.py
      * Replace dependency on python-setuptools with
        python-pkg-resources. (Closes: #468718)
      * Documentation is not included in source package, is now
        created during package build. Added build-dependencies
        on GL (libgl1), GLU (libglu1), GLUT (freeglut3) and
        GLE (libgle3) to make this possible.
    
     -- Andrea Gasparini <email address hidden>   Mon, 19 May 2008 03:10:01 +0200
  • pyopengl (3.0.0~b1-0ubuntu4) hardy; urgency=low
    
      * debian/control: Conflict/Replace python2.4-opengl, to allow upgrades from
        Dapper.
    
     -- William Grant <email address hidden>   Sun, 30 Mar 2008 18:42:58 +1100