Change logs for newsbeuter source package in Jaunty

  • newsbeuter (1.3-1) unstable; urgency=low
    
      * New upstream release
        - switched to smart pointers, should fix all remaining segfaults (Closes: #498377).
    
     -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  06 Dec 2008 22:02:43 +0000
  • newsbeuter (1.2-1) unstable; urgency=low
    
      * New upstream release.
        - Fix incomplete quoting fix for article URLs by replacing '
          with the proper encoding in hex (Closes: #497495).
      * Update rss_parser.cpp part of the use_system-wide-libs for the
        new download-timeout option.
    
    newsbeuter (1.1-1) unstable; urgency=medium
    
      * New upstream release.
        - Fixes arbitrary code execution via crafted URL if passed to external browser
      * Drop debian/patches/{external_command_execution, wrap-long-lines},
        applied upstream.
    
    newsbeuter (1.0-3) unstable; urgency=low
    
      * Remove calls to libnxml-depends and libmrss-depends from rules as they
        break newsbeuter upgrades because nxml and mrss stopped providing their
        -abi packages (Closes: #496772).
      * Fix calling external html-render by passing the command to /bin/sh -c
        instead of directly to execve (external_command_execution; Closes: #496766).
    
    newsbeuter (1.0-2) unstable; urgency=low
    
      * Make newsbeuter depend on stfl >= 0.19 as the highlighting in the
        feed list, article list and article view needs it.
      * debian/patches/wrap-long-lines to wrap long header lines in the article
        view (Closes: #491122).
    
    newsbeuter (1.0-1) unstable; urgency=low
    
      * New upstream release.
      * Bump Standards version to 3.8.0, no changes needed.
      * Bump compat level and debhelper dependency to 7.
      * Explicitly add libcurl4-gnutls-dev to build-depends to satisfy pkg-config.
      * Add quilt to build dependencies and introduce use_system-wide_libs to
        build newsbeuter with the system-wide libmrss and libnxml instead of
        directly patching the source with each release.
    
     -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  05 Nov 2008 10:43:00 +0000
  • newsbeuter (0.9.1-1+lenny3) testing-security; urgency=high
    
      * Non-maintainer upload by the Security Team.
      * Fix regression introduced with latest patch, only append the
        escaped URL once.
    
    newsbeuter (0.9.1-1+lenny2) testing-security; urgency=high
    
      * Non-maintainer upload by the Security Team.
      * Fix arbitrary code execution via crafted URL if URL is passed
        to external browser (No CVE id yet; Closes: #497495).
      * Do not build with internal nxml/mrss copy but use the system-wide
        libraries.
    
     -- William Grant <email address hidden>   Wed, 03 Sep 2008 19:17:33 +0200