Change logs for gnumeric source package in Karmic

  • gnumeric (1.9.9-1ubuntu2) karmic; urgency=low
    
      * src/dialogs/dialog-stf-preview.c: Replace usage of deprecated
        gtk_tree_view_column_get_cell_renderers() with
        gtk_cell_layout_get_cells() to avoid bad compilation due to missing
        prototypes. Patch backported from 1.9.10. (LP: #402175)
    
     -- Martin Pitt <email address hidden>   Tue, 15 Sep 2009 12:14:45 +0200
  • gnumeric (1.9.9-1ubuntu1) karmic; urgency=low
    
      * Merge from debian unstable, remaining changes:
        - Promoted gnumeric-doc to Recommends in gnumeric package for help to be
          installed automatically
        - gnumeric-gtk is a transitional package
        - gnumeric conflicts with gnumeric-gtk << 1.8.3-3ubuntu1
        - call initltool-update in po*
        - remove psiconv support (psiconv is in universe):
          o debian/control: remove B-D on libpsiconv-dev
          o debian/rules: don't pass --with-psiconv to ./configure
          o debian/gnumeric-plugins-extra.install: don't install the psiconv
            plugin
    
    gnumeric (1.9.9-1) unstable; urgency=low
    
      * New upstream development release.
      * [debian/control]
        * Bumped libgsf and goffice build dependencies as per per configure.in .
        * Updated Standards-Version.
    
     -- Gauvain Pocentek <email address hidden>   Mon, 22 Jun 2009 13:37:20 +0200
  • gnumeric (1.9.8-1ubuntu3) karmic; urgency=low
    
      * The "always test your changes even if they seem trivial" release
      * debian/gnumeric-plugins-extra.install: don't install the psiconv plugin
    
     -- Gauvain Pocentek <email address hidden>   Mon, 08 Jun 2009 21:15:18 +0200
  • gnumeric (1.9.8-1ubuntu2) karmic; urgency=low
    
      * debian/control: really drop the Build Dependency on libpsiconv-dev
    
     -- Gauvain Pocentek <email address hidden>   Mon, 08 Jun 2009 18:03:27 +0200
  • gnumeric (1.9.8-1ubuntu1) karmic; urgency=low
    
      * Merge from debian unstable, remaining changes:
        - Promoted gnumeric-doc to Recommends in gnumeric package for help to be
          installed automatically
        - gnumeric-gtk is a transitional package
        - gnumeric conflicts with gnumeric-gtk << 1.8.3-3ubuntu1
        - call initltool-update in po*
        - remove psiconv support (psiconv is in universe):
          o debian/control: remove B-D on libpsiconv-dev
          o debian/rules: don't pass --with-psiconv to ./configure
    
    gnumeric (1.9.8-1) unstable; urgency=low
    
      * New upstream development release.
      * [debian/control] Bumped libgsf and goffice build dependencies as per
        configure.in; updated scrollkeeper build dependency to rarian-compat |
        scrollkeeper.
    
    gnumeric (1.9.7-1) unstable; urgency=high
    
      * New upstream development release. Upstream changes include:
        * Fix xls export issue that made files readable by Gnumeric only.
        Urgency set accordingly.
      * [debian/control] Bumped libgsf and goffice build dependencies as per
        configure.in .
    
    gnumeric (1.9.6-1) unstable; urgency=low
    
      * New upstream development release. Upstream changes include:
        * Basic infrastructure for variable sheet sizes. For example, text and
          CSV files now load into sheets as big as needed and the silent
          truncation of a test DBF file with 65536 rows is no longer
          reproducible. (Closes: #252468, #331356)
      * [debian/control]
        * Bumped libgsf and goffice build dependencies as per configure.in .
        * Fixed debhelper-but-no-misc-depends.
        * Call dh_prep instead of dh_clean -k.
        * Updated Standards-Version.
        * Follow upstream VCS change: replaced Vcs-Svn by Vcs-git and updated
          Vcs-Browser.
      * [debian/gnumeric.install] Re-enabled schema installation.
      * [debian/gnumeric.prerm] Dropped. Fixes maintainer-script-empty.
      * [debian/rules]
        * Removed calls to dh_desktop which has been deprecated.
        * Removed --without-gnomedb, --without-gb, --without-bonobo from
          features; they are longer needed or recognised.
    
    gnumeric (1.9.5-1) unstable; urgency=low
    
      * New upstream development release.
      * [debian/control] Bumped glib, gtk and goffice build dependencies as per
        configure.in .
    
    gnumeric (1.9.4-1) unstable; urgency=low
    
      * New upstream development release. Uploading to unstable now that lenny
        has been released. Upstream changes include:
        * Fix for CVE-2009-0318, an untrusted search path vulnerability which
          affected the python-loader plugin which is part of the
          gnumeric-plugins-extra package. (Closes: #569648)
        * ssconvert(1) now documents the options for --export-options and has a
          simpler example to start with. (Closes: #406920, 511958)
        * gnumeric(1) now mentions ssconvert in SEE ALSO. (Closes: 511957)
        * Fix problem with functions docs in locales without encoding information.
          (Closes: #514127)
      * [debian/control] Updated glib, goffice and pango build dependencies,
        dropped gconf build dependency per configure.in . Dropped bonobo,
        libgnomeui, libgnome, libgsf-gnome build dependencies as we follow the
        new upstream default of a non-GNOME build. (Closes: #399323)
      * [debian/gnumeric.install] Removed gconf schemas which are no longer
        built.
      * [debian/gnumeric-common.install] Removed pattern for idl files as they
        are no longer built.
      * [debian/gnumeric.mime] Removed entry for obsolete, unofficial type
        text/x-comma-separated-values.
    
    gnumeric (1.9.3-1) experimental; urgency=low
    
      * New upstream development release. Upstream changes include:
        * Print wysiwyg. (Closes: #180378)
      * Fixed version numbering.
      * [debian/rules] Fix permissions of plugins under /usr/lib/goffice as well.
      * [debian/gnumeric.install] Install the plugins under /usr/lib/goffice as
        well.
      * [debian/control]
        * Updated goffice build dependency per configure.in .
        * Change the Recommends: evince to evince | evince-gtk. (Closes: #501897)
    
    gnumeric (1.9.2) experimental; urgency=low
    
      * New upstream development release.
      * [debian/compat] New; updated to current debhelper compatibility level.
      * [debian/rules] No longer set DH_COMPAT.
      * [debian/control]
        * Updated debhelper build dependency.
        * Bumped libgsf and pango build dependencies per configure.in .
        * Changed fonts suggestion now that the Liberation fonts are available in
          main and the Microsoft Corefonts installer package has been renamed.
          (Closes: #490039)
        * Cleaned up build dependencies to fix build-depends-on-1-revision lintian
          warning.
      * [debian/gnumeric.install, debian/gnumeric-common.install,
        debian/gnumeric-plugins-extra.install] Dropped some obsoleted patterns;
        commented out some patterns which have no current matches.
      * [debian/gnumeric.preinst] Added debhelper token.
    
    gnumeric (1.9.1-1) experimental; urgency=low
    
      * New upstream development release.
      * [doc/C/gnumeric-C.omf] Missing from tarball; added from SVN.
      * [debian/control]
        * Updated goffice build dependency per configure.in .
        * Reintroduced intltool build dependency. (Closes: #487581)
        * Updated Standards-Version.
      * [debian/gnumeric-common.install] Include the tango based icons which are
        now shipped upstream.
      * [debian/rules] Call dh_icons.
      * [debian/gnome-gnumeric.xpm] Updated, based on upstream 32x32 png icon.
    
    gnumeric (1.9.0-1) experimental; urgency=low
    
      * New upstream development release.
    
      * Upstream changes include:
        * Gnumeric graphs cannot always round trip through xls format, as
          Gnumeric's structure for graphs is richer than that supported by the xls
          format, e.g. Gnumeric supports multiple charts per graph and
          distinguishes between graph titles and chart titles, but the xls format
          only supports one chart per graph and just one title. When exporting to
          xls format, if there is no chart title, but there is a graph title, save
          that graph title. (Closes: #305399)
      * [debian/control] Update libgsf and goffice build dependencies as per
        configure.in .
      * [debian/gnumeric.install] Include ssgrep.
    
     -- Gauvain Pocentek <email address hidden>   Sun, 07 Jun 2009 11:10:47 +0200
  • gnumeric (1.8.4-3ubuntu2) jaunty; urgency=low
    
      * correct the IM interface so input works correctly again (LP: #333139),
        fixed in upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=575267,
        via the 1.8.x backported patch:
        http://bugzilla.gnome.org/attachment.cgi?id=130621&action=view
    
     -- Kees Cook <email address hidden>   Mon, 13 Apr 2009 08:48:46 -0700