Ubuntu

“seamonkey” 2.0.4+nobinonly-0ubuntu1 source package in The Lucid Lynx

Publishing history

2.0.4+nobinonly-0ubuntu1
PUBLISHED: Lucid pocket Release in component universe and section net
  • Published on 2010-04-28

Builds

Changelog

seamonkey (2.0.4+nobinonly-0ubuntu1) lucid; urgency=low

  * New upstream release v2.0.4 (SEAMONKEY_2_0_4_RELEASE) (LP: #461864)

  [ Fabien Tassin <email address hidden> ]
  * Add conditional support for system Cairo, NSS, NSPR
    - update debian/rules
  * Update icons from xpm to png
    - update debian/seamonkey-*.{install,links,menu}
  * We no longer need dynamic -lsoftokn, disable NSS_DYNAMIC_SOFTOKN
    - add debian/patches/no_dynamic_nss_softokn.patch
    - update debian/patches/series

  [ Micah Gersten <email address hidden> ]
  * Use versioned install directory
    - update debian/rules
  * Bump minimum versions of system libs; cairo to 1.8.8; NSPR to 4.8;
    NSS to 3.12.6
    - update debian/rules
  * Update .install files for latest release
    - update debian/seamonkey-browser.install
    - update debian/seamonkey-mailnews.install
  * Refresh patches
    - update debian/patches/cleaner_dist_clean.patch
    - update debian/patches/fix_installer.patch
    - update debian/patches/seamonkey-fsh.patch
  * Drop cairo FTBFS patch after upstream landing
    - drop debian/patches/fix_ftbfs_with_cairo_fb.patch
    - update debian/series
  * Install gnome components in -browser package so that it works out of the box
    - update debian/seamonkey-browser.install
    - update debian/control
    - update debian/rules
  * Move mozclient to be in source
    - add debian/mozclient/compare.mk
    - add debian/mozclient/seamonkey-remove.binonly.sh
    - add debian/mozclient/seamonkey.conf
    - add debian/mozclient/seamonkey.mk
    - update debian/rules

  [ Chris Coulson <email address hidden> ]
  * Ensure the symlinks are installed correctly. File name expansion
    doesn't work in the .links files, so call dh_link explicitly in
    debian/rules instead
    - drop debian/seamonkey-browser.links
    - drop debian/seamonkey-mailnews.links
    - update debian/rules
  * Only the seamonkey-gnome-support package should have dependencies on GNOME
    libraries - ensure that seamonkey-browser doesn't have the GNOME components
    installed when dh_shlibdeps is run
    - update debian/rules
    - update debian/seamonkey-browser.install
 -- Micah Gersten <email address hidden>   Mon, 26 Apr 2010 14:30:57 -0500