Change logs for sl-modem source package in Maverick

  • sl-modem (2.9.11~20100718-2) unstable; urgency=low
    
      * debian/sl-modem-daemon.init: Run 'aplay -l' with LC_ALL=C to fix modem
        detection with non-English locales (Closes: #626231) (LP: #626231), patch
        submitted by: Milan Bouchet-Valat <email address hidden>
      * debian/control: Bumped Standards-Version to 3.9.1, no changes needed.
    
    sl-modem (2.9.11~20100718-1) unstable; urgency=low
    
      * New upstream release.
      * debian/watch: Fixed mangling to get a proper orig tarball
      * Removed 2.6.33.diff patch as it got applied upstream.
      * debian/copyright: Replaced empty lines in license text with ' .'
     -- ???? ???????? (Ahmed El-Mahmoudy) <email address hidden>   Mon,  06 Sep 2010 11:28:12 +0100
  • sl-modem (2.9.11~20100303-5) unstable; urgency=low
    
      * debian/sl-modem-daemon.bug-*: Added reportbug customization and script
        files.
      * debian/rules: put sequence to run before any option (for
        compatibility with debhelper v8)
      * Update Danish translation (Closes: #586239)
      * debian/source_sl-modem.py: Enhance apport hook
        + Add output of: ls -l /dev/ttySL* /dev/pts/* /dev/slamr* /dev/slusb
        + Interacts with user to specify the problem.
        + Check for ALSA mode if problem is with fax.
        + Ask to test with WvDial if problem is with dialup, also attach wvdial
          conf file (if it exists).
      * debian/control:
        + Bumped Standards-Version to 3.9.0
        + sl-modem-source (<< 2.9.11~20080817) moved from Conflicts to Breaks
     -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden>   Sat, 10 Jul 2010 14:22:38 +0300
  • sl-modem (2.9.11~20100303-4) unstable; urgency=low
    
      * Updated to ungrab-winmodem 20090716 from upstream. Credits to
        Harald Jenny <email address hidden> for the heads up.
      * Added patch 2.6.33.diff, to use path of utsrelease.h for linux
        kernels >= 2.6.33 Credits to Harald Jenny
        <email address hidden> for the heads up
      * debian/source_sl-modem.py, debian/sl-modem-daemon.install: Added an apport
        hook.
     -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  24 Jun 2010 19:23:00 +0100
  • sl-modem (2.9.11~20100303-3) unstable; urgency=low
    
      * debian/control, debian/copyright: Updated my email address
      * Update Spanish translations (Closes: #577050)
      * sl-modem-daemon.postinst: Remove /etc/modprobe.d/sl-modem-daemon.modutils
        on upgrade/install (Closes: #579825).
     -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  10 May 2010 09:05:38 +0100
  • sl-modem (2.9.11~20100303-2) unstable; urgency=low
    
      * debian/control:
        + Really remove quilt from sl-modem-source's Depends
        + Add execstack to Build-Deps
      * debian/rules: Mark slmodemd as not requiring executable stack
        (LP: #537650)
    
    sl-modem (2.9.11~20100303-1) unstable; urgency=low
    
      * New upstream release.
        + Fixes NO CARRIER issue with linux kernel >= 2.6.31
      * Dropped 2.6.31.diff patch, as it got applied upstream.
      * Refreshed debian/sl-modem-source.lintian-overrides
      * debian/control: Added DM-Upload-Allowed field.
      * Only include modem/modem_defs.h in sl-modem-source
      * debian/rules: add -s switch to dh to correctly build on amd64 archs.
    
    sl-modem (2.9.11~20090222-3) unstable; urgency=low
    
      [ Rolf Leggewie ]
      * debian/control:
        - add myself to Uploaders
        - update description for sl-modem-daemon package. (LP: #109620)
        - request the package to be autobuilt (adjust debian/copyright accordingly)
        - drop kernel-package from Recommends, we use dkms
        - move linux-headers from Recommends to Depends and make more robust
        - stop to provide sl-modem-modules-new which has been unused for years now
      * debian/patches: add autoload.diff patch from Ubuntu
        (Ubuntu should be able to go back to sync mode now)
    
      [ أحمد المحمودي (Ahmed El-Mahmoudy) ]
      * debian/control:
        - sl-modem-source conflicts with sl-modem-daemon version 2.9.11~20080817
          and earlier (LP: #520890)
        - Bump Standards-Version to 3.8.4
      * debian/sl-modem-daemon.init: Fix error message when slamr is not found
        (LP: #42991)
      * debian/sl-modem-source.postinst: use DKMS-provided logic instead of
        maintaining our own (LP: #497149)
    
    sl-modem (2.9.11~20090222-2) unstable; urgency=low
    
      * Switch to 3.0 (quilt) source format.
      * Removed debian/sl-modem-daemon.dirs
      * Added debian/sl-modem-daemon.preinst to remove obsolete
        sl-modem-daemon.modutils conf file. (from Ubuntu although for a different
        purpose)
      * Added debian/sl-modem-daemon.lintian-overrides
      * Install sl-modem.conf using dh_installmodules
      * debian/dkms.conf.in: Use 'cd' instead of popd & pushd
      * debian/control:
        + s/Alsa/ALSA in extended description.
        + Bumped Standards-Version to 3.8.3
      * Added 2.6.31.diff patch to fix FTBFS with kernels >= 2.6.31
        (Closes: #563823)
      * debian/sl-modem-daemon.init:
        + Added $remote_fs to Required-Start & Required-Stop
        + Added sl-modem-daemon to Provides
      * debian/NEWS: Use regular paragraphs rather than asterisks.
    
    sl-modem (2.9.11~20090222-1) unstable; urgency=low
    
      * New upstream release.
      * Refreshed patch: 01_Makefile.diff
      * Removed patches that were merged upstream: 02_dial_string_size.diff,
        03_Makefile_2.6.12.4.diff, 05_st7554_license.diff, README.diff,
        06_slmodem-class-simple-to-class-meins.diff, kernel-ver.diff,
        fortify_source.diff, class_device.diff
      * Remove support for module-assistant
        + debian/rules:
          - Remove binary-modules, kdist_clean & kdist_config targets and the
            variables/includes associated with them (including AGE, k & SUBLEVEL
            variables).
          - Remove lines that create/install /usr/src/sl-modem.tar.bz2 from
            install target.
        + debian/control for sl-modem-source target:
          - Remove module-assistant, debhelper, bzip2, quilt from Depends field.
          - Remove mention of module-assistant from extended description.
          - Added: Provides: sl-modem-modules, sl-modem-modules-new
        + sl-modem-daemon.README.Debian: Remove mention of module-assistant.
        + debian/README.Debian:
          - Removed mention of module-assistant & make-kpkg.
          - Rephrased the paragraph about manual building of modules.
        + Merge sl-modem-modules-_KVERS_.postinst.modules.in into
          sl-modem-source.postinst:
          - Use invoke-rc.d instead of directly running sl-modem-daemon init
            script.
          - Remove sl-modem-modules-_KVERS_.postinst.modules.in
          - Removed code that creates slamr and slusb devices.
          - Renamed daemon-stop function to daemon_stop to remove bashism.
        + Remove sl-modem-source.dirs
      * Removed debian/hotplug
      * debian/rules: simplified rules file
      * Removed debian/control.modules.in
      * Updated Japanese translation (Closes: #518603).
      * Rename sl-modem-daemon.modutils to sl-modem.conf (Closes: #519672).
      * debian/copyright: converted to machine readable format.
      * Merge changes from Ubuntu:
        + debian/patches/autoload.diff: Patch drivers to export the right aliases
          for auto-load on open.
        + Hence remove alias lines from sl-modem.conf.
      * debian/control:
        + Added Vcs-* fields.
        + Bump Standards-Version to 3.8.2, no changes needed
        + Build-Depend on debhelper >= 7.0.50~ to support override targets.
        + Build-Depend on quilt >= 7.0.50~ to support dh --with quilt
      * debian/compat, debian/control: Upgraded to debhelper 7
      * debian/sl-modem.conf: add entries for slusb loading.
      * Added debian/sl-modem-source.lintian-overrides,
        debian/sl-modem-daemon.manpages and debian/NEWS
    
    sl-modem (2.9.11~20080817-4) unstable; urgency=low
    
      * Added libc6-dev to sl-modem-source's Depends: field.
      * debian/patches/*.diff: add contributor info.
      * debian/sl-modem-daemon.init (change from Ubuntu): Also check for modems
        which are subdevices, and thus only expose themselves in "aplay -l", not
        in /proc/asound/cards. Thanks to Peteris Krisjanis for the patch! (Closes:
        #517055).
      * Added 12_ulimit_warn.diff from Corey Hickey, that checks the current limit
        and makes slmodemd warn & die if the limit is judged to be too low (< 8
        MB). (Closes: #511996)
      * Added 13_slusb.diff patch to enable support for slusb module.
      * debian/dkms.conf.in:
        + Added USB=1 in make[0] field to enable compilation of slusb module.
        + Added fields for slusb module.
      * debian/sl-modem-daemon.config: use set -e instead of passing -e to the 
        shell on the #! line.
      * Provide pm-utils hook script to restart slmodem daemon on resume:
        + Added debian/15sl-modem-daemon
        + debian/rules: install debian/15sl-modem-daemon in 
          /usr/lib/pm-utils/sleep.d
        Based on patches submitted by: Julien Valroff <email address hidden>, "Tim 
        Dijkstra \(tdykstra\)" <email address hidden> (Closes: #411851).
     -- ???? ???????? (Ahmed El-Mahmoudy) <email address hidden>   Mon,  22 Mar 2010 18:17:38 +0000