Ubuntu

“libreoffice” 1:3.3.4-0ubuntu1.4 source package in The Natty Narwhal

Publishing history

1:3.3.4-0ubuntu1.4
OBSOLETE: Natty pocket Updates in component main and section editors
  • Removed from disk on 2013-06-04.
  • Removal requested on 2013-06-04.
  • Published on 2012-08-14
  • Copied from ubuntu natty in Private PPA for Ubuntu Security Team by Ubuntu Archive Robot
1:3.3.4-0ubuntu1.4
OBSOLETE: Natty pocket Security in component main and section editors
  • Removed from disk on 2013-06-04.
  • Removal requested on 2013-06-04.
  • Published on 2012-08-14
  • Copied from ubuntu natty in Private PPA for Ubuntu Security Team by Marc Deslauriers

Changelog

libreoffice (1:3.3.4-0ubuntu1.4) natty-security; urgency=low

  * SECURITY UPDATE: arbitrary code execution via XML manifest encryption
    tag parsing code
    - debian/patches/CVE-2012-2665.patch: merge base64 encoders/decoders,
      check key size, unwind manifest xml parser and follow tag hierarchy
      model, count and order of receipt of properties doesn't matter,
      use sax::Converter::base64 code instead, ThreeByteToFourByte and
      friends are no longer in use.
    - CVE-2012-2665
 -- Marc Deslauriers <email address hidden>   Thu, 09 Aug 2012 13:28:35 -0400