Change logs for gnome-do-plugins source package in Oneiric

  • gnome-do-plugins (0.8.4-1build1) oneiric; urgency=low
    
      * Rebuild for mono 2.10 transition.  Fixes GNOME Do crash on startup.
        (LP: #816507)
     -- Christopher James Halse Rogers <email address hidden>   Wed, 27 Jul 2011 10:16:32 +1000
  • gnome-do-plugins (0.8.4-1) unstable; urgency=low
    
      [ Iain Lane ]
      * Update to use my d.o email address
    
      [ Christopher James Halse Rogers ]
      * Imported Upstream version 0.8.4
      * Drop 02_gdata_1.7_compatibility.diff; fixed upstream
      * Bump gnome-do depends versioning to 0.8.5 for new plugin APIs
      * Add --enable-release configure flag; upstream's build system is fixed now.
      * Use ‘--with cli’ in rules to avoid warning spam
      * Remove mention of long-dead Evolution plugin from package description.
        (LP: 682228)
      * Add dllmap files for WindowManager and XRandR plugins
    
    gnome-do-plugins (0.8.3-1) unstable; urgency=low
    
      * It came from the deep! New upstream release
      * debian/rules:
        - Now 100% dfsg-free; drop get-orig-source logic
        - Drop autoreconf-ing; we no longer need to patch the build system.
        - Add “--with” quilt to actually apply the patches.
        - Delete *.addin.xml files on clean; these are autogenerated files which
          shouldn't be in the tarball, and they clutter the debian diff.
        - Upstream buildsystem no longer fails without unused mautil.  Drop it from
          configure.
      * debian/patches/00_debian_default_plugins.patch:
        - Refresh for new upstream version.
      * debian/patches/02_fix_firefox_icon.patch:
        - Drop; fixed in more generality upstream.
      * debian/control:
        - Bump runtime and build-depends on gnome-do to 0.8.4.
        - Add libdbus1.0-cil-dev and libdbus-glib1.0-cil-dev to Build-Depends for
          Empathy plugin.
        - Bump Standards-Version; no changes required.
        - Transition VCS-* fields to git
      * debian/patches/02_gdata_1.7_compatibility.diff:
        - Drop address field from the GMail contacts plugin; this API changed in
          gdata .NET 1.7, and needs fixing upstream
     -- Chris Halse Rogers <email address hidden>   Tue,  28 Jun 2011 09:18:25 +0000
  • gnome-do-plugins (0.8.3-0ubuntu1) natty; urgency=low
    
      * Pre-sync from Debian git.  All Ubuntu changes are now upstream.
      * It came from the deep! New upstream release
      * debian/rules:
        - Now 100% dfsg-free; drop get-orig-source logic
        - Drop autoreconf-ing; we no longer need to patch the build system.
        - Add “--with” quilt to actually apply the patches.
        - Delete *.addin.xml files on clean; these are autogenerated files which
          shouldn't be in the tarball, and they clutter the debian diff.
        - Upstream buildsystem no longer fails without unused mautil.  Drop it from
          configure.
      * debian/patches/00_debian_default_plugins.patch:
        - Refresh for new upstream version.
      * debian/patches/02_fix_firefox_icon.patch:
        - Drop; fixed in more generality upstream.
      * debian/control:
        - Bump runtime and build-depends on gnome-do to 0.8.4.
        - Add libdbus1.0-cil-dev and libdbus-glib1.0-cil-dev to Build-Depends for
          Empathy plugin.
        - Bump Standards-Version; no changes required.
        - Transition VCS-* fields to git
      * debian/patches/02_gdata_1.7_compatibility.diff:
        - Drop address field from the GMail contacts plugin; this API changed in
          gdata .NET 1.7, and needs fixing upstream
     -- Christopher James Halse Rogers <email address hidden>   Mon, 21 Feb 2011 22:31:09 +1100