Ubuntu

“firefox” 12.0+build1-0ubuntu0.12.04.1 source package in The Precise Pangolin

Publishing history

12.0+build1-0ubuntu0.12.04.1
SUPERSEDED: Precise pocket Updates in component main and section web
  • Removed from disk on 2012-07-16.
  • Removal requested on 2012-06-07.
  • Superseded on 2012-06-06 by firefox - 13.0+build1-0ubuntu0.12.04.1
  • Published on 2012-04-26
  • Copied from ubuntu precise in PPA for Ubuntu Mozilla Security Team
12.0+build1-0ubuntu0.12.04.1
SUPERSEDED: Precise pocket Security in component main and section web
  • Removed from disk on 2012-07-16.
  • Removal requested on 2012-06-07.
  • Superseded on 2012-06-06 by firefox - 13.0+build1-0ubuntu0.12.04.1
  • Published on 2012-04-26
  • Copied from ubuntu precise in PPA for Ubuntu Mozilla Security Team

Builds

Changelog

firefox (12.0+build1-0ubuntu0.12.04.1) precise-security; urgency=low

  * New upstream stable release (FIREFOX_12_0_BUILD1)
    - see LP: #987262 for USN information

  * Update globalmenu-extension to 3.2.3
    - Fix regression introduced by the fix for LP: #915888
  * Firefox recommends libcanberra0 now that bmo: #635918 has landed
    - update debian/control{,in}
  * Refresh patches
    - update debian/patches/avoid-dbus-roundtrip-for-httpchannel.patch
    - update debian/patches/no-sps-profiler-on-unsupported-archs.patch
    - update debian/patches/ubuntu-codes-google.patch
  * Refresh locales
    - refresh debian/config/locales.all
    - refresh debian/control
  * Make the language packs Architecture: any. Whilst they are actually
    architecture independent, we do install them in to /usr/lib (as the
    extensions location is shared with architecture-specific extensions).
    This also avoids the problem of offering incompatible language pack
    upgrades to users on architectures where Firefox fails to build
    (I'm looking at you, powerpc)
    - update debian/control.langpacks
    - update debian/control.langpacks.unavail
    - update debian/rules
    - refresh debian/control
  * Disable fix-build-failure-without-yarr-jit.patch, as it needs some work.
    This means that there is currently no powerpc support
 -- Chris Coulson <email address hidden>   Mon, 23 Apr 2012 13:13:27 +0100