Ubuntu

“isc-dhcp” 4.1.ESV-R4-0ubuntu5.5 source package in The Precise Pangolin

Publishing history

4.1.ESV-R4-0ubuntu5.5
SUPERSEDED: Precise pocket Updates in component main and section net
  • Removal requested on 2013-01-26.
  • Superseded on 2013-01-25 by isc-dhcp - 4.1.ESV-R4-0ubuntu5.6
  • Published on 2012-09-18
  • Copied from ubuntu precise in Private PPA for Ubuntu Security Team by Ubuntu Archive Robot
4.1.ESV-R4-0ubuntu5.5
PUBLISHED: Precise pocket Security in component main and section net
  • Published on 2012-09-18
  • Copied from ubuntu precise in Private PPA for Ubuntu Security Team by Marc Deslauriers

Builds

Changelog

isc-dhcp (4.1.ESV-R4-0ubuntu5.5) precise-security; urgency=low

  [ Jamie Strandboge ]
  * debian/dhclient-script.linux: Explicitly set the PATH to that of
    ENV_SUPATH in /etc/login.defs and unset various other variables. We need
    to do this so /sbin/dhclient cannot abuse the environment to escape
    AppArmor confinement via this script. Don't worry about
    debian/dhclient-script.linux.udeb or debian/dhclient-script.kfreebsd*
    since AppArmor isn't used in these environments.
    - LP: #1045986

  [ Marc Deslauriers ]
  * SECURITY UPDATE: denial of service via ipv6 lease expiration time
    reduction
    - debian/patches/CVE-2012-3955.patch: properly handle time reduction in
      server/dhcpv6.c, server/mdb6.c.
    - CVE-2012-3955
 -- Marc Deslauriers <email address hidden>   Fri, 14 Sep 2012 12:58:33 -0400