Ubuntu

Change logs for “fuse-emulator” source package in Quantal

  • fuse-emulator (1.0.0.1a+dfsg1-4) unstable; urgency=low
    
    
      * Add headers to all patches.
      * 01_compile-without-roms.patch: apply against Makefile.am and
        configure.in.
        - debian/control: Add build dependency on dh-autoreconf.
        - debian/rules: Run dh --with autoreconf.
      * 09_dont-use-sdl-audio.patch: Don't use the SDL audio driver, it has
        issues with PulseAudio. Use Alsa instead.
      * 10_fix-joystick-crash.patch: Don't crash with joysticks with more than
        10 buttons (Closes: #665640).
      * Use the 48x48 version of the Fuse icon:
        - debian/control: build-depend on icoutils instead of imagemagick.
        - debian/fuse-emulator-common.install: change icon path.
        - debian/rules: use icotool to extract the icon.
      * Disable GObject cast checks in the GTK+ version:
        - debian/rules: add -DG_DISABLE_CAST_CHECKS to the CFLAGS variable.
      * debian/control: update Standards-Version to 3.9.3.
      * debian/copyright: update debian copyright format URL.
    
     -- Alberto Garcia <email address hidden>  Sun, 25 Mar 2012 23:43:31 +0300
  • fuse-emulator (1.0.0.1a+dfsg1-1) unstable; urgency=low
    
      * New upstream release.
      * debian/control: add dependency on opense-basic as an alternative to
        spectrum-roms, but suggest spectrum-roms anyway.
      * debian/control: move the package from contrib to main. Now that
        there's opense-basic, the non-free package spectrum-roms is no longer
        a requisite. See README.Debian for details.
      * debian/control: add DM-Upload-Allowed flag.
      * debian/control: update Standards-Version to 3.9.2.
      * Refresh 04_unfiltered-audio.patch.
      * New patches:
        - 06_load-opense-rom.patch: load the OpenSE BASIC ROM if the original
          Spectrum ROMs are not found.
        - 07_disable-autoload.patch: don't use the auto load feature with
          OpenSE BASIC.
      * debian/watch: update regular expression to include letters in the
        version number.
      * debian/README.Debian: update notes to mention OpenSE BASIC.
      * debian/copyright: the legal status of the ROMs distributed in the
        upstream tarball is not unclear anymore.
      * debian/copyright: list files released under the GNU LGPL.
      * debian/fuse-emulator-{common,gtk,sdl}.lintian-overrides: the package
        description is really meant to start with 'The'.
    
    fuse-emulator (1.0.0+dfsg1-1) unstable; urgency=low
    
      * Initial release (Closes: #608203).
     -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  27 Jun 2011 11:22:17 +0000