Change logs for atomix source package in Xenial

  • atomix (3.19.4-1) unstable; urgency=medium
    
      * Imported Upstream version 3.19.4.
      * Vcs-Git: Use https.
      * Drop icon-path.patch. No longer needed because a new svg icon is provided
        now.
    
     -- Markus Koschany <email address hidden>  Sun, 24 Jan 2016 15:44:58 +0100
  • atomix (3.19.3-1) unstable; urgency=medium
    
      * Imported Upstream version 3.19.3.
    
     -- Markus Koschany <email address hidden>  Sat, 19 Dec 2015 01:25:47 +0100
  • atomix (3.19.2-1) unstable; urgency=medium
    
      * Imported Upstream version 3.19.2.
      * Update my e-mail address.
    
     -- Markus Koschany <email address hidden>  Tue, 08 Dec 2015 00:33:13 +0100
  • atomix (3.18.0-1) unstable; urgency=medium
    
      * Imported Upstream version 3.18.0.
      * Drop fix-incorrect-arrow-click-sensitivity.patch. Fixed upstream.
    
     -- Markus Koschany <email address hidden>  Wed, 28 Oct 2015 18:34:10 +0100
  • atomix (3.16.0-1) unstable; urgency=medium
    
      * Imported Upstream version 3.16.0. (Closes: #780714)
      * debian/control:
        - Use dh-autoreconf instead of autotools_dev.
        - Add gettext, appstream-util and libgtk-3-dev to Build-Depends.
        - Drop obsolete GNOME 2 build-dependencies.
        - Use cgit for Vcs-Browser field.
        - Update homepage field and use gnome.org address.
      * Declare compliance with Debian Policy 3.9.6.
      * Update debian/watch to detect newer upstream releases.
      * Drop all patches. They were merged or fixed upstream.
      * Add icon-path.patch.
        Since DATADIR is /usr/share/games in Debian this patch is necessary for
        finding atomix-icon.png. It can be dropped when upstream fixes the
        installation path and installs the icon to the hicolor directory.
      * atomix-data.install: Do not install obsolete gnome directory.
      * Drop atomix-data.links and install the data to
        /usr/share/games/atomix
      * debian/rules:
        - Remove dh_fixperms override.
        - Do not add -lm to LDFLAGS and build with autoreconf. This ensures that
          Atomix will not FTBFS on Ubuntu any more. (Closes: #773094)
        - Use dh_install --fail-missing.
        - Add datadir option to dh_auto_configure.
        - Add get-orig-source target.
      * atomix.install: Do not install non-existent /var/games directory.
      * atomix-data.install: Install /usr/share/locale directory
      * atomix-data.install: Install /usr/share/appdata directory.
      * Update debian/copyright for new release
      * Add clean file and ensure that Atomix can be built twice in a row.
      * Add fix-incorrect-arrow-click-sensitivity.patch
        Cherry-pick upstream commit f53a3905e790170b1ad5e7f9dcb0c78c7fe841f2
        to fix a bug with selecting nearby atoms.
      * Add fix-locale-dir.patch and fix incorrect directory of installed
        translation files due to Debian specific datadir.
    
     -- Markus Koschany <email address hidden>  Sun, 26 Apr 2015 21:15:24 +0200