Change logs for libvncserver source package in Xenial

  • libvncserver (0.9.10+dfsg-3ubuntu0.16.04.3) xenial-security; urgency=medium
    
      * SECURITY UPDATE: Multiple security issues
        - debian/patches/CVE-2018-*.patch: add upstream commits to fix
          multiple security issues.
        - debian/libvncserver1.symbols: updated for new symbols.
        - CVE-2018-6307, CVE-2018-15126, CVE-2018-15127, CVE-2018-20019,
          CVE-2018-20020, CVE-2018-20021, CVE-2018-20022, CVE-2018-20023,
          CVE-2018-20024, CVE-2018-20748, CVE-2018-20749, CVE-2018-20750
    
     -- Marc Deslauriers <email address hidden>  Wed, 30 Jan 2019 13:24:30 -0500
  • libvncserver (0.9.10+dfsg-3ubuntu0.16.04.2) xenial-security; urgency=medium
    
      * SECURITY UPDATE: integer overflow or memory access
        - debian/patches/CVE-2018-7225.patch: limit client cut text length to
          1 MB in libvncserver/rfbserver.c.
        - CVE-2018-7225
    
     -- Marc Deslauriers <email address hidden>  Fri, 30 Mar 2018 10:40:42 -0400
  • libvncserver (0.9.10+dfsg-3ubuntu0.16.04.1) xenial-security; urgency=medium
    
      * SECURITY UPDATE: heap overflows in rectangle fill functions
        - debian/patches/CVE-2016-9941.patch: add bounds checking to
          libvncclient/rfbproto.c.
        - CVE-2016-9941
      * SECURITY UPDATE: heap overflow in Ultra type tile decoder
        - debian/patches/CVE-2016-9942.patch: use _safe variant in
          libvncclient/ultra.c.
        - CVE-2016-9942
    
     -- Marc Deslauriers <email address hidden>  Fri, 06 Jan 2017 07:55:19 -0500
  • libvncserver (0.9.10+dfsg-3build1) xenial; urgency=medium
    
      * No-change rebuild for gnutls transition.
    
     -- Matthias Klose <email address hidden>  Wed, 17 Feb 2016 22:26:21 +0000
  • libvncserver (0.9.10+dfsg-3) unstable; urgency=medium
    
      * Avoid regeneration of rfbint.h and rfbconfig.h (Closes: #786822)
    
     -- Peter Spiess-Knafl <email address hidden>  Tue, 26 May 2015 00:12:15 +0200