strongswan source package in Xenial

libstrongswan: strongSwan utility and crypto library
libstrongswan-dbgsym: No summary available for libstrongswan-dbgsym in ubuntu wily.
strongswan: No summary available for strongswan in ubuntu wily.
strongswan-dbg: No summary available for strongswan-dbg in ubuntu wily.
strongswan-ike: No summary available for strongswan-ike in ubuntu wily.
strongswan-ike-dbgsym: No summary available for strongswan-ike-dbgsym in ubuntu xenial.
strongswan-ikev1: No summary available for strongswan-ikev1 in ubuntu wily.
strongswan-ikev2: No summary available for strongswan-ikev2 in ubuntu wily.
strongswan-nm: No summary available for strongswan-nm in ubuntu wily.
strongswan-nm-dbgsym: No summary available for strongswan-nm-dbgsym in ubuntu wily.
strongswan-plugin-af-alg: No summary available for strongswan-plugin-af-alg in ubuntu wily.
strongswan-plugin-af-alg-dbgsym: No summary available for strongswan-plugin-af-alg-dbgsym in ubuntu wily.
strongswan-plugin-agent: No summary available for strongswan-plugin-agent in ubuntu wily.
strongswan-plugin-agent-dbgsym: No summary available for strongswan-plugin-agent-dbgsym in ubuntu wily.
strongswan-plugin-attr-sql: strongSwan plugin for providing IKE attributes from databases
strongswan-plugin-attr-sql-dbgsym: No summary available for strongswan-plugin-attr-sql-dbgsym in ubuntu xenial.
strongswan-plugin-certexpire: No summary available for strongswan-plugin-certexpire in ubuntu wily.
strongswan-plugin-certexpire-dbgsym: No summary available for strongswan-plugin-certexpire-dbgsym in ubuntu wily.
strongswan-plugin-coupling: strongSwan plugin for permanent peer certificate coupling
strongswan-plugin-coupling-dbgsym: No summary available for strongswan-plugin-coupling-dbgsym in ubuntu wily.
strongswan-plugin-curl: No summary available for strongswan-plugin-curl in ubuntu wily.
strongswan-plugin-curl-dbgsym: No summary available for strongswan-plugin-curl-dbgsym in ubuntu wily.
strongswan-plugin-dhcp: No summary available for strongswan-plugin-dhcp in ubuntu wily.
strongswan-plugin-dhcp-dbgsym: No summary available for strongswan-plugin-dhcp-dbgsym in ubuntu wily.
strongswan-plugin-dnscert: No summary available for strongswan-plugin-dnscert in ubuntu wily.
strongswan-plugin-dnscert-dbgsym: No summary available for strongswan-plugin-dnscert-dbgsym in ubuntu wily.
strongswan-plugin-dnskey: No summary available for strongswan-plugin-dnskey in ubuntu wily.
strongswan-plugin-dnskey-dbgsym: No summary available for strongswan-plugin-dnskey-dbgsym in ubuntu wily.
strongswan-plugin-duplicheck: No summary available for strongswan-plugin-duplicheck in ubuntu wily.
strongswan-plugin-duplicheck-dbgsym: No summary available for strongswan-plugin-duplicheck-dbgsym in ubuntu wily.
strongswan-plugin-eap-aka: strongSwan plugin for generic EAP-AKA protocol handling
strongswan-plugin-eap-aka-3gpp2: No summary available for strongswan-plugin-eap-aka-3gpp2 in ubuntu wily.
strongswan-plugin-eap-aka-3gpp2-dbgsym: No summary available for strongswan-plugin-eap-aka-3gpp2-dbgsym in ubuntu wily.
strongswan-plugin-eap-aka-dbgsym: No summary available for strongswan-plugin-eap-aka-dbgsym in ubuntu xenial.
strongswan-plugin-eap-dynamic: strongSwan plugin for dynamic EAP method selection
strongswan-plugin-eap-dynamic-dbgsym: No summary available for strongswan-plugin-eap-dynamic-dbgsym in ubuntu wily.
strongswan-plugin-eap-gtc: strongSwan plugin for EAP-GTC protocol handler
strongswan-plugin-eap-gtc-dbgsym: No summary available for strongswan-plugin-eap-gtc-dbgsym in ubuntu wily.
strongswan-plugin-eap-md5: No summary available for strongswan-plugin-eap-md5 in ubuntu wily.
strongswan-plugin-eap-md5-dbgsym: No summary available for strongswan-plugin-eap-md5-dbgsym in ubuntu wily.
strongswan-plugin-eap-mschapv2: No summary available for strongswan-plugin-eap-mschapv2 in ubuntu wily.
strongswan-plugin-eap-mschapv2-dbgsym: No summary available for strongswan-plugin-eap-mschapv2-dbgsym in ubuntu wily.
strongswan-plugin-eap-peap: No summary available for strongswan-plugin-eap-peap in ubuntu wily.
strongswan-plugin-eap-peap-dbgsym: No summary available for strongswan-plugin-eap-peap-dbgsym in ubuntu xenial.
strongswan-plugin-eap-radius: strongSwan plugin for EAP interface to a RADIUS server
strongswan-plugin-eap-radius-dbgsym: No summary available for strongswan-plugin-eap-radius-dbgsym in ubuntu xenial.
strongswan-plugin-eap-sim: No summary available for strongswan-plugin-eap-sim in ubuntu wily.
strongswan-plugin-eap-sim-dbgsym: No summary available for strongswan-plugin-eap-sim-dbgsym in ubuntu wily.
strongswan-plugin-eap-sim-file: No summary available for strongswan-plugin-eap-sim-file in ubuntu wily.
strongswan-plugin-eap-sim-file-dbgsym: No summary available for strongswan-plugin-eap-sim-file-dbgsym in ubuntu xenial.
strongswan-plugin-eap-sim-pcsc: No summary available for strongswan-plugin-eap-sim-pcsc in ubuntu wily.
strongswan-plugin-eap-sim-pcsc-dbgsym: No summary available for strongswan-plugin-eap-sim-pcsc-dbgsym in ubuntu xenial.
strongswan-plugin-eap-simaka-pseudonym: strongSwan plugin for the EAP-SIM/AKA identity database
strongswan-plugin-eap-simaka-pseudonym-dbgsym: No summary available for strongswan-plugin-eap-simaka-pseudonym-dbgsym in ubuntu wily.
strongswan-plugin-eap-simaka-reauth: strongSwan plugin for the EAP-SIM/AKA reauthentication database
strongswan-plugin-eap-simaka-reauth-dbgsym: No summary available for strongswan-plugin-eap-simaka-reauth-dbgsym in ubuntu wily.
strongswan-plugin-eap-simaka-sql: strongSwan plugin for SQL-based EAP-SIM/AKA backend reading
strongswan-plugin-eap-simaka-sql-dbgsym: No summary available for strongswan-plugin-eap-simaka-sql-dbgsym in ubuntu wily.
strongswan-plugin-eap-tls: No summary available for strongswan-plugin-eap-tls in ubuntu wily.
strongswan-plugin-eap-tls-dbgsym: No summary available for strongswan-plugin-eap-tls-dbgsym in ubuntu wily.
strongswan-plugin-eap-tnc: No summary available for strongswan-plugin-eap-tnc in ubuntu wily.
strongswan-plugin-eap-tnc-dbgsym: No summary available for strongswan-plugin-eap-tnc-dbgsym in ubuntu wily.
strongswan-plugin-eap-ttls: strongSwan plugin for the EAP-TTLS protocol handler
strongswan-plugin-eap-ttls-dbgsym: No summary available for strongswan-plugin-eap-ttls-dbgsym in ubuntu wily.
strongswan-plugin-error-notify: No summary available for strongswan-plugin-error-notify in ubuntu wily.
strongswan-plugin-error-notify-dbgsym: No summary available for strongswan-plugin-error-notify-dbgsym in ubuntu wily.
strongswan-plugin-farp: No summary available for strongswan-plugin-farp in ubuntu wily.
strongswan-plugin-farp-dbgsym: No summary available for strongswan-plugin-farp-dbgsym in ubuntu xenial.
strongswan-plugin-fips-prf: No summary available for strongswan-plugin-fips-prf in ubuntu wily.
strongswan-plugin-fips-prf-dbgsym: No summary available for strongswan-plugin-fips-prf-dbgsym in ubuntu wily.
strongswan-plugin-gcrypt: strongSwan plugin for gcrypt
strongswan-plugin-gcrypt-dbgsym: No summary available for strongswan-plugin-gcrypt-dbgsym in ubuntu wily.
strongswan-plugin-gmp: No summary available for strongswan-plugin-gmp in ubuntu wily.
strongswan-plugin-gmp-dbgsym: No summary available for strongswan-plugin-gmp-dbgsym in ubuntu wily.
strongswan-plugin-ipseckey: No summary available for strongswan-plugin-ipseckey in ubuntu wily.
strongswan-plugin-ipseckey-dbgsym: No summary available for strongswan-plugin-ipseckey-dbgsym in ubuntu wily.
strongswan-plugin-kernel-libipsec: No summary available for strongswan-plugin-kernel-libipsec in ubuntu wily.
strongswan-plugin-kernel-libipsec-dbgsym: No summary available for strongswan-plugin-kernel-libipsec-dbgsym in ubuntu wily.
strongswan-plugin-ldap: strongSwan plugin for LDAP CRL fetching
strongswan-plugin-ldap-dbgsym: No summary available for strongswan-plugin-ldap-dbgsym in ubuntu wily.
strongswan-plugin-led: No summary available for strongswan-plugin-led in ubuntu wily.
strongswan-plugin-led-dbgsym: No summary available for strongswan-plugin-led-dbgsym in ubuntu xenial.
strongswan-plugin-load-tester: No summary available for strongswan-plugin-load-tester in ubuntu wily.
strongswan-plugin-load-tester-dbgsym: No summary available for strongswan-plugin-load-tester-dbgsym in ubuntu wily.
strongswan-plugin-lookip: strongSwan plugin for lookip interface
strongswan-plugin-lookip-dbgsym: No summary available for strongswan-plugin-lookip-dbgsym in ubuntu wily.
strongswan-plugin-mysql: No summary available for strongswan-plugin-mysql in ubuntu wily.
strongswan-plugin-mysql-dbgsym: No summary available for strongswan-plugin-mysql-dbgsym in ubuntu wily.
strongswan-plugin-ntru: No summary available for strongswan-plugin-ntru in ubuntu wily.
strongswan-plugin-ntru-dbgsym: No summary available for strongswan-plugin-ntru-dbgsym in ubuntu wily.
strongswan-plugin-openssl: No summary available for strongswan-plugin-openssl in ubuntu wily.
strongswan-plugin-openssl-dbgsym: No summary available for strongswan-plugin-openssl-dbgsym in ubuntu wily.
strongswan-plugin-pgp: strongSwan plugin for PGP encoding/decoding routines
strongswan-plugin-pgp-dbgsym: No summary available for strongswan-plugin-pgp-dbgsym in ubuntu wily.
strongswan-plugin-pkcs11: strongSwan plugin for PKCS#11 smartcard backend
strongswan-plugin-pkcs11-dbgsym: No summary available for strongswan-plugin-pkcs11-dbgsym in ubuntu wily.
strongswan-plugin-pubkey: No summary available for strongswan-plugin-pubkey in ubuntu wily.
strongswan-plugin-pubkey-dbgsym: No summary available for strongswan-plugin-pubkey-dbgsym in ubuntu wily.
strongswan-plugin-radattr: strongSwan plugin for custom RADIUS attribute processing
strongswan-plugin-radattr-dbgsym: No summary available for strongswan-plugin-radattr-dbgsym in ubuntu xenial.
strongswan-plugin-soup: No summary available for strongswan-plugin-soup in ubuntu wily.
strongswan-plugin-soup-dbgsym: No summary available for strongswan-plugin-soup-dbgsym in ubuntu wily.
strongswan-plugin-sql: strongSwan plugin for SQL configuration and credentials
strongswan-plugin-sql-dbgsym: No summary available for strongswan-plugin-sql-dbgsym in ubuntu xenial.
strongswan-plugin-sqlite: No summary available for strongswan-plugin-sqlite in ubuntu wily.
strongswan-plugin-sqlite-dbgsym: No summary available for strongswan-plugin-sqlite-dbgsym in ubuntu wily.
strongswan-plugin-sshkey: No summary available for strongswan-plugin-sshkey in ubuntu wily.
strongswan-plugin-sshkey-dbgsym: No summary available for strongswan-plugin-sshkey-dbgsym in ubuntu xenial.
strongswan-plugin-systime-fix: No summary available for strongswan-plugin-systime-fix in ubuntu wily.
strongswan-plugin-systime-fix-dbgsym: No summary available for strongswan-plugin-systime-fix-dbgsym in ubuntu wily.
strongswan-plugin-unbound: No summary available for strongswan-plugin-unbound in ubuntu wily.
strongswan-plugin-unbound-dbgsym: No summary available for strongswan-plugin-unbound-dbgsym in ubuntu wily.
strongswan-plugin-unity: No summary available for strongswan-plugin-unity in ubuntu wily.
strongswan-plugin-unity-dbgsym: No summary available for strongswan-plugin-unity-dbgsym in ubuntu xenial.
strongswan-plugin-whitelist: No summary available for strongswan-plugin-whitelist in ubuntu wily.
strongswan-plugin-whitelist-dbgsym: No summary available for strongswan-plugin-whitelist-dbgsym in ubuntu xenial.
strongswan-plugin-xauth-eap: No summary available for strongswan-plugin-xauth-eap in ubuntu wily.
strongswan-plugin-xauth-eap-dbgsym: No summary available for strongswan-plugin-xauth-eap-dbgsym in ubuntu wily.
strongswan-plugin-xauth-generic: strongSwan plugin for the generic XAuth backend
strongswan-plugin-xauth-generic-dbgsym: No summary available for strongswan-plugin-xauth-generic-dbgsym in ubuntu wily.
strongswan-plugin-xauth-noauth: No summary available for strongswan-plugin-xauth-noauth in ubuntu wily.
strongswan-plugin-xauth-noauth-dbgsym: No summary available for strongswan-plugin-xauth-noauth-dbgsym in ubuntu xenial.
strongswan-plugin-xauth-pam: No summary available for strongswan-plugin-xauth-pam in ubuntu wily.
strongswan-plugin-xauth-pam-dbgsym: No summary available for strongswan-plugin-xauth-pam-dbgsym in ubuntu wily.
strongswan-pt-tls-client: No summary available for strongswan-pt-tls-client in ubuntu wily.
strongswan-pt-tls-client-dbgsym: No summary available for strongswan-pt-tls-client-dbgsym in ubuntu xenial.
strongswan-starter: No summary available for strongswan-starter in ubuntu wily.
strongswan-starter-dbgsym: No summary available for strongswan-starter-dbgsym in ubuntu wily.
strongswan-tnc-base: strongSwan Trusted Network Connect's (TNC) - base files
strongswan-tnc-base-dbgsym: No summary available for strongswan-tnc-base-dbgsym in ubuntu wily.
strongswan-tnc-client: strongSwan Trusted Network Connect's (TNC) - client files
strongswan-tnc-client-dbgsym: No summary available for strongswan-tnc-client-dbgsym in ubuntu wily.
strongswan-tnc-ifmap: strongSwan plugin for Trusted Network Connect's (TNC) IF-MAP client
strongswan-tnc-ifmap-dbgsym: No summary available for strongswan-tnc-ifmap-dbgsym in ubuntu wily.
strongswan-tnc-pdp: strongSwan plugin for Trusted Network Connect's (TNC) PDP
strongswan-tnc-pdp-dbgsym: No summary available for strongswan-tnc-pdp-dbgsym in ubuntu wily.
strongswan-tnc-server: No summary available for strongswan-tnc-server in ubuntu wily.
strongswan-tnc-server-dbgsym: debug symbols for package strongswan-tnc-server

Versions published

Release

The package versions that were published when the distribution release was made.

Security

Package versions containing security fixes for the released distribution. It is a good idea to have security updates turned on for your system.

Updates

Package versions including new features after the distribution release has been made. Updates are usually turned on by default after a fresh install.

strongswan information

Current version:
5.3.5-1ubuntu3.8
Uploaded:
2018-09-26
Urgency:
Medium Urgency

Upstream connections

strongSwanmaster

strongSwan is a complete IPsec implementation for the Linux, Android, FreeBSD, Mac OS X and Windows operating systems. It interoperates with with most other IPsec-based VPN products via the IKEv2 or IKEv1 key exchange protocols. The focus of the strongSwan project is on strong authentication mechanisms using X.509 public key certificates and optional secure storage of private keys on smartcards through a standardized PKCS#11 interface. A rich choice of modular plugins adds additional features like Trusted Network Connect or advanced cryptographic algorithms.

Bug supervisor: no
Bug tracker: no
Branch: yes

There are no registered releases for the strongSwan ⇒ master.

Binary packages

Download files from current release (5.3.5-1ubuntu3.8)

File Size SHA-256 Checksum
strongswan_5.3.5.orig.tar.bz2 4.2 MiB 2c84b663da652b1ff180a1a73c24a3d7b9fc4b9b8ba6bd07f94a1e33092e6350
strongswan_5.3.5-1ubuntu3.8.debian.tar.xz 137.7 KiB 167e07f694b37ec0c9e7295ac407354d166543bbb2fa1665c9228301f8095414
strongswan_5.3.5-1ubuntu3.8.dsc 8.7 KiB 2359fc7914924da482ee888bfd0dac17836326a477bf4a08b0eb004c2504c4b6

Package relationships

Build dependencies

Platform-independent build dependencies

Platform-dependent build dependencies

Build conflicts

Platform-independent build dependencies

Platform-dependent build dependencies