Change logs for uriparser source package in Xenial

  • uriparser (0.8.4-1) unstable; urgency=medium
    
      * New upstream release.
      * debian/liburiparser-dev.links:
        - Bump library version to 1.0.20.
      * Add package liburiparser-doc:
        - debian/rules:
          + Add override_dh_auto_build-indep and override_dh_installdocs-indep
            to handle the build and install the html documentation.
        - debian/control:
          + Add Build-Depends-Indep.
          + Add new package liburiparser-doc.
        - New debian/liburiparser-doc.doc-base.
        - New debian/liburiparser-doc.dirs.
      * New debian/liburiparser-doc.lintian-overrides to override the lintian
        warning "embedded-javascript-library".
      * debian/copyright:
        - Change GPL-3.0+ to GPL-3+.
        - Change Upstream Mail Address to Sebastian Pipping <email address hidden>
      * debian/rules:
        - Add override_dh_compress to exclude *.qhp.
        - Remove -c0 from dh_makeshlibs call.
    
     -- Jörg Frings-Fürst <email address hidden>  Wed, 04 Nov 2015 07:02:13 +0100
  • uriparser (0.8.3-1) unstable; urgency=low
    
      * New upstream release.
      * New debian/upstream/metadata:
        - Add some DEP-12 upstream metadata.
    
     -- Jörg Frings-Fürst <email address hidden>  Wed, 07 Oct 2015 18:35:50 +0200
  • uriparser (0.8.2-1) unstable; urgency=low
    
      * New upstream release.
      * debian/control:
        - Bump Standards-Version to 3.9.6 (no changes required).
        - Remove unknown substitution variable ${shlibs:Depends}
          from liburiparser-dev.
      * Refresh debian/liburiparser1.symbols.
      * Refresh link to usr/lib/liburiparser.so in liburiparser-dev.links.
      * debian/copyright:
        - Add License and author for the new files:
          +  test/VersionSuite.*.
      * debian/source/options:
        - Removed because xz is now standard compression.
      * debian/rules:
        - Enable hardening.
        - Add override_dh_makeshlibs for testing symbols.
      * Enable mulitarch:
        - debian/rules:
          + Add --libdir to confflags
        - debian/liburiparser-dev.links:
          + Add dh-exec shebang line.
          + Add ${DEB_HOST_MULTIARCH}.
          + make file executable.
        - debian/*.install:
          + Change the path (add /*/).
        - debian/control:
          + Add dh-exec (>=0.3) to Build-Depends.
          + Add Pre-Depends: ${misc:Pre-Depends} to package liburiparser1.
          + Add Multi-Arch: same to package liburiparser1.
    
     -- Jörg Frings-Fürst <email address hidden>  Tue, 28 Apr 2015 08:18:53 +0200