libdlrestrictions1-dbgsym 0.15.24ubuntu1 (amd64 binary) in ubuntu zesty

 This package provides a DLRestrictions library that can be used to check
 compatibility of the external shared library (or plugin) against other
 libraries currently loaded in the global symbol object. It might help to avoid
 symbol clashes and provide means for graceful failure detection in advance
 before the first dlsym() call. Otherwise, usage of incompatible library might
 result in crashes or other unpredictable failures of the application.
 .
 A shared library that is protected by DLRestrictions provides a special symbol
 which defines conditions under which the library may be safely used. At the
 moment, the only restriction that may be imposed controls whether multiple
 SONAMEs of the same library can safely co-exist in the same symbol space.
 Shared library dependencies are also checked for compatibility.

Details

Package version:
0.15.24ubuntu1
Source:
pkg-kde-tools 0.15.24ubuntu1 source package in Ubuntu
Status:
Obsolete
Component:
universe
Priority:
Extra

Package relationships