Ubuntu Customization Kit

Script cancelled by user

Reported by whittmadden on 2006-06-13
2
Affects Status Importance Assigned to Milestone
Ubuntu Customization Kit
High
Fabrizio Balliano

Bug Description

This is using the ubuntu desktop Dapper Drake. When running the install script i can reproduce this error every time.

wmadden@wmadden-desktop:~/Desktop/uck-1.1$ ./customize-cd-gui
./customize-cd-gui: line 28: failure: command not found
./customize-cd-gui: line 107: --title: command not found
./customize-cd-gui: line 70: --stdout: command not found
Script cancelled by user

Can you run the script with "bash -x ./customize-cd-gui" and post the results?

Changed in uck:
assignee: nobody → krzysiek-launchpad-ubuntu-com
Kevin (tritz) wrote :

I got this error before I had installed xdialog.

This is listed as a requirement in the documentation, but I've encountered other errors because of missing packages as well (squashfs for example). It would be good to have a list of required packages for this script.

Kevin

> This is listed as a requirement in the documentation, but I've
> encountered other errors because of missing packages as well (squashfs
> for example). It would be good to have a list of required packages for
> this script.

i think we should do a script to check required packages in install them...

This script is called .deb ;)

For now, it should be stated clearly on page that dialog or Xdialog or kdialog should be installed.
I will check why the script does not fail when it does not find any of these,

> This script is called .deb ;)

quite right, but also a simple "apt-get install all packages needed"
could work for immediate solving :-))
fabrizio

Kevin (tritz) wrote :

I reproduced your error.

I tried a clean Ubuntu installation and installed xdialog.

However, the script fails, and when I tried 'which xdialog' (that the script uses) it doesn't find xdialog.

Kevin

Kevin (tritz) wrote :

Also, when I try and use the normal text-based dialog, I get a failure when the script tries to use dialog_choose_file to select the ISO image:

Can't make new window at (-4,0), size (31,78).

Kevin

You must have something broken with PATH.
Can you post output of "echo $PATH"?

As for the dialog problem, what size of terminal (rows and columns) do you use?

confirmed, on clean ubuntu install UCK is unable to detect dialog

Changed in uck:
assignee: krzysiek-launchpad-ubuntu-com → fabrizio-balliano
importance: Untriaged → High
status: Unconfirmed → Confirmed

solution

failure function can't be after the first call, code must be moved below

Changed in uck:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers