"Install updates"-button only refreshes update list in it_IT environement

Bug #51419 reported by Karianne Fog Heen on 2006-06-30
322
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Software Updater
Invalid
Medium
Unassigned
gksu (Ubuntu)
High
Michael Vogt
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

When I click the "Install updates"-button, um only goes through "examining the system", and then refreshes the updates list, and does not install. It seems to work correctly in synaptics.

simira@jupiter:~$ sudo update-manager
/usr/lib/python2.4/site-packages/apt/__init__.py:17: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)

(I run Dapper release version)

Changed in update-manager:
assignee: nobody → mvo
Marco Bianchi (petrucci82) wrote :

YES, I get exactly the same problem!

By now I check changelogs in update-maneger but upgrade via apt-get or aptitude...

Karianne Fog Heen (simira) wrote :

Seems to work now.

Changed in update-manager:
status: Unconfirmed → Confirmed
Michael Vogt (mvo) wrote :

Thanks for your bugreport and sorry for my late reply (I was on vacation).

@Marco Bianchi: does it work now for you too?

@Karianne Grønningsæter: did you changed anything on the system? or did it magically healed itself?

Thanks,
 Michael

Michael Vogt (mvo) on 2006-08-08
Changed in update-manager:
importance: Untriaged → Medium
Karianne Fog Heen (simira) wrote :

Only a regular update

Claudio Di Vita (cdivita) wrote :

I have the same problem on Edgy: the only way to update my system is through Synapatic or with apt-get

Damiano Dallatana (damidalla) wrote :

Same problem here. It started from the edgy beta version of update-manager AFAIK. Two updates later, the problem is still unresolved (at least for me).

Michael Vogt (mvo) wrote :

Could you please try with the latest synaptic version from edgy?

Changed in update-manager:
status: Confirmed → Needs Info
Damiano Dallatana (damidalla) wrote :

Last Synaptic update from edgy repos resolved the problem.
Great to have again an update-manager working... And thanks to everyone who resolved that. Consider yourself hugged!

Michael Vogt (mvo) wrote :

Thanks for confirming that the latest synaptic upload fixes the problem. I close the bug now, please reopen if you see this problem again.

Changed in update-manager:
status: Needs Info → Fix Released
status: Unconfirmed → Fix Released
Damiano Dallatana (damidalla) wrote :

There's a regression with this bug.
3 days ago, it was working as usual. Today I verified if there were new updates (edgy). There's only an update (human-icon-theme), but the update-manager returned to have this bug.
The problem should be in an update from the last 2/3 days (I do not really remember if in these days I always updated and controlled update-manager).

Changed in update-manager:
status: Fix Released → Needs Info
status: Fix Released → Needs Info
Michael Vogt (mvo) wrote :

@Damiano Dallatana:
Thanks for this additional information. Do I understand this correctly? You open update-managaer and it shows you a single update. If you then click on "install" no install window comes up and nothing is installed. It just re-reads the cache and the update is still there? Could you please run (in a termianl):
$ update-manager
and click on install and add the termianl output here?

Thanks,
 Michael

Damiano Dallatana (damidalla) wrote :

Yes, you did understand correctly.
I just tried with today's updates (firefox & firefox-gnome-support & iptables & ..., so more than one update)
Now, here's the output:

Introspect error: The name org.freedesktop.UpdateManager was not provided by any .service files
no listening object (The name org.freedesktop.UpdateManager was not provided by any .service files)
current dist not found in meta-release file

But this output does not come from the click on the install; it does come from the loading of update-manager.
Thanks for your work,
 Damiano

Michael Vogt (mvo) wrote :

Thanks for this additional information.

Are you using a ".it" environemnt? I can reproduce the problem in a it_IT environemnt.

Cheers,
 Michael

Damiano Dallatana (damidalla) wrote :

Yes, I am using ubuntu with it_IT i18n.

Michael Vogt (mvo) wrote :

I close the update-manager(upstream) task, one is enough to keep track of the issue.

Changed in update-manager:
status: Needs Info → Confirmed
status: Needs Info → Rejected
Emilio Scalise (emisca) wrote :

Me too, I also opened a duplicate bug, number 67857. Please close it as duplicate...

Michael Vogt (mvo) wrote :
Changed in gksu:
assignee: nobody → mvo
importance: Undecided → High
status: Unconfirmed → Confirmed
Luca Ferretti (elle.uca) wrote :

Just to clarify what appened to other people: we, the Italian Ubuntu translators, have used the following translation for a message in update-manager:

   Attendere, l'operazione potrebbe richiedere del tempo

Unfortunately this message is passed via command line to synaptic, adding the ' (apostrophe) too. (see bug 67112 for details)

This should be the cause of the misbehaving.

Wating for the upstream fix, the message was changed, removing the ' (s/l'operazione/questo), so the next langpack update should also fix the misbehavior. I'll report on it.

I beg your pardon!

i have the same problem, i opened a duplicate bug, by issuing sudo update-manager in a bash i get a notice that dbus is not working correctly.
i dunno how to apply a .diff so i am locked in the problem.

Michael Vogt (mvo) wrote : SRU: gksu

Hi,

I would like to ask for a SRU for gksu. The changelog is here:

+gksu (1.9.3-1ubuntu2.1) edgy-proposed; urgency=low
+
+ * debian/patches/01_quote_escape.diff:
+ - quote any " ' " charackters in the arguments so that it is
+ properly passed on to su/sudo (lp: #51419)
+
+ -- Michael Vogt <email address hidden> Tue, 24 Oct 2006 15:46:56
+0200

The full debdiff:
http://librarian.launchpad.net/4938156/gksu_1.9.3-1ubuntu2.1.debdiff

The problem here is that ' is used by gksu as a seperator but if a '
is also found in the commandline it is not properly escaped
there. This patches adds the required escaping. This currently breaks
update-managers call to synaptic in the "it" locale.

Cheers,
 Michael

Kees Cook (kees) wrote :

I'm rather alarmed that libgksu uses a plain string for the command to run, instead of passing an array, which wouldn't have these escaping issues. I'd like to see this corrected upstream, especially since only a few packages would need to be adjusted.

However, if this is just a quick patch, it will need to escape slash as well. Consider the case of:

  \'

already being in the argument. This patch would result in the string becoming:

  \\'

instead of the correctly escaped:

  \\\'

Michael Vogt (mvo) wrote :

Thanks Kees for looking over the patch again. I will fix it and re-send a debdiff.

Just to clarify, libgksu does use a array when it runs the command with execve() later, but the communication with gksu and its backend library has only a gksu_context_set_command(). For feisty we should probably add a patch to add gksu_context_set_argv() (if kov agrees of couse :)

Cheers,
 Michael

Matt Zimmerman (mdz) wrote :

On Fri, Oct 27, 2006 at 01:43:14PM +0200, Michael Vogt wrote:
> Hi,
>
> I would like to ask for a SRU for gksu. The changelog is here:
>
> +gksu (1.9.3-1ubuntu2.1) edgy-proposed; urgency=low
> +
> + * debian/patches/01_quote_escape.diff:
> + - quote any " ' " charackters in the arguments so that it is
> + properly passed on to su/sudo (lp: #51419)
> +
> + -- Michael Vogt <email address hidden> Tue, 24 Oct 2006 15:46:56
> +0200
>
> The full debdiff:
> http://librarian.launchpad.net/4938156/gksu_1.9.3-1ubuntu2.1.debdiff
>
> The problem here is that ' is used by gksu as a seperator but if a '
> is also found in the commandline it is not properly escaped
> there. This patches adds the required escaping. This currently breaks
> update-managers call to synaptic in the "it" locale.

If this is attempting to quote for the shell, it won't work. Single quotes
can't be escaped with backslashes.

--
 - mdz

Michael Vogt (mvo) wrote :

On Tue, Oct 31, 2006 at 10:35:21AM -0800, Matt Zimmerman wrote:
> On Fri, Oct 27, 2006 at 01:43:14PM +0200, Michael Vogt wrote:
> > Hi,
> >
> > I would like to ask for a SRU for gksu. The changelog is here:
> >
> > +gksu (1.9.3-1ubuntu2.1) edgy-proposed; urgency=low
> > +
> > + * debian/patches/01_quote_escape.diff:
> > + - quote any " ' " charackters in the arguments so that it is
> > + properly passed on to su/sudo (lp: #51419)
> > +
> > + -- Michael Vogt <email address hidden> Tue, 24 Oct 2006 15:46:56
> > +0200
> >
> > The full debdiff:
> > http://librarian.launchpad.net/4938156/gksu_1.9.3-1ubuntu2.1.debdiff
> >
> > The problem here is that ' is used by gksu as a seperator but if a '
> > is also found in the commandline it is not properly escaped
> > there. This patches adds the required escaping. This currently breaks
> > update-managers call to synaptic in the "it" locale.
>
> If this is attempting to quote for the shell, it won't work. Single quotes
> can't be escaped with backslashes.

Its not. It fixes the way gksu/libgksu communicate. gksu reads its
argv and uses a ' to seperate each arguemnt:
g_strconcat(command, " '",newargv[i], "'",NULL)).

It does not do any escaping if a ' is already in the string.

In libgksu (gksu_sudo_full() when the command is prepared for executing, it
goes over this string again and looks for ' to seperate the command
into a argv array again to execv() it. In gksu_su_full() it does
nothing but add:
cmd[i] = g_strdup_printf("%s \"%s\", auxcommand, context->command);

So it seems like the patch needs to be updated to only escape the '
when run in sudo mode. I will prepare a updated version.

I think in the longer run we probably want to gksu_context_set_argv().

Cheers,
 Michael

Giuliastro (messaggi-giulio) wrote :

I have the same update problem here and the same error. Are you planning to update the language files? No idea on how to patch using your diffs. Thank you.

Fabio Marzocca (thesaltydog) wrote :

By reading all posts in this bug report I thought the problem had been found, so the fix should have been came quickly.
Obviously, it is not yet arrived.

Italian community is all stuck with this bug and connot use update-manager. Is there any timetable to fix this bug?

Damiano Dallatana (damidalla) wrote :

As the development of Feisty did start, I think the best solution for this *really* annoying problem is to release with an high priority a workaround to give Italian users the possibility to update trough update-manager (the new l10n of ubuntu-manager should suffice), then postpone a better resolution to Feisty Fawn.
I am waiting for the bug to be resolved, as it really is a blocking bug for Italian newbies (and I am waiting to do 2 new Edgy setups!!).

Luca Ferretti (elle.uca) wrote :

Quick fix: download the MO file from here [1] and use it to replace the /usr/share/locale-lagpack/it/LC_MESSAGES/update-manager.mo file by hand

https://launchpad.net/distros/ubuntu/edgy/+source/update-manager/+pots/update-manager/it/+export

Vincenzo Ciancia (vincenzo-ml) wrote :

What is really needed is a fixed package in edgy-updates, so that a freshly installed system will never be broken by a system upgrade.

In the current situation people will not be able to upgrade their system unless an expert user explains to them that they have to right click on the update icon. This is embarassing for ubuntu, expecially in this period, when ubuntu is gaining high popularity, and must be quick-fixed urgently.

Don't want to be polemic, absolutely, just to explain my mood, and the mood that I also feel from other's comments.

I know people that *never* wanted to use free software, always telling that "computers are made to be just used, and linux is made to hack and I don't want to hack". Recently some of them have asked me to help them, not generically with "linux", they've asked me to help them install "ubuntu", they've been specific since ubuntu is "in vogue" now. This is really positive in my "ubuntu-lover" opinion, but bugs like this one can really destroy any positive impression newbies can get about the distro.

Sorry if this comment hurts anyone, it's not its purpose, I am grateful to package mantainers and translators for their good work in any case :)

Il giorno ven, 17/11/2006 alle 18.51 +0000, Vincenzo Ciancia ha scritto:
> What is really needed is a fixed package in edgy-updates, so that a
> freshly installed system will never be broken by a system upgrade.
>

The fastest way to get rid of this bug, would be to have a new italian
lang-pack!

--
Milo Casagrande <email address hidden>

Fabio (gandolaf) wrote :

I hope that this bug can be fixed soon.
I have found online a way to manually patch, but this way is not suitable for newbie users.
So I think that italian newbies should be able to update ubuntu without any trouble.

I hope that this can be fixed soon.

jackzanon (jackzanon) on 2006-12-01
Changed in update-manager:
assignee: mvo → jackzanon
status: Rejected → Confirmed
assignee: jackzanon → nobody
status: Confirmed → Rejected
marwin82 (marwin82) wrote :

hi fabio

can you send the url for the manually patch of this bug?
or some instructions?

Damiano Dallatana (damidalla) wrote :

With yesterday's update of language-pack-it (and relatives) the problem does not show up any more (thank you Luca!!! consider yourself hugged) . I think it is only the effect of the "corrected" translation (as a workaround).
So, the functionality is restored for us Italian people, and Feisty is waiting for the complete patch to the bug...

Michael Vogt (mvo) wrote :

I fixed the underlying problem in gksu/libgksu. It should work now there. I also send a mail to kov to start a discussion about a new api that is based around argv string instead of a command string

Changed in gksu:
status: Confirmed → In Progress
Fabio Marzocca (thesaltydog) wrote :

I confirm it is working

Alessio Caiazza (nolith) wrote :

This bug still exists on feisty ppc ubuntu.

Tnx

Michael Vogt (mvo) wrote :

@Alessio Caiazza: what version of gksu/libgksu are you using?

On 3/6/07, Michael Vogt <email address hidden> wrote:
> @Alessio Caiazza: what version of gksu/libgksu are you using?
>

$ dpkg -l *gksu
Desiderato=sconosciUto/Installato/Rimosso/P:eliminato/H:bloccato
| Stato=Non/Installato/file Config./U:spacchett./conf. Fallita/H:inst.parzial.
|/ Err?=(nessuno)/H:bloc./necess.Reinst./X=entrambi (Stato,Err: maiusc.=grave)
||/ Nome Versione Descrizione
+++-==============-==============-============================================
ii gksu 2.0.0-1ubuntu3 graphical frontend to su

There's no libgksu installed by default in feisty.

Michael Vogt (mvo) wrote :

Sorry, I did not made myself clear. Please use
# dpkg -l libgksu2-o

to find the libgksu version.

Cheers,
 Michael

Fabio Marzocca (thesaltydog) wrote :

I confirm that everything is working here, Feisty, libgksu2-0 2.0.3-3ubuntu3 , it_IT environment.

Nicolò Chieffo (yelo3) wrote :

Sorry, I have 2.0.3-3ubuntu3 and it does not work. I started it from the commandline but I did not get any debug message.

Michael Vogt (mvo) wrote :

@Nicolo: So you still get the exact same behavior as before the libkgsu update? On clicking "Install" nothing happens and the list refreshes?

The bug is still present for me.
libgtksu is at version 2.0.3-3ubuntu5

kiscsiga (kiscsiga2000) wrote :

I also have the same problem.I have Feisty and my update-manager version is 1:0.59.21 , the synaptic version is: 0.57.11.1u Originally I have hu_HU.utf-8 locale settings. I changed the locale settings to en_GB.utf8, but unfortunately it didn't solve the problem. So maybe this problem is not related to the locale settings.

Nicolò Chieffo (yelo3) wrote :

what is the situation in gutsy? can we close this bug?

Yes, the bug is closed and the compiz worked. Thanks

> From: <email address hidden>> To: <email address hidden>> Date: Mon, 8 Oct 2007 17:25:39 +0000> Subject: [Bug 51419] Re: "Install updates"-button only refreshes update list in it_IT environement> > what is the situation in gutsy? can we close this bug?> > -- > "Install updates"-button only refreshes update list in it_IT environement> https://bugs.launchpad.net/bugs/51419> You received this bug notification because you are a bug contact for> gksu in ubuntu.
_________________________________________________________________
Scarica GRATIS le emoticon della tua squadra del cuore e il calendario di serie A!
http://www.emoticons-livemessenger.com/pages/msnitcalcio/index.htm

Works for me, you can close the bug.

kirth_gersen25 (kirth-gersen) wrote :

Sorry, it was an error, i can't a developer.
----------------------------------------> From: <email address hidden>> To: <email address hidden>> Date: Tue, 9 Oct 2007 05:54:28 +0000> Subject: [Bug 51419] Re: "Install updates"-button only refreshes update list in it_IT environement>> Works for me, you can close the bug.>> --> "Install updates"-button only refreshes update list in it_IT environement> https://bugs.launchpad.net/bugs/51419> You received this bug notification because you are a bug contact for> gksu in ubuntu.

_________________________________________________________________
Scarica GRATIS la versione personalizzata MSN di Internet Explorer 7!
http://optimizedie7.msn.com/default.aspx?mkt=it-it

Michael Vogt (mvo) wrote :

This should be fixed with the latest language-pack-it in edgy and the bug itself is fixed in feisty (and all later versions of ubuntu). Thanks for everybody who helped fixing it.

Thanks,
 Michael

Changed in gksu:
status: In Progress → Fix Released
Vincenzo Ciancia (vincenzo-ml) wrote :

Fix released everywhere :)

Changed in update-manager:
status: Confirmed → Fix Released
Mårten Woxberg (maxmc) wrote :

Hey guys!

This bug just appeared for me on Jaunty running Swedish.

Haven't been able to update using Synaptic or Update-manager since the last RC for Jaunty.

max@lillemor$ update-manager
/var/lib/python-support/python2.6/dbus/connection.py:242: DeprecationWarning: object.__init__() takes no parameters
  super(Connection, self).__init__(*args, **kwargs)

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers