nvidia not compatible with Xorg 7.1 RENDER (Fonts don't appear in edgy)

Bug #55802 reported by George Wright on 2006-08-09
32
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
Medium
linux-restricted-modules-2.6.17 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

When using the NVIDIA binary drivers ("nvidia") or the Xorg NVIDIA drivers ("nv") in Edgy Knot 1 fonts don't display at all in KDE unless anti-aliasing is turned on. Font corruption can also be seen in GNOME.

zdzichu (zdzichu-gmail) wrote :

This is bug in Cairo. It was fixes in cairo-1.2.2. I'm not sure if this version is available in Edgy.

Paul Sladen (sladen) wrote :

George: I believe you said that enabling 'antialiasing' provided a workaround, is this the case?

Changed in xorg:
status: Unconfirmed → Confirmed
George Wright (gwright) wrote :

I'm pretty sure I didn't have Cairo installed.

Yes - antialiasing was a workaround but not a very satisfactory one.

George Wright (gwright) on 2006-08-09
description: updated
Daniel Holbach (dholbach) wrote :

If this is indeed to be fixed by cairo 1.2.2, it'll be fixed by one of the next libcairo uploads. 1.2.2 is currently in consideration.

Changed in libcairo:
assignee: nobody → desktop-bugs
status: Confirmed → Fix Committed
George Wright (gwright) wrote :

It appears this is not due to libcairo, but binary incompatibilities with xorg 7.1.

More information at http://www.nvnews.net/vbulletin/showthread.php?t=72490 - subsection entitled "Any distribution with XOrg 7.1".

George, you're a KDE Developer IIRC, so you're probably not using Cairo/GNOME right?

George Wright (gwright) wrote :

Indeed - this is why I don't think it's a cairo problem. Cairo is fairly irrelevant as far as KDE is concerned.

Paul Sladen (sladen) wrote :

Okay, this probably isn't bug #52445, undup'ing for the moment.

Changed in libcairo:
status: Fix Committed → Needs Info
zdzichu (zdzichu-gmail) wrote :

Fix the "disappearing text" bug
-------------------------------
With cairo 1.2.0 many people reported that text would disappear from
applications, sometimes reappearing with mouse motion or
selection. The text would disappear after the first space in a string
of text. This bug was caused by an underlying bug in (very common) X
servers, and only affected text rendered without antialiasing, (either
a bitmap font or a vector font with antialiasing disabled). The bug
was also exacerbated by a KDE migration bug that caused antialiasing
to be disabled more than desired.

report: https://bugs.freedesktop.org/show_bug.cgi?id=7494
fix: http://gitweb.freedesktop.org/?p=cairo;a=commit;h=456cdb3058f3b416109a9600167cd8842300ae14
see also:
Xorg: https://bugs.freedesktop.org/show_bug.cgi?id=7681
KDE: http://qa.mandriva.com/show_bug.cgi?id=23990

Changed in xorg-server:
status: Unknown → Confirmed
Quim Calpe (quimcalpe) wrote :

I think George is right and it's a nvidia binary driver bug, not related with cairo.

Pasted from my Xorg.0.log:
.....................
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
 compiled for 4.0.2, module version = 1.0.8762
 Module class: X.Org Video Driver
(EE) ============= WARNING WARNING WARNING WARNING =============
(EE) This server has a video driver ABI version of 1.0 but this
(EE) driver is designed to work with versions before 1.0. The
(EE) driver will continue to load, but may behave strangely.
(EE) Please check http://www.nvidia.com/ for driver updates or
(EE) downgrade to an X server with a supported driver ABI.
(EE) ===========================================================
..................

hads (hads) wrote :

from the link posted by George Wright above:
> if you disable its RENDER acceleration with Option "RenderAccel" "0", but it is recommended
> that you use an older version of Xorg until support for Xorg 7.1 has been added to the NVIDIA
> X driver.

Adding Option "RenderAccel" "0" to xorg.conf, although a temporary fix, works for me at present.

LGB [Gábor Lénárt] (lgb) wrote :

I've got same problem on both of i386 and x64. Well, a very stupid question: how can I set font antialiasing on?

Vassilis Pandis (pandisv) wrote :

Bug 57013 may be related to this ...

Jiahua Huang (huangjiahua) wrote :

I found that it can be "fixed" by Xgl.
Fonts can display fine under Xgl, but no properly under Xorg7.1 .

Kyle Gordon (kylegordon) wrote :

I can confirm that Option "RenderAccel" "0" fixes this disappearing text problem in Xorg 7.0.22ubuntu7, with nvidia-glx 1.0.8762+2.6.17.2-1 and nvidia-kernel-common 20051028+1ubuntu4

Kyle

Chris Lord (cwiiis) wrote :

This option does *not* fix it for me, unfortunately :( Ubuntu edgy recent as of right now, Geforce 6800.

Jiahua Huang (huangjiahua) wrote :

NVIDIA binary drivers version 1.0-8774 outed.
http://www.nvidia.com/object/unix.html
http://www.nvidia.com/object/linux_display_ia32_1.0-8774.html
It said that:
    * Added support for X.Org 7.1.
    * Added support for XVideo with the Composite X extension when using X.Org 7.1.
    * Improved interaction with newer Linux kernels.

How about it?

Jens Fursund (dlai) wrote :

Yup the new drivers are out lets see them in edgy, please!

Changed in nvidia-kernel-common:
assignee: desktop-bugs → nobody
Quim Calpe (quimcalpe) wrote :

New Nvidia drivers (1.0.8774) just installed from edgy repos solved the problem ;-)

Bug closed then?

Rodrigo Novo (rodarvus) wrote :

This issue was fixed on the newest upload of linux-restricted-modules, which contains 'nvidia' closed-source driver compatible with X.Org 7.1.

Changed in nvidia-kernel-common:
importance: Untriaged → Medium
status: Needs Info → Fix Released
Faré (fahree) wrote :

The workaround proposed here works for me with nv 8774:
http://mandrivausers.org/index.php?showtopic=32900
disable the render acceleration with
Option "RenderAccel" "false" in the Device section.

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.