Vollstrecker does not use Launchpad. This page was created on 2008-01-27 when the amule_2.1.3+CVS20080121 package was uploaded to hardy/RELEASE.

Are you Vollstrecker?