Publishing details


libreoffice (1:4.0.0~alpha1-0ubuntu1~ppa1) quantal; urgency=low

  * testbuilding

libreoffice (1:4.0.0~alpha1+git20121121-1) UNRELEASED; urgency=low

  * new upstream snapshot
    - contains new driver for mozab (mork). Automatically enabled thus
      this closes: #321099

  * debian/
    - make -impress suggest bluez (for impress remote control)
    - make libreoffice depend on / -common recommend python-uno for the
      new python-based wizards
  * debian/rules:
    - disable langpacks for now; translations not yet updated causing
      weird stuff
    - add new conditionals for new dependencies: liblangtag, liborcus,
      libmspub, (u)cpp; remove them for gone saxon, librsvg, db
    - enable sdrmeote on all archs; b-d on libbluetooth-dev on where we
      enable bluetooth (!kfreebsd-*)
    - use gstreamer1.0
    - temporarily disable python3-uno as the new python-based wizards
      (in comon!) don't work with it...
  * debian/uno-libs3.symbols: update
  * debian/control*.in, debian/rules, debian/scripts/ binfilter
    is gone. yay.

libreoffice (1:3.6.4~rc1-1) experimental; urgency=low

  * new upstream release candidate

  * debian/patches/poppler_0_21_0.diff: fix build of sdext with poppler

  * merge from Ubuntu:
    - fix quoting of PYTHON_{CFLAGS,LIBS} (Matthias Klose)

  * debian/rules:
    - mention CVE-2012-4233 in 1:3.6.1~rc2-1's changelog
    - re-enable mozilla plugin
    - actually make python version-switching work
  * debian/
    - recommend fonts-liberation instead of ttf-liberation
      (closes: #691949)
  * debian/libreoffice-core.bug-control:
    - report-with: fonts-opensymbol instead of transitional ttf-opensymbol
  * debian/libreoffice-{core,gtk3}
    - find out whether we have Experimental features enabled

libreoffice (1:3.6.3~rc2-1) experimental; urgency=low

  * new upstream release candidate

  * debian/patches/soffice-bashisms.diff: fix bashism in soffice for
    valgrinding (closes: #690717)
  * debian/patches/he-lucida-sans-unicode.diff: Update default Hebrew font
    from Lucida Sans to Lucida Sans Unicode, thanks Lior Kaplan
  * debian/patches/ure-no-etc-opt-ure.diff: exclude /etc/opt/ure from ure
    search paths (closes: #677601)

  * debian/rules:
    - fix upstream README(_en-US) install for binary-indep packages
    - fix typo in finding gcj dir detection, thanks Rico Tzschichholz
    - don't add version from librsvg*.shlibs (as for libebook) as we
      dlopen() it anyway.

libreoffice (1:3.6.3~rc1-1) experimental; urgency=low

  * new upstream release candidate

  [ Rene Engelhard ]
  * debian/patches/sensible-lomua.diff: add patch from Dave Steele to
    make default to standard mailto handler (closes: #687228)

  * debian/rules:
    - try again with gcc 4.6 for mips* since apparently testtools/smoketest
      now work..
    - document truth and remove alpha from supported architectures
    - exclude .desktop from dh_link call to get absolute symlinks
      (closes: #690336)

  [ Bjoern Michaelsen ]
  * make metapackage explicit in short description

libreoffice (1:3.6.2~rc1-1) experimental; urgency=low

  * new upstream release candidate
    - waits for InternalIPC::ProcessingDone in oosplash (closes: #681185)

  * debian/patches/disable-flaky-unoapi-tests.diff: disable flaky
    toolkit and sc.ScAccessible* unoapi tests
  * debian/patches/gcj-safe-jni-h-include.diff: add missing -I...
  * debian/
    - make -core break libreoffice-common (<< 1:3.6.1~rc1) as "unopkg sync"
      ran in the triggers is gone (closes: #686666)
  * debian/rules:
    - fix native-jars dependeny to depend on install-common ...
    - ... but as this doesn't build then disable it for now...
    - hack around broken "*" directory in debian/tmp/pkg on kfreebsd-*
      extremely slowing down the install target...
    - use xz compression for all binary packages (closes: #687041)

libreoffice (1:3.6.1-1) experimental; urgency=low

  * LibreOffice 3.6.1 final release (identical to rc2)

  * debian/rules:
    - work around possible failure install-common target with missing
      ca-XV .dirs/.install...

libreoffice (1:3.6.2~rc2-0ubuntu4~ppa1) quantal; urgency=low

  * update to unitymenus patch Change-Id
    I56652b6074d0138128178b479503a21e0bcd0c7f (LP: #1064962)

libreoffice (1:3.6.2~rc2-0ubuntu3) quantal-proposed; urgency=high

  * packaging shouldnt try to move stuff it doesnt build on armel/armhf
 -- Bjoern Michaelsen <email address hidden>   Thu, 15 Nov 2012 00:35:15 +0100

Available diffs


Package files

No files published for this package.