GTK+3 with the Broadway (HTML5) backend

PPA description

This is a rebuild of the GTK+3 Ubuntu 12.04, 12.10, 13.04, 13.10, 14.04 and 14.10 packages with an enabled Broadway backend.

Note that this PPA is no longer necessary starting from Ubuntu 15.04, as the Broadway backend is now enabled by default. The main difference with this PPA is that the "broadwayd" binary is shipped in the "libgtk-3-bin" package when it was in a separated "broadwayd" package in the PPA.

ADDING THIS PPA TO YOUR SYSTEM
==============================

Run these commands in a terminal:

sudo add-apt-repository ppa:malizor/gtk-broadway
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install broadwayd # For Ubuntu >= 13.10

HOWTO SINCE SAUCY (gtk+ >= 3.8)
===============================

As an example, here is how to run gedit in your browser.

In a terminal, run:
broadwayd

In another terminal, run:
GDK_BACKEND=broadway UBUNTU_MENUPROXY= LIBOVERLAY_SCROLLBAR=0 gedit

Finally, open you Web browser and go to http://localhost:8080/

The "UBUNTU_MENUPROXY= LIBOVERLAY_SCROLLBAR=0" is only useful if you use the global-menu and/or overlay-scrollbars. You have to disable them for Broadway, otherwise the program will segfault.

Please see the "broadwayd" manpage for more information.

HOWTO BEFORE SAUCY (gtk+ < 3.8)
===============================

As an example, here is how to run gedit in your browser.

In a terminal, run:
GDK_BACKEND=broadway UBUNTU_MENUPROXY= LIBOVERLAY_SCROLLBAR=0 gedit

Finally, open you Web browser and go to http://localhost:8080/

The "UBUNTU_MENUPROXY= LIBOVERLAY_SCROLLBAR=0" is only useful if you use the global-menu and/or overlay-scrollbars. You have to disable them for Broadway, otherwise the program will segfault.

You can customize the port by setting the BROADWAY_DISPLAY variable.

DISCLAIMER
==========

I provide this PPA in the hope that it will be useful and I will try to upload new versions whenever the Ubuntu package is updated.
However, I do NOT guarantee that this PPA will always be stable and up-to-date nor that packages it contains may not destroy your computer, cause the end of the world and kill kittens.

Adding this PPA to your system

You can update your system with unsupported packages from this untrusted PPA by adding ppa:malizor/gtk-broadway to your system's Software Sources. (Read about installing)

Technical details about this PPA

This PPA can be added to your system manually by copying the lines below and adding them to your system's software sources.

Display sources.list entries for:
deb http://ppa.launchpad.net/malizor/gtk-broadway/ubuntu YOUR_UBUNTU_VERSION_HERE main 
deb-src http://ppa.launchpad.net/malizor/gtk-broadway/ubuntu YOUR_UBUNTU_VERSION_HERE main 
Signing key:
1024R/18015CCF (What is this?)
Fingerprint:
37450E53799BF6BEFF55A6DDF829E15318015CCF

For questions and bugs with software in this PPA please contact Nicolas Delvaux.

PPA statistics

Activity
0 updates added during the past month.
View package details

Overview of published packages

16 of 6 results
Package Version Uploaded by
gtk+3.0 3.12.2-0ubuntu15.3+broadway1 Nicolas Delvaux (2015-06-10)
gtk+3.0 3.10.8-0ubuntu1.5+broadway1 (Newer version available) Nicolas Delvaux (2015-06-10)
gtk+3.0 3.8.6-0ubuntu3.1+broadway2 Nicolas Delvaux (2013-12-11)
gtk+3.0 3.6.4-0ubuntu8+broadway1 Nicolas Delvaux (2013-04-30)
gtk+3.0 3.6.0-0ubuntu3.3+broadway1 Nicolas Delvaux (2012-12-10)
gtk+3.0 3.4.2-0ubuntu0.8+broadway1 Nicolas Delvaux (2014-03-30)
16 of 6 results

Latest updates

  • gtk+3.0 7 weeks ago
    Successfully built
  • gtk+3.0 7 weeks ago
    Successfully built
  • gtk+3.0 70 weeks ago
    Successfully built
  • gtk+3.0 85 weeks ago
    Successfully built
  • gtk+3.0 117 weeks ago
    Successfully built