Publishing details

Changelog

icu (63.2-2ubuntu0.1~ubuntu18.04.1~bionic1) bionic; urgency=medium

  * No-change backport to bionic

icu (63.2-2ubuntu0.1) eoan-security; urgency=medium

  * SECURITY UPDATE: Integer Overflow
    - debian/patches/CVE-2020-10531.patch: adds a int32_t overflow
      check when calculate a newLen in doReplace function in
      source/common/unistr.cpp and adding test to
      source/test/intltest/ustrtest.*.
    - CVE-2020-10531

icu (63.2-2) unstable; urgency=medium

  * Revert ICU-20250 (ICU 63 UnicodeSet startup performance regression) to
    fix ABI break (closes: #929474).

icu (63.2-1) experimental; urgency=medium

  * New upstream release with Japanese new era "Reiwa" support
    (closes: #927933).
  * Drop backported ICU-20246 and ICU-20208 fixes as no longer needed.
  * Break Chromium versions that not built with this ICU release.

icu (63.1-6) unstable; urgency=medium

  * Build without icu-config (closes: #898820).
  * Update Standards-Version to 4.3.0 .

icu (63.1-5) unstable; urgency=medium

  * Build without Paragraph Layout API.
  * Remove libiculx63 package, no longer needed (closes: #898571).

icu (63.1-4) unstable; urgency=medium

  * Build with Paragraph Layout API.

icu (63.1-3) unstable; urgency=high

  * Backport fix for ICU-20246: fixing another integer overflow in number
    parsing - fixes CVE-2018-18928 .
  * Backport fix for ICU-20208: uspoof.cpp function checkImpl() should be
    static, regenerate urename.h .
  * Build without Paragraph Layout API.
  * Upload to Sid.

icu (63.1-2) experimental; urgency=medium

  * Build with Paragraph Layout API.
  * Link with the -Wl,--as-needed flag.

icu (63.1-1) experimental; urgency=medium

  * New major upstream release.
  * Build without Paragraph Layout API.

icu (62.1-2) experimental; urgency=medium

  * Build with Paragraph Layout API.
  * Add break for OpenTTD.

  [ Matthias Klose <email address hidden> ]
  * Split Layout Engine shared library into a separate package, due to
    heavy dependencies, and breaking circular dependency
    (closes: #893801, #898571, #898806).

icu (62.1-1) experimental; urgency=medium

  * New major upstream release (closes: #907748).
  * Update Standards-Version to 4.2.1 .

  [ Helmut Grohne <email address hidden> ]
  * Fix FTCBFS: Build the native pass without libicu-le-hb-dev
    (closes: #906906).

icu (60.2-6) unstable; urgency=medium

  * Build with Paragraph Layout API.
  * Don't break OpenTTD anymore.
  * Remove multiarch of libicu-dev due to icu-config installed
    (closes: #898331).
  * Remove libstdc++-6-dev dependency on libicu-dev (closes: #892598).

icu (60.2-5) unstable; urgency=medium

  * Upload to Sid.
  * Break OpenTTD as this build is without Paragraph Layout API.

icu (60.2-4) experimental; urgency=medium

  * Install icu-config again.
  * Don't specify parallel to debhelper.
  * Update Standards-Version to 4.1.4 .

 -- Mikhail Novosyolov <email address hidden>  Mon, 23 Mar 2020 00:18:44 +0300

Available diffs

Builds

Built packages

Package files